If you still have a legacy card, try these.

Discussion in 'Videocards - AMD Radeon Drivers Section' started by kevsamiga1974, Nov 7, 2012.

  1. kevsamiga1974

    kevsamiga1974 Master Guru

    Messages:
    881
    Likes Received:
    0
    GPU:
    EVGA GTX 580 SC
    1. Not mainstream.
    2. Different set of bugs/issues to deal with compared to x64.
    3. Too much work to maintain multiple releases.
    4. Less memory available in virtual space for multi gb VRAM cards.
    5. I don't use it to test it to a standard that I would be satisfied with.

    However, I have done some limited testing with XP 32-bit drivers recently, I just don't have the time at the moment to do anything for x86 or x64 of any flavour. (moving home)

    What I can tell you is that skyrim (TESV) crashes badly with the last 13.1 XP 32-bit drivers, but there is a solution for the UltraHD 4K video crash. Won't have time to work on anything to do with drivers till moving home is completed.
     
    Last edited: Apr 5, 2013
  2. kevsamiga1974

    kevsamiga1974 Master Guru

    Messages:
    881
    Likes Received:
    0
    GPU:
    EVGA GTX 580 SC
    [​IMG]

    Some little bonuses for legacy peeps, and a trip back in time... :)

    I'm going to use this post to fix up some old releases that never worked right from the AMD camp beginning with Catalyst 10.8...

    History lesson.

    Catalyst 10.8 WHQL was known as a good driver along with 10.5a and 10.3a, but it was severely broken on 4870x2 maybe other crossfire setups as well, as was everything from 10.6 - 10.9a.

    The main issues at the time in 2010 were broken crossfire/half the performance.
    2nd core not engaging in games, and remaining in 2D or only 50% GPU utilisation on one of the cores.
    Clock's not returning to 2d idle from various DX9/DX10 3D games, even with the 10.8b/10.9a hotfixes issued to resolve the problems at the time. (which still had sticky clocks)

    Using my knowledge of component interoperability across versions *and* without introducing any instability, and how to fix up the modern drivers...

    I took a trip back in time and fixed all 10.8 WHQL's crossfire/clock problems, and present the driver as is here for anyone curious enough to try/use it on 4870x2 or for anything else for that matter as they see fit.

    Because for at least in the 4870x2's case, the drivers were completely broken from June 2010 to October 2010 on multi gpu setups inclusive.

    I didn't fix 10.6 or 10.7 (although it's entirely possible) due to the horrendous memory leak in borderlands after 10.5 (fixed by 10.8). Also the video components of 10.8 are still good (10.9 & 10.10 freeze flash) and still support VLC decoding.

    I have included 10.8a special CAP profiles (AvP & BFBC2 performance) and Stream SDK 2.2 (which is appropriate for 10.8 and works) and integrated AVIVO/Hydravision and everything into one 10.8 (working) package.

    It's an old, but nevertheless stable good driver (now fixed)

    Fixed Catalyst 10.8 - Windows Vista/7 x64.

    http://www.mediafire.com/?654u98cxbqht3m7
     
    Last edited: Apr 8, 2013
  3. iakoboss7

    iakoboss7 Active Member

    Messages:
    76
    Likes Received:
    6
    GPU:
    Sapphire RX 480
  4. kevsamiga1974

    kevsamiga1974 Master Guru

    Messages:
    881
    Likes Received:
    0
    GPU:
    EVGA GTX 580 SC
    Erm...well...House move in progress....I'm completely upside down atm and hence stuck, sorry. Any more work on drivers/fixing is on hold till things get sorted out in that department, as well as changing ISP and 1001 other things.

    However next up is a history fix for 10.9a (stuck clock on games exit which I'd already fixed in 10.8 WHQL above as well as poor GPU usage.). 10.6+10.7 are not really worth fixing because of bad bugs. Waste o' time.

    Complete package, everything included as well as 10.9 profiles. At least some of the drivers 10.5a<>10.10 are not fubared on 4870x2 cards now like they were before. :)

    Both drivers are untouched original drivers, except necessary changes to fix only the clock/gpu usage bugs for mainly 4870x2 rockers.

    There's quite a few downloads/interest of these old, but stable fixed up drivers for 4870x2, so I decided to fix up 10.9a while I was at it as well.

    So at least 10.8 WHQL and 10.9a now work how they're supposed to on 4870x2 after 2 years...they work fine with photoshop and webgl etc, next up is 11.1.

    [​IMG]

    10.9a hotfix fix - Vista/Win7 x64

    http://www.mediafire.com/?k51nid8e4i9aume

    If you want to run new games on these old drivers then some games might need renames to work @ good speed. Eg...

    Skyrim - (TESV.exe) needs rename to oblivion.exe
    F1 2012 - needs rename to bioshock.exe prior to Catalyst 11.9.

    Otherwise they're fine and stable left as they are.

    OpenGL components can't be changed out until at least 10.11, well not to anything newer anyway, which i'm going to do on an 11.1 improvement later on with support for modern stuff/games while still retaining the speed of 11.1 core+other fixups, fixing the dynamic contrast stripes/video components, and a properly working CCC amongst other shortcomings of older drivers.
     
    Last edited: Apr 18, 2013

  5. Thaddy

    Thaddy New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    Sapphire 4870X2
    Thanks!

    Hey Kev!

    I just updated to the R13's after removing the R11 UV's using ATI Man.

    So the system runs just fine but I'm still unable to access the Vision Engine Control Center, from any links on my computer. I click on the link and nothing happens ... looking into my "ACE Event Log" I get these errors:

    "Failed to merge manifest file: C:\Program Files\ATI Technologies\ATI.ACE\Fuel\Fuel.xml with exception: Could not find file 'C:\Program Files\ATI Technologies\ATI.ACE\Fuel\Fuel.xml'."

    "Failed to merge manifest file: C:\Program Files (x86)\ATI Technologies\ATI.ACE\MOM-InstallProxy\mom-installproxy.xml with exception: Could not find file 'C:\Program Files (x86)\ATI Technologies\ATI.ACE\MOM-InstallProxy\mom-installproxy.xml'."

    "Exception <GetType>: Method 'SubscribeToValueChangesEvent' in type 'ATI.ACE.CLI.Component.Runtime.Runtime' from assembly 'CLI.Component.Runtime, Version=3.5.4356.39827, Culture=neutral, PublicKeyToken=90ba9c70f846762e' does not have an implementation."

    "Could not find Type [ATI.ACE.CLI.Component.Runtime.Runtime] from [CLI.Component.Runtime] in assembly [CLI.Component.Runtime, Version=3.5.4356.39827, Culture=neutral, PublicKeyToken=90ba9c70f846762e]"

    Any insight would be greatly appreciated. For the record I was having the same issue with the the R10's and R11's also. I did a clean format when I installed the R11's, this time around I just used ATI Man to uninstall the old drivers.

    Cheers, :cheers:
    -Thad
     
    Last edited: Apr 23, 2013
  6. vlc_marcos

    vlc_marcos Member

    Messages:
    22
    Likes Received:
    0
    GPU:
    asus 8800gt/ hd M 4650
    i have a question, i would like to know if you cannot do anything with the new drivres, and 10.2 and 10.3.
     
  7. Thaddy

    Thaddy New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    Sapphire 4870X2
    I know you're done working on these and I'm super grateful for all the work you've done!

    Last ditch effort all the same, do you have any ideas for what could be causing my errors when trying to load up the CCC?

    Re-post:


    "I just updated to the R13's after removing the R11 UV's using ATI Man.

    So the system runs just fine but I'm still unable to access the Vision Engine Control Center, from any links on my computer. I click on the link and nothing happens ... looking into my "ACE Event Log" I get these errors:

    "Failed to merge manifest file: C:\Program Files\ATI Technologies\ATI.ACE\Fuel\Fuel.xml with exception: Could not find file 'C:\Program Files\ATI Technologies\ATI.ACE\Fuel\Fuel.xml'."

    "Failed to merge manifest file: C:\Program Files (x86)\ATI Technologies\ATI.ACE\MOM-InstallProxy\mom-installproxy.xml with exception: Could not find file 'C:\Program Files (x86)\ATI Technologies\ATI.ACE\MOM-InstallProxy\mom-installproxy.xml'."

    "Exception <GetType>: Method 'SubscribeToValueChangesEvent' in type 'ATI.ACE.CLI.Component.Runtime.Runtime' from assembly 'CLI.Component.Runtime, Version=3.5.4356.39827, Culture=neutral, PublicKeyToken=90ba9c70f846762e' does not have an implementation."

    "Could not find Type [ATI.ACE.CLI.Component.Runtime.Runtime] from [CLI.Component.Runtime] in assembly [CLI.Component.Runtime, Version=3.5.4356.39827, Culture=neutral, PublicKeyToken=90ba9c70f846762e]"

    Any insight would be greatly appreciated. For the record I was having the same issue with the the R10's and R11's also. I did a clean format when I installed the R11's, this time around I just used ATI Man to uninstall the old drivers."

    Thanks for taking a look and if you don't have the time or patience to look into it just let me know!

    Thanks again for all the work you've put into these!
    -Thad
     
  8. liquidfox12

    liquidfox12 Member

    Messages:
    38
    Likes Received:
    0
    GPU:
    ati x1400
    Hello thanks for supporting legacy cards , can anyone confirm this will work for ati mobility x1400 ?
     
  9. iakoboss7

    iakoboss7 Active Member

    Messages:
    76
    Likes Received:
    6
    GPU:
    Sapphire RX 480
    hey found a new problem, you can read about it here from other user/users

    http://forums.ppsspp.org/showthread.php?tid=4279

    amd drivers crashes after some minutes of gameplay in the emulator (using latest version of the emu doesnt fix this), i am using your latest version installed after format and never installed/uninstalled them at all!

    if it matters i am playing kingdom hearts birth by sleep final mix eng translation 1.0.12

    some more info on the bottom of the 1st post here http://forums.ppsspp.org/showthread.php?tid=4383

    installing driver version 11.11a seems to solve the problem for most of them, can you look into it? like what is changed etc? cause i would like to use your driver as i have for all this time now :)

    more threads with this problem for ppsspp emu https://www.google.com/search?q=ppsspp+crashes+amd+driver+site:forums.ppsspp.org&newwindow=1

    if you need any info/logs etc tell me :)
     
    Last edited: Sep 6, 2013
  10. kevsamiga1974

    kevsamiga1974 Master Guru

    Messages:
    881
    Likes Received:
    0
    GPU:
    EVGA GTX 580 SC
    Unfortunately my interest in this project has waned due to a combination of factors, which included moving home, and having such a poor ISP service in these parts compared to what I was used to using before, and having to resort to mobile broadband just to get any working connectivity at all, where the charges are hyper expensive, and the data caps charged by the MB are a complete joke.

    I therefore find myself in an unfortunate situation that I no longer either have the time, nor any inclination to upload on a heavily capped mobile broadband connection.

    If it's any consolation, there isn't much more to be had out of the drivers for legacy cards, and there hasn't been for years so hacking and patching is on the whole a contrivance and a complete waste of time unless your interested in fixing one bug and re-introducing another.

    AMD has a policy of only seeming to be concentrating on the current flavour of the month gfx cards, and moving right along when they are no longer profitable to support or it suits their retirement policies on the driver front.

    So in that case there hasn't been anything new of substance to work with since April 2012, and the likelihood is, there isn't likely to be.

    Thanks to everybody for all the support and feedback over the months, but it's impossible to cater for all tastes with what is left available. I'll still keep on the forum from time to time, but there won't be any more stuff from me, sorry.

    :)
     

  11. iakoboss7

    iakoboss7 Active Member

    Messages:
    76
    Likes Received:
    6
    GPU:
    Sapphire RX 480
    totally understandable :) and thank you very much for your contribution! it really helped allot of people!!

    good luck with whatever you do in your life! :)
     
  12. Strykaar

    Strykaar Member

    Messages:
    32
    Likes Received:
    0
    GPU:
    Sapphire 4870x2 2GB
    I understand as well. I believe you've done more than your fair share Kev and I wish you the best in your future endeavors. Thank you.
     
  13. Joe 69

    Joe 69 Master Guru

    Messages:
    213
    Likes Received:
    0
    GPU:
    Sapphire HD4850 1GB
    Thanks for all and good luck for what you are doing now....Hope things going good in your life and God bless you for the future.
    Keep in touch :)
     
  14. Thunderbolt8

    Thunderbolt8 Active Member

    Messages:
    77
    Likes Received:
    0
    GPU:
    Geforce GTX 760M
    kevsamiga1974, I would like to try your hybrid 11.12 as described in the OP, but the mediafire link is down. can you please post a new working link?
    thanks!

    p.s. that driver does work with legacy mobility cards as well, does it? got a mobility radeon 4850
     
    Last edited: Sep 11, 2013
  15. neock

    neock New Member

    Messages:
    9
    Likes Received:
    0
    GPU:
    AMD Radeon HD 3870 X2
    do u still have the driver ? i wanted to download , but links are down
     

  16. Miroglu

    Miroglu Active Member

    Messages:
    66
    Likes Received:
    0
    GPU:
    ATI Radeon HD 4350 512 MB
  17. godknowswhy

    godknowswhy Member Guru

    Messages:
    132
    Likes Received:
    1
    GPU:
    All sorts

Share This Page