Idle Random Reboot Solution

Discussion in 'Videocards - AMD Radeon Drivers Section' started by spekgat7, Jun 16, 2014.

  1. spekgat7

    spekgat7 Member

    Messages:
    38
    Likes Received:
    0
    GPU:
    Gigabyte 7950
    With some Catalyst drivers (v14.4 and v14.6 Beta and some earlier ones) my PC would randomly reboot if it was left at idle for some time.

    My PC is a highly automated barebones Win7 x64 SP1 system, so I suspect the problem might stem from that, as I don't see others complaining about the same issue.

    Anyway, if someone does have the problem, I solved it as follows, but note that I tested this only in Win7 x64 SP1, so I have no idea about other OS versions. And why it works I don't know, perhaps it's something specific to the hardware of my Gigabyte HD-7950 model.

    Solution:

    (1) Disable ULPS (even if you do NOT use XFire i.e. for a single card too).

    (2) Set the Windows "Turn Off Display After" setting to "Never" (Control Panel > Power Options > Change Plan Settings > Change advanced power settings > Display) (i.e. disable monitor suspend). I always physically turn my monitor on/off so the fact that Windows will no longer suspend the monitor is not a problem for me.


    I wrote a small EXE program to enable/disable both of the above. PM me if you want to try it. I don't post it here, as it was tested only in Win7 x64 SP1. And you have to be an Administrator to use it, as it changes the registry.


    HOW TO MANUALLY DISABLE ULPS:

    (1) Change all instances of "EnableULPS" found under these two registry keys to 0 (zero):
    - HKLM\System\CurrentControlSet\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}
    - HKLM\System\CurrentControlSet\services\amdkmdag
    (2) Reboot the PC

    Note: The "EnableULPS" setting also exists in "HKLM\System\CurrentControlSet\Control\Video", but the above will automatically change them too.
     
  2. DM789

    DM789 Master Guru

    Messages:
    435
    Likes Received:
    0
    GPU:
    ???
    never had random reboot with 14.4, but i did not use 14.6 for long, because of the artifacting bug it had, so i don't know about 14.6,

    and i also often left my pc idle for quite a while.
     

Share This Page