How to set constant gpu clock?

Discussion in 'Videocards - AMD Radeon Drivers Section' started by spectatorx, Nov 25, 2015.

  1. spectatorx

    spectatorx Master Guru

    Messages:
    740
    Likes Received:
    97
    GPU:
    Radeon RX580 8GB
    I'm testing some things in various games and for ac3 i want to force constant clock on my r9 380. In game gpu clock is much lower than it should be. I already did put power limit to +20 but it doesn't make clock constant and card sits in game on clocks in range 400-600MHz.
    How could i force constant 990MHz clock for this game?
     
  2. sammarbella

    sammarbella Ancient Guru

    Messages:
    3,931
    Likes Received:
    178
    GPU:
    290X Lightning CFX (H2O)
    AB.

    Set and use a 3D profile while gaming.

    Set power limit to +50, it's not going to destroy your GPU.

    It doesn't mean it will be always at +50 usage but it will have the option to do it if needed.

    Force constant voltage as LAST resort.
     
  3. spectatorx

    spectatorx Master Guru

    Messages:
    740
    Likes Received:
    97
    GPU:
    Radeon RX580 8GB
    Probably this game is total wreck and that's why it can't work with full gpu clock speed on my gpu. Every time i change gpu to newer one i always hope for it to make it work flawlessly but no, it always has to be working like a pile of poo.

    I did set the profile in radeon software, also i created a profile in afterburner and in both cases the same thing: gpu clock fluctuates in range 400-600MHz with some deviations from it to lower or upper, fps is around 30, probably caused by low clocks.

    In all other games gpu clock is fine but in ac3 not.
     
  4. LIGuitar77

    LIGuitar77 Master Guru

    Messages:
    599
    Likes Received:
    37
    GPU:
    ASUS 7790 2GB OC
    ASUS GPU Tweak II can do it. Advanced screen, top left.

    Problem for me is that it is flaky (the whole software) in its operations. Sometimes it works well, but more often than not, it won't even flash the screen like it does and apply clocks you set. This is on my 7790 and I do believe the experience varies by card.

    GPU Tweak (1st version) 2.8.2.0 is perfectly stable for me but it does not have that option you want.

    http://www.asus.com/Graphics-Cards/HD7790DC2OC2GD5/HelpDesk_Download/
     

  5. norton

    norton Member Guru

    Messages:
    195
    Likes Received:
    49
    GPU:
    GTX970 G1 Gaming
    AC3 is a single threaded game and it depends on the single core performance (Bad PC port) and your CPU's single core performance is low and the result your CPU can't keep up with your GPU (in this game) so that your GPU can't keep steady 3D clock
    in this Pic you can see what i mean
    [​IMG]
     
  6. Pinky Floyd

    Pinky Floyd Member

    Messages:
    36
    Likes Received:
    0
    GPU:
    Fury Nitro
    For info, I tried an AB 3D profile on my r9 390 and it made no difference. The power setting was reflected in Crimson Overdrive but the clocks remained as bouncy as a rubber ball.

    I also think its a power saving feature gone wrong or if its functioning as designed (God forbid) then at least give us an option to turn it off.
     
  7. biggyca

    biggyca Master Guru

    Messages:
    352
    Likes Received:
    0
    GPU:
    GTX 980 GALAX
  8. spectatorx

    spectatorx Master Guru

    Messages:
    740
    Likes Received:
    97
    GPU:
    Radeon RX580 8GB
    @LIGuitar77, yes, asus gpu tweak software worked like a charm, that's what i needed.
    @norton, hm.. i would say yes and no. Forcing stable gpu clock made 0 difference in framerate. I doubt that game is really single threaded as it utilizes all 8 cores of my fx-8320.

    BTW, i'm using windows 10 x64 enterprise.

    @Pinky Floyd, try asus gpu tweak.
    @biggyca, i think your minor fluctuations are not influencing gameplay, framerate so it is fine, imo.
     
  9. LeBron23cavs

    LeBron23cavs Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    MSI R9 390X Gaming 8G
    I'm having serious issues with 390x core clocks after crimson installed. I tried to force constant core clocks in AB settings (without powerplay), but after that, my pc would hold MAX core clocks and mem clocks all the time, not just in games. I'll try asus gpu tweak, thx for that. But seriously, I hope there will be some hotfix or something, because I can't play any fking game. Fifa 16, clocks bouncing from 400 to 600 MHz stuttering in replays. Nba 2K16 600 to 800 MHz stuttering whole the time. The witcher 950 to 1100 MHz stuttering. I need constant core clocks in those games. I tried the thing in afterburner, I talked about, and played these games with 1100/1525 as it should be. No stuttering at all. Why they won't let me to decide if I don't want to save consumption. I hate crimson update and hope for fix soon.
     
  10. sammarbella

    sammarbella Ancient Guru

    Messages:
    3,931
    Likes Received:
    178
    GPU:
    290X Lightning CFX (H2O)
    AMD is getting better at been "green" what is a contradiction from the "red" GPU brand. :D

    They improved their power consumption at the expense of gameplay and multimedia stability lowering clocks at any moment the driver "thinks" it can do it.

    AMD FORCE or try to force this lower consumption to be active always.

    This is not a good move IMHO for hardware dedicated to play games.
     

  11. LeBron23cavs

    LeBron23cavs Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    MSI R9 390X Gaming 8G
    Exactly. 100% True.
     
  12. RexOmnipotentus

    RexOmnipotentus Master Guru

    Messages:
    796
    Likes Received:
    4
    GPU:
    Vega 64
    I bet that powerplay is also the cause for the fluctuating core clocks with FreeSync enabled. It's just not funny that it sometimes cut your framerate in half.
     
  13. sammarbella

    sammarbella Ancient Guru

    Messages:
    3,931
    Likes Received:
    178
    GPU:
    290X Lightning CFX (H2O)
    I think so.

    Things are getting worst with Crimson and AMD "low power crazyness" it seems Fury (X) are now "inmune" to the options we have (until now) to disable powerplay.

    They want to erase the high power usage stigma at all cost instead to erase the low performance stigma at all cost!

    Bad move..again

    :(
     
  14. RexOmnipotentus

    RexOmnipotentus Master Guru

    Messages:
    796
    Likes Received:
    4
    GPU:
    Vega 64
    Then they should make hardware that uses less power. If someone wants to use the full power of the GPU, then let them. If i want my card to consume less power, i simply use a framelimiter or Vsync. Automatically downclocking my cores to unplayable levels is just annoying. I'm happy the afterburner exist or else i would have had a very bad time with my FreeSync monitor.
     
  15. Pinky Floyd

    Pinky Floyd Member

    Messages:
    36
    Likes Received:
    0
    GPU:
    Fury Nitro
    As spectatorx said, GPU Tweak does indeed allow you to lock the clocks and it's so easy. Just click 'Always 3D clock'. My Fallout 4 is now far less stuttery. Amazing how much these jumping clocks is detrimental to the gameplay experience. Here's a screen of the setting you need.

    [​IMG]
     

  16. RexOmnipotentus

    RexOmnipotentus Master Guru

    Messages:
    796
    Likes Received:
    4
    GPU:
    Vega 64
    Doesn't that mean that your clocks will be maxed out. Even if you are not running a game?

    Does anyone know if it is a good idea to run maximum clocks all the time? What about power usage? Does it increase alot? Are there any other drawbacks?
     
  17. LeBron23cavs

    LeBron23cavs Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    MSI R9 390X Gaming 8G
    Exactly my point. You can do same thing in MSI Afterburner, just select without powerplay and your clocks will by maxed all the time. But I don't want this all the time, just when I'm gaming. In AB after change of this powerplay setting, my computer must restart, so it's not really sweet. Is this better? Can you just click and it instantly maxed clocks and after you turn off game, can you just click one more and all clocks will be normal again? Thanks for answer :).
     
  18. Pinky Floyd

    Pinky Floyd Member

    Messages:
    36
    Likes Received:
    0
    GPU:
    Fury Nitro
    No, that icon I circled is a button. Just click it to toggle the 'always on 3d clock' on or off.
     
  19. Pinky Floyd

    Pinky Floyd Member

    Messages:
    36
    Likes Received:
    0
    GPU:
    Fury Nitro
    Yes, the button is just a toggle so you can click it to turn it on and off. I have only tested for 20 mins or so but there is no setup involved and it just seems to work.
     
  20. sammarbella

    sammarbella Ancient Guru

    Messages:
    3,931
    Likes Received:
    178
    GPU:
    290X Lightning CFX (H2O)
    Check RadeonPro, i think it has an option per game for that.

    If i remember correctly.
     

Share This Page