How To Properly Update your P55/X58 mobo under Windows 7 (Guide)

Discussion in 'Processors and motherboards Intel' started by Year, Aug 4, 2010.

  1. TheHunter

    TheHunter Banned

    Messages:
    13,408
    Likes Received:
    1
    GPU:
    MSi N570GTX TFIII [OC|PE]
    ^
    yea LPC driver impact is minimal but its there,.. maybe you dont have it, best to test with everest memory bandwidth (i had around 20-50mb/s less and 0.5ns higher latency with intel LPC driver).
     
  2. Abilio_KID

    Abilio_KID Master Guru

    Messages:
    644
    Likes Received:
    1
    GPU:
    MSI 1070 Armor OC
    Guys, I followed this topic and updated my chipset drivers. However I now seem to have a strange problem. My system turned itself off after the CPU went too high playing some game. Altough it's usual to be hot here, this is the first time such thing happens.
    A couple minutes ago I did a CPU stability test in Everest and noticed when CPU is 100% in use, temperatures start getting high but the CPU fan speed remains the same (doesn't spin faster to compensate the high temps). I know the fan is working properly because it was at full speed after system went down.
    Could this be related to the chipset driver update?
     
  3. fagoatse

    fagoatse Member Guru

    Messages:
    140
    Likes Received:
    0
    GPU:
    nvidia
    Doesn't work with the latest chipset drivers.
     
  4. TheHunter

    TheHunter Banned

    Messages:
    13,408
    Likes Received:
    1
    GPU:
    MSi N570GTX TFIII [OC|PE]
    you need to pinpoint ALL folder instead of WIN7 and it will update..
     

  5. fagoatse

    fagoatse Member Guru

    Messages:
    140
    Likes Received:
    0
    GPU:
    nvidia
    The problem is that the drivers come with an installer now : / (talking about 9.1.2.1007)
     
  6. TheHunter

    TheHunter Banned

    Messages:
    13,408
    Likes Received:
    1
    GPU:
    MSi N570GTX TFIII [OC|PE]
    try that link Year posted, its extracted and it contains all the stuff you need, this new 9.1.2.1007 won't change anything because its targeted at the newest chipsets (only main inf will be at 9.1.2.1007)... like i said chose ALL folder from that installer and it will update the rest., most of your stuff is dated around 2008-2009 so yea no worries.
     
  7. Indeo

    Indeo Ancient Guru

    Messages:
    1,552
    Likes Received:
    0
    GPU:
    XFX 5970@950\1200 + GT240
    All I needed for a proper install was -overall with no Vista SP2 compatibility setting. No changes in performance\stability spotted.
     
  8. Apparatus

    Apparatus Master Guru

    Messages:
    374
    Likes Received:
    38
    GPU:
    Aorus 1080 ti
    Thanks for the guide!
    I followed the procedure and i got my drivers properly updated.

    A new version of chipset drivers was released by intel.
    Do we have to repeat the procedure or intel fixed things ?
    Anybody tried them ?
     
  9. MerolaC

    MerolaC Ancient Guru

    Messages:
    3,475
    Likes Received:
    325
    GPU:
    MSI 5600XT G. MX
    Most likely they added a BETA driver for a newer chip.
    That what they ALWAYS do when they release a new pack.
    And you will still need the SP2 and Overall thing.
     
  10. Altazimuth

    Altazimuth Maha Guru

    Messages:
    1,307
    Likes Received:
    2
    GPU:
    Sapphire Vapor-X 5870
    Manual Install

    To extract the files for a manual install, you don't need to do all that "-a at the end", "shortcut", "temp folder" carry on if you have 7-zip installed. Just right-click on the exe -> 7-zip -> extract files ..... and the 'INF_allOS_9.1.2.1008_PV' folder will appear in the same place as the exe. Simples!

    I don't think I'll try this though because all mine say 2009-2010.
     

  11. Altazimuth

    Altazimuth Maha Guru

    Messages:
    1,307
    Likes Received:
    2
    GPU:
    Sapphire Vapor-X 5870
    Well I did try it.

    These drivers extract to "C:\Program Files (x86)\Intel\InfInst" with the -a option (7-zip will extract EVERYTHING, including the Setup.exe)



    I was the same for me. I had to manually update them by pointing it to the 'all' folder (yet it says in the readme this folder is for win 2000, win XP etc - not win 7? Weird).

    The Device Drivers now say 2009-2010.

    I have yet to test for any improvements or whatever, but it just shows you, it's still a problem even with the latest drivers.
     
  12. FDisk

    FDisk Master Guru

    Messages:
    766
    Likes Received:
    0
    GPU:
    ASUS STRIX GTX970 OC 4GB
    Thank you, all updated. How the hell did I found out about this just now?
     
  13. ubermann

    ubermann Master Guru

    Messages:
    300
    Likes Received:
    0
    GPU:
    8800GTS vmem+vgpu Mod
    i always use -overall and -override on intel chipset drivers.
     
  14. Altazimuth

    Altazimuth Maha Guru

    Messages:
    1,307
    Likes Received:
    2
    GPU:
    Sapphire Vapor-X 5870

    Well, it's actually "-overide" ("-override" doesn't work!) and this FORCES a reinstall of all the drivers whether they are already installed or not.

    But it still doesn't update the 7 drivers I was talking about in my previous post (for me, anyway).

    You have to do it manually.

    In Windows XP, all the drivers are installed, so it must be a Windows 7 problem.
     
  15. MadPerson

    MadPerson Master Guru

    Messages:
    205
    Likes Received:
    0
    GPU:
    Zotac 9600GT 512MB
    I tried this and with the overall command and the installer disappear how do I know when it complete.

    So I am going to update the staff manually do I only update the stuff that have Intel(R) next to it.
     

  16. FDisk

    FDisk Master Guru

    Messages:
    766
    Likes Received:
    0
    GPU:
    ASUS STRIX GTX970 OC 4GB
    I had the same bug, just run it again and don't forget to set compatibility to Vista SP2.
     
  17. MadPerson

    MadPerson Master Guru

    Messages:
    205
    Likes Received:
    0
    GPU:
    Zotac 9600GT 512MB
    I haven't re-run the exe yet but when I do this "allOS_9.1.2.1007_PV.exe -Overall" on the shortcut target I get a file name error.
     
  18. TheHunter

    TheHunter Banned

    Messages:
    13,408
    Likes Received:
    1
    GPU:
    MSi N570GTX TFIII [OC|PE]
    no need for compatibility mode or overall, just download the latest official from here
    http://www.station-drivers.com/page/intel chipset.htm
    Version 9.1.2.1008 WHQL

    extract and use ALL or win7 folder., i had to use ALL folder.

    First install it normally, then update each intel part manually and pinpoint to this ALL folder while you're doing it, 2 or 3 might not update, that's ok..
     
  19. MadPerson

    MadPerson Master Guru

    Messages:
    205
    Likes Received:
    0
    GPU:
    Zotac 9600GT 512MB
    I installed the 9.1.2.1009 Beta I havent had any problems but how do I remove it so I can install the 9.1.2.1008 WHQL version.
     
  20. MadPerson

    MadPerson Master Guru

    Messages:
    205
    Likes Received:
    0
    GPU:
    Zotac 9600GT 512MB
    I noticed yesterday that some nvidia chipset drivers got install on my Intel mobo some how. And I have only run the Intel drivers posted here.
     

Share This Page