How to get proper SLI scaling in Far Cry 3. (DX11 mode)

Discussion in 'Games, Gaming & Game-demos' started by drac, Nov 28, 2012.

  1. drac

    drac Ancient Guru

    Messages:
    1,604
    Likes Received:
    3
    GPU:
    MSI Gaming X GTX1080 8GB
    Just thought I'd make a quick post to explain how to do this, because my 2nd GPU was only at 20% in DX11 mode without making this adjustment.

    Just use Nvidia Inspector, find Far Cry 3 profile, click Add application to current profile and add farcry3_d3d11.exe from Far Cry 3/Bin. Poof 99% both GPU. :eek:

    This happens for me with 310.61 and 310.64 drivers, not sure about others.
     
  2. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    15,030
    Likes Received:
    19
    GPU:
    EVGA GTX 1080 Ti SC2
    Thanks for that drac.

    Looks like NVIDIA either forgot to add the DX11 executable or Ubisoft changed the filename prior to release. I have farcry3.exe and fc3launch_pc_r.exe in my profile from the v310.64 beta drivers.
     
  3. darrensimmons

    darrensimmons Maha Guru

    Messages:
    1,416
    Likes Received:
    1
    GPU:
    1080TI SLI 2100MHZ
    Thanks for the info. What frames are you getting in SLI now?
     
  4. Placebo_Tony

    Placebo_Tony Master Guru

    Messages:
    209
    Likes Received:
    0
    GPU:
    EVGA GTX 1080 SC

  5. darrensimmons

    darrensimmons Maha Guru

    Messages:
    1,416
    Likes Received:
    1
    GPU:
    1080TI SLI 2100MHZ
  6. Placebo_Tony

    Placebo_Tony Master Guru

    Messages:
    209
    Likes Received:
    0
    GPU:
    EVGA GTX 1080 SC
    Yes, without what's written above sli doesn't work and the problem disappears...
    And yea it happens in dx9 also.:puke2:
     
  7. darrensimmons

    darrensimmons Maha Guru

    Messages:
    1,416
    Likes Received:
    1
    GPU:
    1080TI SLI 2100MHZ
    Try turning all option to as low as they will go. If it stops happening it must be one of the settings, perhaps decals?Then turn each one up until you find the culprit, worth a try?
     
  8. Placebo_Tony

    Placebo_Tony Master Guru

    Messages:
    209
    Likes Received:
    0
    GPU:
    EVGA GTX 1080 SC
    Did just that, nothing worked... Sli is causing this, can't figure out why:bang:
    reinstalled the new beta drivers, reinstalling the game right now.
     
  9. johnyz333

    johnyz333 Active Member

    Messages:
    56
    Likes Received:
    0
    GPU:
    Inno3d 8800GTS 512 x2
    Sli scaling is messed up at the moment, nvidia is working on a fix as we speak.
     
  10. MaLDo

    MaLDo Master Guru

    Messages:
    536
    Likes Received:
    0
    GPU:
    GTX1080

    Try this

    open farcry 3 profile with inspector, and change SLI bits for DX11

    0x000902F5 to 0x0C1902F5



    Edited value, before was wrong.
     
    Last edited: Nov 28, 2012

  11. darrensimmons

    darrensimmons Maha Guru

    Messages:
    1,416
    Likes Received:
    1
    GPU:
    1080TI SLI 2100MHZ
    Can anyone confirm if this works, did it work for you MaLDo?
     
  12. MaLDo

    MaLDo Master Guru

    Messages:
    536
    Likes Received:
    0
    GPU:
    GTX1080
    Yes, is the first thing I did. But look again because I posted the wrong value before, now is fine.
     
  13. darrensimmons

    darrensimmons Maha Guru

    Messages:
    1,416
    Likes Received:
    1
    GPU:
    1080TI SLI 2100MHZ
    Thanks MaLDo. this is great news for sli owners:)
     
  14. darrensimmons

    darrensimmons Maha Guru

    Messages:
    1,416
    Likes Received:
    1
    GPU:
    1080TI SLI 2100MHZ
    Ok, my inspector does not have dx11 sli compat bits, just dx10??
     
  15. MaLDo

    MaLDo Master Guru

    Messages:
    536
    Likes Received:
    0
    GPU:
    GTX1080
    Is the same.
     

  16. darrensimmons

    darrensimmons Maha Guru

    Messages:
    1,416
    Likes Received:
    1
    GPU:
    1080TI SLI 2100MHZ
    Great, thanks again
     
  17. TK423

    TK423 Active Member

    Messages:
    62
    Likes Received:
    0
    GPU:
    GeForce GTX 980
    'll apologize in advance for my lack of knowledge.

    I don't know much when it comes to GPUS but I've got two GTX 580s running in SLI and like many Far Cry 3 is running very poorly.

    I downloaded Nvidia Inspector (I had never heard of the program before tonight) but unfortunately have no idea how to use it or apply the fixes described in this forum.

    I did a bit of poking around via Google but I'm still not quite sure how to enact the fixes (adding the farcry3_d3d11.exe to Nvidia Inspector, etc.) listed above.

    Would anyone would be kind enough to guide a new comer to GPU tweaking and SLI on how to use Nvidia Inspector to fix the Far Cry 3 issue?

    Sincere thanks.
     
  18. drac

    drac Ancient Guru

    Messages:
    1,604
    Likes Received:
    3
    GPU:
    MSI Gaming X GTX1080 8GB
    No problem!
     
    Last edited: Nov 29, 2012
  19. drac

    drac Ancient Guru

    Messages:
    1,604
    Likes Received:
    3
    GPU:
    MSI Gaming X GTX1080 8GB

    Not sure how to explain it much better than I have already, but ill try :)

    1)Install nv inspector

    2)Load it up and click the little profile settings button (looks like a wrench and screwdriver)

    3)Top left is the list of game profiles, scroll down to find Far Cry 3, select it.
    Now look at the list of buttons at the top middle, find the one that says "Add application to current profile", select that.

    4)Find farcry3_d3d11.exe, usually in C:\Program Files (x86)\Steam\steamapps\common\Far Cry 3\bin

    5)Also as Maldo said, change SLI compatibility bits for DX11 to 0x0C1902F5

    6)Now click Apply changes, top right.

    7)All done, play the game :)
     
  20. drac

    drac Ancient Guru

    Messages:
    1,604
    Likes Received:
    3
    GPU:
    MSI Gaming X GTX1080 8GB
    Not sure, haven't tested it, but it instantly looked a lot smoother. :hatty:
     

Share This Page