1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to disable dithering in Linux?

Discussion in 'Videocards - AMD Radeon Drivers Section' started by d06pbiu, Mar 11, 2014.

  1. d06pbiu

    d06pbiu New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    AMD Radeon HD 7970
    Hello!
    I use Scientific Linux 6.3 x86_64, AMD Catalyst 13.12 driver and Radeon HD 7970 graphic card.
    What should I do to disable dithering?

    Thanks.
     
  2. d06pbiu

    d06pbiu New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    AMD Radeon HD 7970
    For nvidia cards it's disabled this way:
    Open ““/etc/X11/xorg.conf”” and add the lines in Bold:

    Section “Screen”
    Identifier ...
    Device ...

    Option “Dac8Bit” “False”
    Option “RegistryDwords” “DitherAlgo8=3; DitherAlgo6=3”

    EndSection

    For nvidia it works!

    If I use the same options for ati card - it doesn't work, in log file I see messages (WW) like these "Option 'Dac8Bit'|'RegistryDwords' is not used"...
     
  3. Espionage724

    Espionage724 Guest

  4. d06pbiu

    d06pbiu New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    AMD Radeon HD 7970
    Thanks for your reply.

    Some info about dithering:
    "If temporal dithering is enabled on your graphics card, it may force even static images to be dynamic to emulate a color that is not available in its color palette. Temporal dithering does this by constantly switching between two nearby colors very quickly on pixels on the image. The alternating between the two colors is fast and most people should only see one color, instead of two rapidly changing colors."

    I'm using PCoIP that is why I want to disable dithering.
    I found how disable it in Windows and now I need the same but for Linux.
     

  5. yasamoka

    yasamoka Ancient Guru

    Messages:
    4,723
    Likes Received:
    177
    GPU:
    EVGA GTX 1080Ti SC
    AMD GPU dithering is supposed to be happening only when you are using color profiles. In that case, it would use a 10-bit LUT and output an 8-bit signal with dithering enabled to eliminate gradient banding. Otherwise, there should be no dithering if you do not have a color profile loaded.

    If you're using a color profile, you could stop dithering from being used by truncating color profile gamma curve output values from ~16-bit to 8-bit. I have code for this so if you're using a color profile, send it to me via PM and I'll convert it to 8-bit.
     
  6. d06pbiu

    d06pbiu New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    AMD Radeon HD 7970
    Thanks for your reply Yasamoka!

    "...only when you are using color profiles." - I've only installed 'AMD Catalyst™ 13.12 Proprietary Linux x86 Display Driver'. I did not configure it. Is it using some color profile by default? How can check it? How can I disable using color profiles if it'll use?

    P.S. Sorry for my bad English, and thanks for your help!
     
  7. Espionage724

    Espionage724 Guest

    Hmm, care to share how to do it in Windows? :)
     
  8. d06pbiu

    d06pbiu New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    AMD Radeon HD 7970
    Open Catalyst Control Center
    Go to information|software and look for the 2D driver file path which will have the registry location you're after.
    Inside the registry location, create a DWORD value called DP_DisableDither and set it to 1
     
  9. d06pbiu

    d06pbiu New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    AMD Radeon HD 7970
    If you don't use PCoIP, you will not detect difference between dithering or without it ... I suppose.
     
  10. d06pbiu

    d06pbiu New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    AMD Radeon HD 7970
    May be I should add something in /etc/ati/amdpcsdb?
    I didn't find documentation about amdpcsdb.

    Anybody can help me?
     

  11. voodoo

    voodoo New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    AMD
    Hi, did you try this (as root)?

    Code:
    telinit 3
    aticonfig --set-pcs-val=MCIL,DP_DisableDither,1
    aticonfig --set-pcs-val=TMDS_DisableDither,1
    aticonfig --set-pcs-val=HDMI_DisableDither,1
    telinit 5
    DP = Display Port
    TMDS = DVI
    HDMI = well, HDMI
     
    Last edited: Feb 21, 2015
  12. Meier

    Meier New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    NVIDIA
    Just wanted to add for future readers:

    - the tool itself might have been renamed to "amdconfig"
    - the parameter may have been renamed to --set-pcs-u32
    - any of those lines require "MCIL," at the beginning
    - this only works for the proprietary "fglrx" driver from AMD; it does not work with the open source "radeon" driver which most distributions load by default (not sure if it dithers)
    - the changes should be written to /etc/ati/amdpcsdb

    Code:
    amdconfig --set-pcs-u32=MCIL,TMDS_DisableDither,1
    amdconfig --set-pcs-u32=MCIL,DP_DisableDither,1
    amdconfig --set-pcs-u32=MCIL,HDMI_DisableDither,1
     

Share This Page