1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to achieve maximum turbo frequency

Discussion in 'Processors and motherboards Intel' started by noob25002, Dec 4, 2018.

Tags:
  1. noob25002

    noob25002 New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    1060 GTX
    Hello,

    Setup:
    i5 8400
    System board: ASUS TUF B360-Plus Gaming
    Ram: 2x 8Gb 2133mhz DDR4
    Gammaxx 300 CPU Coller
    Latest Bios.
    Win 10 x64.

    According to Intel's specifications, the turbo table of this cpu should be the following:
    4,000 MHz (1 core),
    3,900 MHz (2 cores),
    3,900 MHz (3 cores),
    3,900 MHz (4 cores),
    3,800 MHz (5 cores),
    3,800 MHz (6 cores)

    No core has ever gone over 3.8ghz. I stress tested 1 core individually, 4, then 6.
    The board does not have MCE or XMP.
    Tried setting the multiplier to 40 for the first core, the rest are auto.
    Tried all the bios settings, maxed out everything.
    In the bios it states the target for turbo is 4000mhz, and 3700mhz for cache.

    What settings do I need?
    Am I being limited by the board?
     
    Last edited: Dec 4, 2018
  2. noob25002

    noob25002 New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    1060 GTX
    From Intel XTU:
    https://imgur.com/a/iddh6tV

    This platform does not support overclocking
    Max core frequency 3.78ghz.
    Procesor cache frequency 3.49ghz.
    Power limit throteling- No.
    Range - No - Yes.
    Thermal throteling- - same as power limit.
    Current limit throteling- - same as power limit.
    System board VR - - same as power limit.

    In the comparisons page on the website , besides the others having z370 boards, the Turbo Boost Power Max was increased.
    Should I attempt to raise it as well?

    Ran stress test on one core, stayed at x38 multiplier.

    Disabled 5 cores from BIOS, here's what I got:
    1x sits at 4000mhz, x40 multiplier.
    Uncore is at 3700, x37 multiplier.

    Disabled 4 cores in BIOS:
    2x cores - 3900mhz, x39 multiplier.
    Uncore is 3600mhz, x36 multiplier.
    Tried setting the multiplier x40 for the 1st core, the 2nd left to auto, ran stress test on one core. No change.
    4x cores, same as 2.

    Intel speed step is disabled.
    Intel speed shift is enabled.
    ACPI timer is at 3580mhz.
    Virtualization is enabled.
    Cpu power enhancement is on. Is this the Multi core enhancement?

    On 6 cores the Uncore sits at 3500mhz/x35 multiplier. Is this the problem?
     
  3. noob25002

    noob25002 New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    1060 GTX
    I figured it out.
    C states must be Auto/Enabled.
    It still does not go to 4ghz, but all cores jump around 3.9ghz from time to time.
     
  4. noob25002

    noob25002 New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    1060 GTX
    I managed to get it to x40 on a single core in idle and load.

    1st picture idle, you can see cores clock and cores ratio go to x40/~3920MHz. Uncore goes to x37/~3690MHz.
    2nd picture Core 0 is at 100%.
    https://imgur.com/a/p3sbQ5h#tWGqrM4
    In idle all the cores go to x40 very easily, in load the one core achieves x40 sporadically.
    Some software will prevent the cores to go to x40 in idle or load, even if they are open and do nothing: Intel XTU, SpyHunter 5.

    It needs to be on full load on one core and idle on the rest:
    OCCT can assign itself to one core (with one thread).
    Prime 95 (cpu stress) needs to be assigned to one core via Task Manager. Needs one or two threads, six will crash it.
    CPU Burner will not get the core to x40 regardless of the settings above, with one or more threads.
    CPU Z only has one benchmark that gets one core to 100% (Version 17.01.64), but it uses the other cores as well. It resets the assigned cores via Task Manager.

    When it goes to x40 the other cores do not go down in frequency as Intel's documentation on this technology claims.
    I thought that it was a headroom issue, so I tried power saving and balanced power settings, and while the core frequency did go down in idle, in load the other cores would still go to 3.8/3.9GHz. The one core would still reach 4Ghz with these 2 power settings as well.

    I noticed In Intel XTU while 5 cores were disabled in BIOS the Turbo Boost Power Max and Turbo Boost Short Power Max were set to Unlimited. I set them to Unlimited after I enabled all cores, but made no difference. This setting would resets itself after a reboot.

    Support told me this is normal CPU behavior, set by Intel.

    Also, can monitoring software display Max Core Frequency per core?
     
    Last edited: Dec 17, 2018

Share This Page