How I got Far Cry 3 DX11 working well.

Discussion in 'Games, Gaming & Game-demos' started by StormVR6, Dec 2, 2012.

  1. StormVR6

    StormVR6 Ancient Guru

    Messages:
    1,584
    Likes Received:
    0
    GPU:
    GTX 780Ti / GTX 650Ti PPU
    Hello,

    I've read loads of posts all over the net about people getting bad results from decent hardware with FC3. The same holds true for many DX10/DX11 titles, and until consoles catch up - and the big money devs/publishers start pushing new tech - we (PC gamers) have to put up with shoddy implementation. Unless the next generation of consoles run DX11 then I believe it, too, will die before it's time, just like DX10 did, which, to be fair, was capable of bringing new stuff to the table. But when 90% of big game sales are on a DX9 platform why try to push a new set of API?

    Anyhow, I've managed to get FC3 running as smoothly as DX9 but containing the nicer lighting and shading that DX11 offers, i.e. nicer water, sun glare effects, etc. I hope this helps any Nvidia owner who's been trawling through hundreds of threads/posts looking for a possible solution.

    1. Add the DX11 Far Cry 3 exe to NV Inspector.
    2. Use the FC2 AA Comp (DX1x) bits. (0x00100000 (Far Cry 2))
    3. Don't touch anything (flags, nothing) just run AA mode on 'Enhance' and then 4xMSAA. Apply settings.
    4. Goto your 'GamerProfile' in documents/my games. Change these:

    MSAALevel="0"
    SSAOLevel="4"
    RefreshRate="60" (or whatever your monitor is)
    PostFxQuality="false"
    ShadowQuality="high"
    VSync="0"
    Obviously make sure that UseD3D11="1"


    (You can play with these settings but I gained nothing from trying SGSSAA or SSAA. YMMV.)

    Save, exit.

    Play game, if you do enter either of the two visual settings pages in FC3 do NOT change/apply, you can look, just remember to use the Escape or back button. You will notice that Post Process will say 'low' and AO will state SSAO, ignore. Post processing is off, so no DOF or ridiculous frame rate loss, and AO will look subtle, unlike SSAO or HBAO.

    I run D3D Overider to gain VSync and TB.

    That's it, no magic or crazy NVI settings and I get an almost constant 60fps. Trying to get the same IQ using the in-game settings would not only yield lower fps but lumpy fps, causing 55-60fps to feel like 20-25fps.

    If you really can't get DX11 to work well then you can use the FC2 DX9 comp bits (0x00008000 (Far Cry 2) to apply MSAA in NVI. You can even inject SMAA, just make sure to run in offline mode otherwise the game will exit upon startup. And apart from DX11=1 (change to 0) you can also leave the config settings as they are. Just remember to run from the DX9 FC3 exe.

    God bless you.

    EDIT: BTW, I'm running @ 2560x1440 on an i7 @ 4.2 and 680.
     
    Last edited: Dec 2, 2012
  2. Mr.Bigtime

    Mr.Bigtime Ancient Guru

    Messages:
    20,725
    Likes Received:
    1
    GPU:
    ASUS 1080TI
    Wrong topic.
     
    Last edited: Dec 2, 2012
  3. moab600

    moab600 Ancient Guru

    Messages:
    5,931
    Likes Received:
    0
    GPU:
    980TI Gaming
    ye noticed that as well, was running 80+, now 60+.
     
  4. ricardonuno1980

    ricardonuno1980 Banned

    Messages:
    4,409
    Likes Received:
    0
    GPU:
    GTX 780Ti Classified :D
    ?? But no!
     

  5. blesner

    blesner Ancient Guru

    Messages:
    2,697
    Likes Received:
    0
    GPU:
    MSI Nvidia GTX 690
    This works the best for me http://forums.guru3d.com/showthread.php?t=371710
     

Share This Page