How I got F@H working with ATI & Nvidia

Discussion in 'Folding@Home - Join Team Guru3D !' started by Mrtom82, Sep 4, 2010.

  1. Mrtom82

    Mrtom82 Member

    Messages:
    25
    Likes Received:
    0
    GPU:
    Sapphire radeon 5970
    I tried countless different ways of getting folding@home to work with my 5970 & 9800gtx+ at the same time and I finally got it to work!! I'm running a Sapphire 5970 as my primary and a EVGA 9800gtx+ for physx. I'm running CCC 10.8 and 258.96 drivers for my Nvidia with the Physx 1.44 mod.
    This is how I did it:

    1. Install all the drivers, including physx mods. After you get both cards working properly- Reboot.
    2. Install the f@h gpu 2 console client and run it, it should by default use the nvidia card. (I used the -gpu 0 flag, I'm not sure if that makes a difference, I haven't tried this without it). Reboot.
    3.Go to the device manager and disable the Nvidia card then reboot.
    3. Install the GPU 3 system tray client. It should use the ATI card by default.
    4. With the GPU 3 running on the ATI, go back to the device manager and enable the Nvidia card.
    5. Run the gpu console client

    Thats it!!

    I've checked gpu-z and it shows a 99% load on both cards. Make sure you remove the gpu 3 system tray from the startup folder. If you reboot with the nvidia still enabled and the GPU 3 client starts it will wipe out the ATI settings and you have to start from scratch. When you're going to fold with both just disable the Nvidia, start the GPU 3, re-enable the nvidia and start the GPU 2.
     
  2. Mrtom82

    Mrtom82 Member

    Messages:
    25
    Likes Received:
    0
    GPU:
    Sapphire radeon 5970
    I should also note that you must delete al previous installations, including the f@h folder in appdata\users. If you don't delete that folder it saves your settings from the previous install & it won't work.
     
  3. Kaktus

    Kaktus Master Guru

    Messages:
    314
    Likes Received:
    11
    GPU:
    Gigabyte GT 960
    WOW.
    Nice one dude. What's your ppd on those babies?
     
  4. Mrtom82

    Mrtom82 Member

    Messages:
    25
    Likes Received:
    0
    GPU:
    Sapphire radeon 5970


    I'm not really sure right now. I'm running the smp on my gpu, gpu 2 on my 9800 and gpu 3 on my ati. Thats a lot of clients on one system so I'm trying to fine tune everything to fold the wu's as fast as possible. I have hit one snag though- I can only do one WU on the ATI and then I need to restart. My method is def working, but one the WU on the ATI is done. When it goes to get a new WU the GPU 3 client goes back to the nvidia card, which is already running using the GPU 2. The only way I can get another WU is to shut both clients down, disable the 9800 and restart. It's not perfect, but it's a start.
     

  5. iancook221188

    iancook221188 Ancient Guru

    Messages:
    1,725
    Likes Received:
    11
    GPU:
    GTX 670 SLI / GTX 460 SLI
    there should be a way of getting this to work have you dried putting the flag -forcegpu nvidia_g80 on the gpu2 clinet
     
  6. Mrtom82

    Mrtom82 Member

    Messages:
    25
    Likes Received:
    0
    GPU:
    Sapphire radeon 5970
    Yup, I've tried everything you can find online- the -forcegpu ati_r800, -gpu 0, -gpu 1, etc.... I'm all out of flags, I've tried them all. I've also tried tweaking what order I open the clients with and so many other little things that would take to long to list. So far the only way I'm able to get it working is to disable the Nvidia card and load the first client. Once the first client is loaded it detects the AMD board and starts folding. Then I just enable the Nvidia card and start the other client and everything works fine. It is actually easier than it sounds. It turns out I don't need to reboot after disabling the Nvidia card in the device manager. So it's really only a couple of clicks and I'm done.
     
  7. jacko36

    jacko36 Member

    Messages:
    26
    Likes Received:
    0
    GPU:
    2x XFX HD5870 xFire
    Mrtom

    try the following flags (yes both are -gpu 0)
    i know this worked on the gpu2 clients, not sure about gpu3

    on the nv card use..
    -gpu 0 -forcegpu nvidia_g80

    on the ati card use..
    -gpu 0 -forcegpu ati_r700

    enter these in shortcuts to the exe files (i cant quite remember but i think i had to do it this way for them to work)

    and considering there are 2 gpus on the 5970, you could also try a 3rd client with the following flags..
    -gpu 1 -forcegpu ati_r700
    dunno if it'll work, but its worth a try.


    with the variables try not to go over 256 on the FLUSH_INTERVAL value.
    higher values will give a better ppd on the ati card,
    but it uses a lot of system resources and the other clients will perform badly.
     
  8. Mrtom82

    Mrtom82 Member

    Messages:
    25
    Likes Received:
    0
    GPU:
    Sapphire radeon 5970
    I'll give that a shot. I've tried the -forcegpu ati_r700 (and ati_r800) -gpu 0 but it still detected the nvidia. I also tried -forcegpu nvidia_g80, but I used -gpu 1. I haven't tried using -gpu 0 for both of them. I've also tried the ati with -gpu 1 & -forcegpu ati_r700 flags with no luck. When my current WUs are done I'll give your tip a try. I have both cards folding right now, so worst case scenario I can always go back to what works.

    Thanks for the help!
     
  9. Mrtom82

    Mrtom82 Member

    Messages:
    25
    Likes Received:
    0
    GPU:
    Sapphire radeon 5970
    The flags don't work. Both the GPU3 and GPU2 clients will only recognize the Nvidia unless I disalbe it first. I might be able to do it if I swapped my cards around and made the Nvidia my primary but I don't want my gaming performance to suffer. Thanks for the tip though, it was worth a shot.
     

Share This Page