Hibernate does not wake up with new NVstrap on

Discussion in 'RivaTuner Advanced Discussion forum' started by T8000, Oct 8, 2004.

  1. T8000

    T8000 Master Guru

    Messages:
    269
    Likes Received:
    0
    GPU:
    GF6800 LE 128 MB 12p_softmod, fanless (24dB_total)
    Yesterday, I put my computer in hibernate (suspend to disk), like I do more often. But when I turned it back on, it did not came past the "restoring Windows" screen, after the progress bar was full.

    Today, I tried to find the cause by rolling back some recent changes, one by one. After some unsuccesful tries, I found out that unloading NVstrap cured the hibernate problem.

    Because I could not believe NVstrap caused this, I turned it on again, did the required reboot and after that I tried to hibernate again. But again, restore hung on the "restoring Windows" screen. And again, unloading NVstrap cured hibernate.

    So it is possible that NVstrap does something that conflicts with hibernate. Because hibernate still worked with Rivatuner 2 rc15.1, it may be a bug in the new version.

    Perhaps you could try to reproduce this problem, by turning on NVstrap in Rivatuner 2 rc15.2 and using hibernate after the settings are applied and the system is rebooted with NVstrap.

    To use hibernate, just hold down the shift key in the shutdown screen and standby changes into hibernate, if it is enabled in "power settings".
     
  2. T8000

    T8000 Master Guru

    Messages:
    269
    Likes Received:
    0
    GPU:
    GF6800 LE 128 MB 12p_softmod, fanless (24dB_total)
    New try

    Today, I tried opting out NVstrap options.

    And setting the card ID back to default also solved the hibernate problem. (I changed the card ID from 6800 LE to 6800 because the 6800 LE is not recognized by the 3Dmark05 ORB and could not post results)

    But, when I open Rivatuner after a succesful hibernate, only 8 pixel pipelines and 4 vertex shaders are available instead of the softmodded 12 and 6, altrough the softmod is still on.

    Rebooting my PC gets everything back to normal, with 12 pipelines and 6 vertex shaders instead of the stock 8 and 4.

    So NVstrap is likely not executed in hibernate mode and the ID change made hibernate fail, because it does not seem to tolerate hardware changes that Windows notices.

    And this is likely also a problem for previous versions, but the first version of 3Dmark05 would post generic VGA instead of nothing, so I did not have the different hardware ID long enough to notice.
     
    Last edited: Oct 9, 2004
  3. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    12,969
    Likes Received:
    57
    Is it so difficult to peek in documentation?

    Your question is answered in both Known Issues and FAQ sections.
     

Share This Page