Help, my GTX 980Ti won't downclock!

Discussion in 'Videocards - NVIDIA GeForce' started by Kaladin, Sep 4, 2015.

  1. Kaladin

    Kaladin Member

    Messages:
    20
    Likes Received:
    0
    GPU:
    Palit GTX 980Ti SJ SLI
    Hi folks, I'm having somewhat of an issue with my new Palit GTX 980Ti JetStream.
    The card is supposedly even cooler than the reference 980Ti. During idle, the fan is even supposed to turn off itself, however my problem is that idle doesn't happen at all - clocks always remain exactly where they are.

    I have Windows 10 and a single 144Hz monitor (BENQ XL2420G, GSYNC mode). I have read over the net that this issue may happen to those who have multiple monitors, but it isn't really the case; I also tried lowering the desktop resolution to 120Hz but it didn't help either.

    Please help, I don't know what to do at this point.
     
  2. MoSTi

    MoSTi Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    Strix 970
    Hi, maybe igp ? just guessing
     
  3. Kaladin

    Kaladin Member

    Messages:
    20
    Likes Received:
    0
    GPU:
    Palit GTX 980Ti SJ SLI
    IGP? I don't have any integrated GPU if that's what you were asking.
     
    Last edited: Sep 4, 2015
  4. Loophole35

    Loophole35 Ancient Guru

    Messages:
    9,795
    Likes Received:
    1,150
    GPU:
    EVGA 1080ti SC
    Check in Nvidia control panel to see if you have "prefer maximum performance" ticked in global settings.
     

  5. Kaladin

    Kaladin Member

    Messages:
    20
    Likes Received:
    0
    GPU:
    Palit GTX 980Ti SJ SLI
    I do, but I tried with adaptive and it didn't change anything. That's for 3D applications, but this happens on desktop.

    Also tried lowering refresh rate to 60Hz, but didn't help either.
     
  6. Kaladin

    Kaladin Member

    Messages:
    20
    Likes Received:
    0
    GPU:
    Palit GTX 980Ti SJ SLI
    The fan isn't the problem. The problem is that clocks stay high even while simply browsing the desktop, which keeps temperature high and forces me to use the fan even when it shouldn't be needed.
     
  7. demented brave

    demented brave Master Guru

    Messages:
    298
    Likes Received:
    5
    GPU:
    MSI GTX1080 EK
    Did you set it to Adaptive performance and then restart? I had this issue too, I had to restart for it to take effect.
     
  8. Kaladin

    Kaladin Member

    Messages:
    20
    Likes Received:
    0
    GPU:
    Palit GTX 980Ti SJ SLI
    Adaptive performance is related to 3D apps, so it doesn't really change anything as far as desktop goes. I tried it, yes, but it didn't solve anything.
     
  9. BUFDUP

    BUFDUP Guest

    i had this problem before when using my swift. i reinstalled drivers again and it fixed it. kinda weird tho.
     
  10. stryfe2010

    stryfe2010 Member Guru

    Messages:
    188
    Likes Received:
    45
    GPU:
    EVGA/GTX 1060 SC 6G
    I've had this problem multiple times on recent drivers on windows 10 pro x64. I had to run multiple instances of DDU to fix it. But what worked for me was running DDU and going back to the previous whlq but even then my card was stuck at 3d clocks on desktop so I ran DDU once again and then installed the latest whlq (355.82) a second time, set it to adaptive and now it's running correctly.
     

Share This Page