1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[HELP] GTX 850m 4GB stuck at 135mhz, it's driving me nuts.

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by KingpinZero, Sep 18, 2016.

  1. KingpinZero

    KingpinZero Master Guru

    Messages:
    913
    Likes Received:
    0
    GPU:
    MSI Armor GTX1080
    Hi all,

    I have a serious problem with a friend laptop, which is an 850m 4GB HP Envy 15 (which has optimus obviusly - i7 4510u - 8GB).

    Since HP tech.support cannot help me further, i thought to write here.

    Basically what happens, not all the times but most of them, its that the GPU gets stuck to lowest clocks possible and it doesnt go up to 3D clocks, no matter what i try.

    So what i did to try to "fix" the problem is:

    - Reinstall from zero Windows 10
    - Roll back drivers from windows
    - Using Windows Update Drivers
    - Using drivers from HP Support Assistant
    - Using DDU, perform a clean in safe mode, reinstall drivers
    - Update to latest drivers using GeForce Experience
    - Use ThrottleStop to keep CPU up to exclude thermal throttling
    - Manually set "prefer maximum performance" and force every possible game to run manually on the Discrete Gpu
    - Set manually clocks of 2d and 3d states to stock clock speed
    - Disable the dGPU, reboot, reenable it in windows and try again

    Windows 10 is completely up to date, as well all other drivers in it (intel gpu as well).

    So to partially fix this (and it doesnt work all the times) i need to unistall the drivers, reinstall them and reboot. Sometimes, let's say 7 on 10, it works. GPU starts working again.
    But most of the times, it doesn't.

    So i'm at loss here; the laptop supports win10 officially as the drivers pack have been uploaded to the laptop page, so that shouldn't be an issue.

    This is a screenshot of both CPUZ and GPUZ:
    http://imgur.com/a/Sdr9Y

    I'm clueless, WHEN IT WORKS, i can get the most out of it, it still holds up pretty fairly and i can game for the whole day.
    Disabling or hybernating the laptop doesn't help, neither an hard reset or cold boot.

    Thank you all, i'm open to any suggestion.

    PS: yes i tried to google and fixes etc are for win7 or 8, most of them are pretty dated. Also most of them advise what i've already tried. If anyone had an experience like this, let me know. I heard that a particular driver works fine for this kind of chipset but i got no source for that.
     
  2. Minotaur

    Minotaur Active Member

    Messages:
    94
    Likes Received:
    6
    GPU:
    Gainward 1080 GLH
    How's driver 269.09 behave? I have almost the same problem on my desktop with most new drivers. However a reboot always fixes bugged clock speeds (a script could be used too, to disable and re-enable the device).
    You could try 268.81? as well.
    Stumped why a reboot doesn't work, is the laptop doing a real hard reboot? The video device might not be disconnecting or something, no idea about how laptop hardware operates sorry. But try removing the battery too, to rule that out I guess.. There should be no need to reinstall Windows either. DDU is all you need, if at all..
    The only other stuff I can recommend is to update all the drivers, esp all the Intel ones. btw Intel's Driver Update Utility, won't pick up all. So open up device manager and check your versions, against those found versions online..
     
    Last edited: Sep 18, 2016
  3. KingpinZero

    KingpinZero Master Guru

    Messages:
    913
    Likes Received:
    0
    GPU:
    MSI Armor GTX1080
    Hey, thank you for your reply.

    Well, if you take a look at what i wrote, software-wise, i've tried everything. So i will exclude to use again DDU and to update or downgrade INTEL drivers as i've already tried.
    Also usually when i install intel i use the -overall swtich, i know what you mean ;)
    Anyway thanks for your input because i will try those two drivers you said; are they compatible with Windows 10?
     
  4. Extraordinary

    Extraordinary Ancient Guru

    Messages:
    19,336
    Likes Received:
    1,398
    GPU:
    GTX980 SLI
    Tried resetting the BIOS to defaults?
     

  5. cryohellinc

    cryohellinc Ancient Guru

    Messages:
    2,569
    Likes Received:
    1,650
    GPU:
    GTX 1080Ti
    Install new GPU bios
     
  6. Cave Waverider

    Cave Waverider Master Guru

    Messages:
    874
    Likes Received:
    34
    GPU:
    GeForce RTX 2080 Ti
    Are you sure your Nvidia card is being used and not just your Intel one? Perhaps you need to tweak your Optimus settings to use your Nvidia card in games. If you don't have them, then you'll need to install the mobile driver instead.

    Also make sure that your active power plan is set to High Performance and that no Nvidia power saving options are set in your active power plan.
     
    Last edited: Sep 21, 2016
  7. KingpinZero

    KingpinZero Master Guru

    Messages:
    913
    Likes Received:
    0
    GPU:
    MSI Armor GTX1080
    I dunno if that is even possible on this thing, besides i dont even know where to check for a new bios compatible to this 4GB 850m.

    Yeah i'm sure as i'm keeping under control usage of both cards, and intel sits at 0%, lowest clock speed. While Nvidia has higher usage but stuck clocks.
    Optimus settings?
    What i did was to select nvidia gpu ad preferred for those games, max performance, and also disabled the batteryboost option in geforce experience.
    Also ive tried with and without laptop battery if that helps, and naturally the laptop is always plugged in the mains.
     
  8. signex

    signex Ancient Guru

    Messages:
    8,688
    Likes Received:
    121
    GPU:
    Aorus RTX 2060 S
  9. KingpinZero

    KingpinZero Master Guru

    Messages:
    913
    Likes Received:
    0
    GPU:
    MSI Armor GTX1080
  10. bloodfx

    bloodfx Member Guru

    Messages:
    180
    Likes Received:
    0
    GPU:
    gtx 760
    Its the power saving mode for sure, mine did exactly the same.
     

  11. KingpinZero

    KingpinZero Master Guru

    Messages:
    913
    Likes Received:
    0
    GPU:
    MSI Armor GTX1080
    Its set to performance mode and any other power measures are turned off.
     

Share This Page