HELP, Gta San Andreas and Vice City mouse not working in game with rtss version 7.0.0, anyone else?

Discussion in 'Rivatuner Statistics Server (RTSS) Forum' started by WillieBru, Nov 2, 2017.

  1. WillieBru

    WillieBru New Member

    Messages:
    8
    Likes Received:
    0
    GPU:
    rx 470
    Hello,

    When I have Rivatuner enabled with the latest software , v7.0.0, the mouse stops working in game in Gta San Andreas and Gta Vice City. I can move the mouse in the menu but it won't click nor does the mouse scroller work. Once in game, the mouse does not even work at all. Can't look around or click. So I saved the game with rtss on which completely ruined my save game and wouldn't even start it steam after that, so I had to use a back up save game to keep it running again. I know for sure it is the rtss version 7.0.0's fault because I uninstalled it and it worked right after it again. Also tried 2 different mouses. So, can someone with Gta SA or Gta VC ( Steam version) try this and see if they have the same issue???? I am almost 100% sure it is the newest version's fault, since it used to work with the older version of it at the beginning of this year. Thanks in advance!
     
  2. GroinShooter

    GroinShooter Master Guru

    Messages:
    314
    Likes Received:
    51
    GPU:
    GTX 1080 SC
    I hope this isn't another blame it on RTSS thread. So many things might have changed in you hardware/software config in that time. But now for starters, did you try this?
    https://steamcommunity.com/sharedfiles/filedetails/?l=finnish&id=162622767
     
  3. dr_rus

    dr_rus Ancient Guru

    Messages:
    2,219
    Likes Received:
    88
    GPU:
    GTX 1080 GRP
    No issues of any kind running GTAVC with AB 4.4.0 final here.



    Will process into 1440p in some minutes.
     
  4. WillieBru

    WillieBru New Member

    Messages:
    8
    Likes Received:
    0
    GPU:
    rx 470


    Well, the problems started when using the 7.0.0 version, and when it is closed, I don't have issues. Not with fraps or afterburner, and the moment I enable rivatuner it won't work so it must be that.
     

  5. WillieBru

    WillieBru New Member

    Messages:
    8
    Likes Received:
    0
    GPU:
    rx 470
    ty for the vid. It is very weird, the moment I have rivatuner enabled the mouse just wont work in game with gta SA or VC, I only get it to work when I press shift+ tab. But the moment I go back at the menu and back in the game , it simply stops working. Do you have some other fix files installed with gta sa or vc? Cuz yours seems perfectly fine.
     
  6. GroinShooter

    GroinShooter Master Guru

    Messages:
    314
    Likes Received:
    51
    GPU:
    GTX 1080 SC
    I noticed the links for the file are down on that Steam site. Here's a working link:
    http://www.mediafire.com/file/v6yyh6euo1da3vl/DINPUT8.rar
    Just put the dinput8.dll in san andres' exe file location.
     
  7. dr_rus

    dr_rus Ancient Guru

    Messages:
    2,219
    Likes Received:
    88
    GPU:
    GTX 1080 GRP
    This sounds more like Steam overlay issue tbh. Try the latest Steam Beta maybe?

    I just installed it to check if there's any issues with it running with AB/RTSS.
     
  8. WillieBru

    WillieBru New Member

    Messages:
    8
    Likes Received:
    0
    GPU:
    rx 470
    Hmm very weird, so it must be a combination of RTSS interfering with one of the programs I have. I only got corsair link, msi live update, logitech gaming software , cpu z and msi afterburner installed atm. Very strange. Anyways, I got everythin up to date. I will try an older version of my amd gpu drivers amd see how that goes. THe weirdest thing is, when I save it when I have rtss enabled, it just won't open the game after it and I have to delete the saving files after it. It is also weird it is just these 2 games, and not for example gta 3 as well.
     
  9. WillieBru

    WillieBru New Member

    Messages:
    8
    Likes Received:
    0
    GPU:
    rx 470
    Tried steam beta, doesn't work. I am gonna do a clean install of windows. If that doesn't work it must we v7,0,0 interfering with amd graphic cards. BTW, can you make a vid of your settings ?
     
  10. dr_rus

    dr_rus Ancient Guru

    Messages:
    2,219
    Likes Received:
    88
    GPU:
    GTX 1080 GRP
    Which settings? GTAVC or AB/RTSS? I've already deleted GTAVC but there wasn't anything special beyond the resolution select and widescreen toggle.
     

  11. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    13,205
    Likes Received:
    230
    Rtss 7.0.0 “interfering” with AMD graphics card is a nonsense statement, sorry. It never was driver or vendor specific application. Please configure it properly.
     
  12. WillieBru

    WillieBru New Member

    Messages:
    8
    Likes Received:
    0
    GPU:
    rx 470
    I had it installed and configured properly. I have everything uninstalled from my PC except steam and ab/rtss and the problem still exist. Like I said before, the old rtss version worked perfecly fine
     
  13. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    13,205
    Likes Received:
    230
    I see the story “old version was fine, new is absolutely bugged” with each new release, and each time it s addressed by proper clean reinstall. I have nothing to add to it besides the same recommendation - configure it properly please.
     
  14. WillieBru

    WillieBru New Member

    Messages:
    8
    Likes Received:
    0
    GPU:
    rx 470
    I mean the ab/rtss settings. I just got a fresh install with w10. SO can you maybe share your settings with me? Thanks in advance
     
  15. dr_rus

    dr_rus Ancient Guru

    Messages:
    2,219
    Likes Received:
    88
    GPU:
    GTX 1080 GRP
    There's nothing special beyond the modifications to Modern Mono OSD layout. The rest are pretty standard.
     

  16. WillieBru

    WillieBru New Member

    Messages:
    8
    Likes Received:
    0
    GPU:
    rx 470
    Fresh install didn't work. Tried to change settings, issue still exist. I have now still the default settings on. I'll just keep fraps for a while in gta sa and vc and ab for the otehr games. Anyways, ty for the help
     

Share This Page