help! defective rampage II extreme board??

Discussion in 'General Hardware' started by TipsyTaxiDriver, May 15, 2009.

  1. TipsyTaxiDriver

    TipsyTaxiDriver New Member

    Messages:
    9
    Likes Received:
    0
    GPU:
    GTX 295 when i find one..
    im hoping someone can help me. i finally got all my new peices together for my new system after months of waiting and to my dismay i got no screen on my first bootup. after trying to figure out what was wrong i narrowed it down to my middle (blue) dram slot, at first i thought one of the memory sticks was dead but i tried all of them single and also in slots 1 & 3 and they all work, im really hoping its not my board as today is actually the 30th day and dont want to get into it with them about an on time RMA

    oh, im also currently using dominator 1600 ram
     
  2. 50000 monkeys

    50000 monkeys Member

    Messages:
    40
    Likes Received:
    0
    GPU:
    Leadtek gtx 260 extreme
    Try taking the cpu out and check very carefully that there are no bent pins and reseat.

    Take motherboard out of the case, and just with bare essentials, boot it up after resetting the bios.

    Good luck
     
  3. deltatux

    deltatux Ancient Guru

    Messages:
    19,051
    Likes Received:
    13
    GPU:
    GIGABYTE Radeon R9 280
    It does actually sound like a dead board. This issue should have been detected within a couple days of the date of purchase. I'm actually surprised that you haven't discover this defect earlier.

    deltatux
     
  4. TipsyTaxiDriver

    TipsyTaxiDriver New Member

    Messages:
    9
    Likes Received:
    0
    GPU:
    GTX 295 when i find one..
    Yea I wish I had bought everything at once. Reason why it's past 30 day rma was because I was peiceing this system out little by little and wasn't able to test anything as soon as I got it, most of the compnents have been sitting in the corner for weeks

    Anyways I got it up and running!! Turns out 50000 monkeys was right on the money and there was in fact 1 pin that was a bit bent but it was nothing a little sewing pin and a magnifying glass couldn't handle :D

    No idea how the pin got bent in the first place. The only time I took the protective cover off was to Install the chip, which I gently lowered in place correctly the first time.

    Thanks a ton for the help
     

  5. 50000 monkeys

    50000 monkeys Member

    Messages:
    40
    Likes Received:
    0
    GPU:
    Leadtek gtx 260 extreme
    Great news.
     
  6. deltatux

    deltatux Ancient Guru

    Messages:
    19,051
    Likes Received:
    13
    GPU:
    GIGABYTE Radeon R9 280
    Nice, bent pins are usually rare, but I guess they happen even if you didn't do anything to the board. The only time I bent pins were when I uninstall my CPU cooler.

    deltatux
     

Share This Page