Help choosing driver for the GTX980 TI

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by Doom23, Apr 25, 2020.

  1. Doom23

    Doom23 New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    Asus GTX980 Ti
    Does anyone know what is the best stable driver for my good old GTX980 Ti?
    Nvidia tend to mess up with drivers a lot and most of the 400 driver series had a lot of issues at first from what I've seen (kinda like most of their drivers over the years) so I'm still using the 390.77 which said to be the stablest at the time,

    DOOM Eternal however got other plans in store for me and now I need to have at least 442.19 or later just to run it, yet don't want to jump the gun and just go for the last driver before some research and feedbacks
     
  2. Strange Times

    Strange Times Master Guru

    Messages:
    289
    Likes Received:
    85
    GPU:
    RX 580 UV
    latest wtf)
     
  3. MaidenFred

    MaidenFred Active Member

    Messages:
    91
    Likes Received:
    3
    GPU:
    MSI 3070 OC
    Hello, I'm using v442.50 quadro modded for the moment, no problem with them.
    Win 10 1909 64bits.
    With 442.74 I had weird bluscreens so I rolled back. Didn't tried latest yet...
     
  4. EugeneJackKhoros

    EugeneJackKhoros Member

    Messages:
    46
    Likes Received:
    28
    GPU:
    GTX 1080
    Pre-Release Driver 999.99 for Windows 10 x64
     
    janos666 likes this.

  5. tayyar

    tayyar Member

    Messages:
    33
    Likes Received:
    14
    GPU:
    2
    I used to use an older driver and Battlefield 5 refused to run because it required recent drivers. Someone made a bypass which stops some nvidia services (I guess, I don't know exactly what it does) and the game launched and ran well.

    I'm sharing it in plain text here, maybe someone can edit the relevant info (like dx12 dll) and try if it works for Doom.

    I still use 391.23 for some emulators, because Windows screwed up vsync for borderless.
     
  6. Astyanax

    Astyanax Ancient Guru

    Messages:
    11,303
    Likes Received:
    4,242
    GPU:
    GTX 1080ti
    nothing is screwed up with vsync and borderless
     
  7. tayyar

    tayyar Member

    Messages:
    33
    Likes Received:
    14
    GPU:
    2
  8. Astyanax

    Astyanax Ancient Guru

    Messages:
    11,303
    Likes Received:
    4,242
    GPU:
    GTX 1080ti
    thats not screwed up though, its working as intended by current design
     
  9. Doom23

    Doom23 New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    Asus GTX980 Ti
    Thx for the replies so far

    Interesting, didn't knew there were modded ver for the drivers.

    Umm I don't think it will help with Doom, since in doom case it's mostly the Vulkan that need to be upgraded over anything else.


    If there was a general driver that works for most people it would've been great >.>
     
  10. -Tj-

    -Tj- Ancient Guru

    Messages:
    17,208
    Likes Received:
    1,941
    GPU:
    Zotac GTX980Ti OC
    I like 442.01 with my 980ti, returned a couple of times back and it doesnt dissapoint... lol :)


    I dont have doom ethernal so idk what's up there.
     

  11. Doom23

    Doom23 New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    Asus GTX980 Ti
    Nice :eek:

    Doom eternal use Vulkan which is an API that is more or less a sane replacement for OpenGL, MS's DX11 and MS's broken DX12,

    In the first game Vulkan was added in an update iirc and was optional, but in the second game it's seem vulkan is the main API the game uses (not surprising considering how it seem to work better compared to OpenGL and DX12) and therefore the game requires at least version 442.19 and onward just to run :/
     
  12. Astyanax

    Astyanax Ancient Guru

    Messages:
    11,303
    Likes Received:
    4,242
    GPU:
    GTX 1080ti
    hahaha sane, no no no, different, the insanity lives on.
     
  13. elrazor

    elrazor Master Guru

    Messages:
    367
    Likes Received:
    5
    GPU:
    970GTX G1 1591/7452
    970 GTX here, using 445.98 hotfix all fine and smooth!
     
  14. Doom23

    Doom23 New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    Asus GTX980 Ti
    Nice, don't seems like I can find that beta ver for my card though ;/
    At least not from Nvidia search (which kinda makes me worry it may not support my card even though in 99% of the cases it's~)

    Also any link I found so far was for Win Sa10,
    I still with 7 here ;p


    EDIT
    Ehhh even on Nvidia site there's only win10 installers it's seems :/
    https://nvidia.custhelp.com/app/answers/detail/a_id/5022/~/geforce-hotfix-driver-version-445.98
     

    Attached Files:

  15. -Tj-

    -Tj- Ancient Guru

    Messages:
    17,208
    Likes Received:
    1,941
    GPU:
    Zotac GTX980Ti OC
    I installed torented version, just to test and I didnt see any warning when I started the game with 442.01, but I deleted it. It wanted me to create a betsheda account.
     

Share This Page