[HELP] AMD Radeon R5 M200 / HD 8500M Series

Discussion in 'Videocards - AMD Radeon' started by EzKill69, Sep 6, 2020.

  1. EzKill69

    EzKill69 New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    Amd Radeon R5 M200
    I apologise in advance if this "situation" was already fixed or talked about it, i cant seem to find a fix for it myself.


    So i have a Lenovo G500 i3 3rd gen, with AMD Radeon R5 M200 / HD 8500M Series , or so i think.

    Im unable to find a driver since my laptop updated to windows 10 , it had 8.1 then after the windows 10 forced update to win 10 everything went south with Amd GPU, what ever i download from AMD center doesant work i get messaged like no amd was detected on your system and smt like that.


    Can somebody help me, im on the edge with this thing.

    This was a recent picture from windows 10

    https://community.amd.com/servlet/JiveServlet/showImage/2-2990863-171948/pastedImage_1.png


    after it told me new updated, i did the update and nothing works now...

    https://community.amd.com/servlet/JiveServlet/showImage/2-2993164-172668/pastedImage_1.png
     
  2. Undying

    Undying Ancient Guru

    Messages:
    13,911
    Likes Received:
    3,149
    GPU:
    Aorus RX580 XTR 8GB
    Make sure you internet connection is disabled while installing the drivers on windows 10. MS will try to force their own via WU.

    Also, try using DDU in safe mode if amd clean install isnt working.
     
    EzKill69 likes this.
  3. EzKill69

    EzKill69 New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    Amd Radeon R5 M200
    Thank you i will try it now. (Il come back with edits if it work'd or not)
     
  4. Yxskaft

    Yxskaft Maha Guru

    Messages:
    1,459
    Likes Received:
    114
    GPU:
    GTX Titan Sli
    My first guess is that it's because your laptop has both an AMD and Intel GPU.
    Laptops have always been more wonky with drivers, even more so for the hybrid systems.

    You might have the best luck if you install the drivers from the manufacturer, assuming this is your laptop
    https://pcsupport.lenovo.com/us/en/...ist/component?name=Display and Video Graphics


    To have the most recent driver though, I'd probably try installing manually via the device manager instead.
    Another option is also letting Windows Update attempt to do its thing, although the drivers probably are old, there's a great chance it'll get it working correctly.
     

  5. EzKill69

    EzKill69 New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    Amd Radeon R5 M200
    Ideed thats my laptop, and on the lenovo forums they didnt update or offer support for windows 10 amd drivers. Thats my issue Spent like 8 hours just to make my windows recognise the AMD gpu, i did a system restore and that did little help now im trying to install manually a amd relive version 20.4 smt that it was saying recomended , before that i made a system restore point , hope its not going to "fk" again the drivers.

    Any ideas on how to fix the AMD issues il gladly test them, btw i dont care about the intel gpu if there is a way to permanently disable it and allow only the amd gpu that would be perfect
     
  6. user1

    user1 Ancient Guru

    Messages:
    1,608
    Likes Received:
    546
    GPU:
    hd 6870
    very rarely there is an option in the bios to disable the igpu and use the discrete gpu only(8500m) you could take a look around, but dont expect much, frankly you'd be better off rolling back to the last version of windows that worked, those amd/intel mixed graphics laptops truely are some of the worst supported pieces of hardware ive ever come across.


    also found this https://community.amd.com/thread/240459
     

Share This Page