1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Hell Freezes Over: NV to support Open Variable Sync Jan 15

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by Chastity, Jan 7, 2019.

  1. sean8102

    sean8102 Member Guru

    Messages:
    168
    Likes Received:
    1
    GPU:
    EVGA GTX 1080 SC
    I'm still trying to nail it down but I have noticed that sometimes something will cause the framerate to stick to 50 FPS at least according to AfterBurner but it feels lower and is choppy. Alt tab in and out of game or even just hitting the win key to change the active window and going back fixes it instantly and goes back to max refresh 75Hz. Still trying to figure out hitting what framerate can cause it, because most of the time even if I drop below the freesync range of 40-75 its no problem.
     
  2. Amaze

    Amaze Ancient Guru

    Messages:
    2,748
    Likes Received:
    291
    GPU:
    1070 ti Strix
  3. Chastity

    Chastity Ancient Guru

    Messages:
    1,549
    Likes Received:
    340
    GPU:
    Nitro 390/GTX1070M
    Well, I don't know how they did their testing, but they list my monitor (Samsung UE590) as a "No" for G-Sync Compatibility. I got it working just fine. They may have run into the driver losing the timings, and getting dropped frames and stutter, and never turned the monitor off/on to address.
     
  4. Amaze

    Amaze Ancient Guru

    Messages:
    2,748
    Likes Received:
    291
    GPU:
    1070 ti Strix
    Yeah it's a bit lacking in detailed info. I don't really know why they tested my monitor even, it doesn't support freesync nor gsync.
     

  5. HeavyHemi

    HeavyHemi Ancient Guru

    Messages:
    6,083
    Likes Received:
    489
    GPU:
    GTX1080Ti
    Apparently because 'FreeSync' is off by default and has to be enabled manually. That is one of the the requirements.

    [​IMG]

    https://www.nvidia.com/en-us/geforce/news/g-sync-ces-2019-announcements/
     
    Stormyandcold likes this.
  6. Keesberenburg

    Keesberenburg Master Guru

    Messages:
    829
    Likes Received:
    19
    GPU:
    EVGA GTX 980 TI sc
  7. Martigen

    Martigen Master Guru

    Messages:
    300
    Likes Received:
    71
    GPU:
    GTX 1080Ti SLI
    Just want to provide my experience for anyone with the same monitor:

    Samsung LC34F791 - 21:9 3440x1440 @100Hz

    1) LFC does not appear to be present. Flickering occurs whenever the framerate nears the lower bounds of the Freesync range (in either Standard or Ultimate mode)
    2) Indeed, it turns out this flickering will occur with +5hz of -any value- you set as the lower bound. So... set it as low as you want.
    3) I used CRU to set a bound of 60-100 Hz in Standard mode (I tend to configure games to rarely dip below 90 anyway)
    4) Profit! It actually works beautifully.

    Well -- almost. Here's the thing: even if setting Gsync to work in 'Windowed' mode, it doesn't. Any windowed mode game flickers. So you -MUST- use Fullscreen Exclusive in your games. Unfortunately, not all games properly set Fullscreen Exclusive, even if configured to use this in settings, thanks to engines like Unity that default 'Fullscreen' to be 'Fullscreen Windowed'. So you may need to experiment with fart-arsing around with config files or launch flags to ensure a game uses 'Exclusive' fullscreen mode, eg appending '-screen-fullscreen -window-mode exclusive' to Steam launch flags for Unity games.

    It can also help to disable Windows 10's shitfaced 'Fullscreen Optimisations'. You can do this in the properties of an .exe file, or globally with a registry variable (google it). Exclusive Fullscreen is required for SLI, DSR, VR etc.
     
  8. Radical_53

    Radical_53 Ancient Guru

    Messages:
    3,798
    Likes Received:
    35
    GPU:
    Aorus 1080 TI
    Which games did you test?

    I‘m using the same monitor and I can only use borderless fullscreen, regular fullscreen won’t activate G-Sync for whatever reason.
    I have that flickering too, but in the regular FPS-range it works beautifully.
    Witcher 3 or Battlefield 5 looked great.
     
  9. Amaze

    Amaze Ancient Guru

    Messages:
    2,748
    Likes Received:
    291
    GPU:
    1070 ti Strix
    Battle(non)sense tested g-sync compatible mode vs freesync for input lag:
     
    Stormyandcold likes this.
  10. Martigen

    Martigen Master Guru

    Messages:
    300
    Likes Received:
    71
    GPU:
    GTX 1080Ti SLI
    Quite a few so far -- Deep Rock Galactic, NS2, Shadow of Tomb Raider, XCOM2, Deus Ex Mankind Divided, Dishonored 2, Dying Light, Ghost of a Tale.

    Perhaps it's because I force disable 'Fullscreen Optimizations' both globally and per .exe for SLI.

    Edit: Checked with Witcher 3 and it works as well. Interestingly it had been updated since I last used it, so the Disable Full Screen Optimisations flag on the .exe was cleared. However, I have it disabled globally via the registry (see https://winaero.com/blog/disable-fullscreen-optimizations-windows-10/). Of course this might not be the reason it works, but you could try.

    Apart from that I'm on Win 1809, displayport to the monitor, and I set a custom range using CRU on the 'Standard' mode. Haven't tried it with 'Ultimate' as it's working for now and LFC doesn't apprently work anyway in Ultimate, so there's no advantage to it (unless there's something else different between the modes beyond the frequency ranges).
     
    Last edited: Jan 22, 2019

  11. Radical_53

    Radical_53 Ancient Guru

    Messages:
    3,798
    Likes Received:
    35
    GPU:
    Aorus 1080 TI
    I set it to Ultimate, DP and Win 1809 here also.
    I even extended the range with CRU, just to be sure.
    Interesting find about the optimizations. Maybe that’s the reason it works in fullscreen for you and only borderless for me.
     
  12. AsiJu

    AsiJu Ancient Guru

    Messages:
    5,551
    Likes Received:
    1,131
    GPU:
    MSI RTX 2070 Armor
    So I bought an Asus VG278Q, which also happens to be one of G-Sync certified displays (didn't choose it because of that but a nice bonus).

    Not arrived yet but since I'm new to VRR / G-Sync / FreeSync:

    - should I install new driver first or is it better to switch monitors first and then update driver? Does that matter?

    - to use VRR, should Vsync be set to On also? Or can it be kept off?

    - if Vsync off, capping framerate to max refresh rate is recommended to avoid going out of range, I suppose?

    I've understood VRR should be the same as Vsync off regarding input lag? As refresh rate varies to match framerate.
     
  13. Dragam1337

    Dragam1337 Maha Guru

    Messages:
    1,093
    Likes Received:
    479
    GPU:
    1080 Gaming X SLI
    Doesnt matter in regards to the driver.

    The best approach you can do is the following:

    1. set g-sync on for fullscreen mode only in nvidia control panel

    2. force v-sync on in global profile in nvidia control panel. You want to have this on, as fluctiations that goes beyond the hz of your monitor will otherwise cause tearing. As long as g-sync is enabled, and fps capped below the hz of the monitor, this will not cause additional input latency.

    3. download msi afterburner with rivatuner statistics server

    4. in rivatuner set fps cap to as minimum 3 fps below the hz of the monitor, or in this case preferably 10 fps below, as the monitor doesn't have a g-sync module, and will therefore be more prone to fluctuations.

    This approach will give you rocksteady frametimes (aka as smooth as it can possibly be) and 1 frame more input lag than v-sync off. (v-sync on is roughly 4 frames of more input lag compared to v-sync off). Assuming this is at 120 hz, then this will mean an input latency of about 30 ms vs about 55 ms with v-sync.
     
  14. Martigen

    Martigen Master Guru

    Messages:
    300
    Likes Received:
    71
    GPU:
    GTX 1080Ti SLI
    You don't necessarily need to go so low I imagine. At least in my testing, 1 below the hz works fine. My monitor is 100Hz and I experimented with 97, 98 and 99 and all were identical and had no issues that I could see in both games and the Nvidia Pendulum demo. Of course, my only experience is with the Samsung CF791.
     
  15. Dragam1337

    Dragam1337 Maha Guru

    Messages:
    1,093
    Likes Received:
    479
    GPU:
    1080 Gaming X SLI
    Well you have to consider that the closer you get to the max hz of your monitor, the less room there is for frametime fluctuations. Lets say you run at 60 hz, the fastest the monitor can handle is 16.6 ms frametimes. So say you cap fps at 59, that would average it at. 16.9 ms... but nothing is able to make frametimes 100% steady, and whenever frametimes become faster than 16.6 ms, you will experience increased input latency as it is out of the gsync range.

    Blue bursters have done quite extensive tests on it

    https://www.blurbusters.com/gsync/gsync101-input-lag-tests-and-settings/5/
     

  16. AsiJu

    AsiJu Ancient Guru

    Messages:
    5,551
    Likes Received:
    1,131
    GPU:
    MSI RTX 2070 Armor
    Thanks, but doesn't just capping the framerate below refresh rate maximum also achieve that?
    Or will G-Sync not activate if Vsync is off?
     
  17. Radical_53

    Radical_53 Ancient Guru

    Messages:
    3,798
    Likes Received:
    35
    GPU:
    Aorus 1080 TI
    It does activate. So far I haven’t seen a reason to turn vsync on.
    Framerate limiter and GSync together works nicely.
     
    AsiJu likes this.
  18. Dragam1337

    Dragam1337 Maha Guru

    Messages:
    1,093
    Likes Received:
    479
    GPU:
    1080 Gaming X SLI
    It is impossible to keep frametimes 100% steady, even with RTSS (which is by far the best tool to keep frametimes as steady as possible), and any fluctuations to frametimes where the frametime goes below or above the gsync range, you will get tearing with v-sync off.

    It is very common to see fluctuations of 5 ms or more. Let us say that you cap fps at 57 (which is an average of 15.7 ms), and your monitor is 60 hz (which is an average of 16.6 ms). That would mean that you would just have to see frametimes fluctuate by 1 ms for it to be outside the g-sync range, thus causing tearing with v-sync disabled. You eliminate this issue entirely by enabling v-sync, and tests shows that v-sync enabled does not increase input latency with g-sync enabled, and fps capped below hz of the monitor.
     
    AsiJu likes this.
  19. AsiJu

    AsiJu Ancient Guru

    Messages:
    5,551
    Likes Received:
    1,131
    GPU:
    MSI RTX 2070 Armor
    Well the monitor is 144 Hz with VRR range of 40 - 144 so if I cap to say 130 ... 140 that should leave plenty of buffer.
    Whilst reaching high Hz.

    Got the monitor but didn't get to try it out yet. Waiting eagerly!
     
  20. Dragam1337

    Dragam1337 Maha Guru

    Messages:
    1,093
    Likes Received:
    479
    GPU:
    1080 Gaming X SLI
    It isn't, at least not without v-sync forced through the global profile.

    As fps increases, frametimes become shorter. The difference in frametimes between 144 and 140 fps is only 0,3 ms. And as fps increases, cpu frametime spikes (which are much more pronounced than gpu frametime variences) start to kick in. So actually, the higher the fps, the more buffer you need to have.
    This is especially true when the variable refresh rate is not hardware controlled by a g-sync module, but software controlled. Tests show that freesync exhibits considerable higher variences in frametimes compared to using a g-sync module, thus needs to be capped lower than when using a g-sync module. Generally speaking on a 144 hz freesync monitor for it to stay within the range, it would need to be capped at least 10 frames below the hz, and preferably at 130. As "g-sync compatible" is the exact same thing as freesync, it acts the same way.

    But if you don't intend to listen to my advice regarding v-sync, why did you ask in the first place ?
     

Share This Page