Hdmi Receiver signal not waking from sleep

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by judicator, Apr 3, 2020.

  1. judicator

    judicator Member

    Messages:
    37
    Likes Received:
    0
    GPU:
    ROG STRIX-GTX1070 8GB
    Hello,

    After installing 445.75, every time I wake my computer from sleep my external Pioneer receiver (connected via hdmi to 1070gtx gpu) doesn't recover. In order to wake/re-initialize the connection I have to go and flip the refresh rate being sent to the receiver. This 'usually' works.

    Does anyone know if there is a regedit I need to do, or have any insight as to how to fix this? I've always had a similar problem in the past where my secondary monitor doesn't resume connection, and I have to go in and flip it's refresh rate. But it's rare, and this is happening every single time.

    Thanks
     
  2. HeavyHemi

    HeavyHemi Ancient Guru

    Messages:
    6,936
    Likes Received:
    930
    GPU:
    GTX1080Ti
    It's likely only by accident your receiver comes on at all. GPU's are not CEC compliant and do not pass on those signals to consumer electronic gear like a receiver. Put another way, turning on my PC connected to my Samsung TV via HDMI, is not going to turn on the TV.
     
  3. Martigen

    Martigen Master Guru

    Messages:
    423
    Likes Received:
    152
    GPU:
    GTX 1080Ti SLI
    I use a Pioneer receiver connected to an LG OLED TV. Just to be clear you're referencing the same problem I -- and every HDMI user connected to an Nvidia card going to a receiver has, and not what HeavyHemi is referencing -- does your receiver also recover if you simply click on Windows' volume icon, and change the volume so it sends a sound output to the receiver?

    If so, there has been an issue with Nvidia drivers since forever, and I really don't know why they haven't changed this behaviour: HDMI power saving. As soon as there is no audio singal, it goes into power saving mode, and recovering from this takes several seconds every time audio is again sent -- leading to missing the first few seconds of audio from a video, or a game, etc. Annoying as all F**K.

    The solution, which you can try even if your problem is different, is to disable HDMI power saving. Do the following:

    Easy way:
    • 1) Start Regedit
    • 2) Search for 'ConservationIdleTime'.
    • 3) You will find entries appearing with the following three strings:

      ConservationIdleTime
      IdlePowerState
      PerformanceIdleTime

      The values respectively will be 04, 03, and 04.
    • 4) Change each of these to 00.
    There will be usually 3 instances of this. Only one refers to the HDMI port you are using, but there's no harm in changing all three, and it saves trying to figure it out manually.

    In my experience, the only registry entries to ever use these values are the Nvidia cards, so changing all of them doesn't affect other devices on your system.

    The figuring it out manually way:
    • 1) Open up Device Manager, scroll down to your 'NVIDIA High Defition Audio' entries under 'Sound, video and game controllers'
    • 2) Right-click, select Properties. Then click on the 'Details' tab.
    • 3) Under 'Property' select 'Class GUID'
    • 4) Copy that {string}.
    • 5) Start regedit, search for that {string}. Follow steps 2-4 above in the 'Easy method'.
    This will ensure you only edit the values pertaining to your connected card. However, as above, I've not seen the HDMI power saving values used by any other device, so the 'Easy' way is, well, easier.

    Finally -- these values get reset whenever you install a new driver, so you need to do the regedit change again.

    Go Nvidia, hey?
     
  4. janos666

    janos666 Master Guru

    Messages:
    951
    Likes Received:
    132
    GPU:
    MSI RTX2060 6Gb
    I experience a sound issue lately where my Denon AVR is rarely recognized by Windows as a working sound output (looks as if the device disappeared) after I power-cycle the HDTV (but not the ARV) or Windows turns the displays off (even though DSPM doesn't work with either devices but the signal is cut on the PC side and the HDTV eventually goes into standby if it receives no input). I thought it was a Windows 20H1 issue (it started around the time I updated from 1909).
    Opening the old Sound config panel from the old Control Panel (I placed a shortcut to it on my desktop --- NOT the new 'Modern' control panel!) always helps to re-initialize the AVR (device appears on the list in front of my eyes and sound returns).

    I believe what Martigen suggests is not or only indirectly related. I actually like that auto-mute feature because then the AVR can switch over to SPDIF (optical cable from the HDTV for Netflix, etc) in Auto input mode. This didn't work for me for a long time (I had mute the PC manually when I used the TV's built-in apps). Nowadays it does. (I don't know what changed, I never touched the registry settings. May be it was the switch from Pascal to Turing, I don't know.)
     

  5. judicator

    judicator Member

    Messages:
    37
    Likes Received:
    0
    GPU:
    ROG STRIX-GTX1070 8GB
    Thanks for the very detailed response! I thought for sure this would solve my issue, as I saw someone else suggesting this too and it makes sense that it would. Unfortunately it does not appear to work for me. I've gone through the registry values multiple times to confirm they're set correctly.

    I also can't fix my issue by adjusting the volume bar. The only thing that works for me is adjusting the refresh rate on the receiver.

    It's been a problem *very* rarely in the past. However since last driver update it's every single time my computer goes to sleep the receiver won't recover until I switch the refresh rate (from 59->60 or vice-versa).


     
  6. judicator

    judicator Member

    Messages:
    37
    Likes Received:
    0
    GPU:
    ROG STRIX-GTX1070 8GB
  7. HeavyHemi

    HeavyHemi Ancient Guru

    Messages:
    6,936
    Likes Received:
    930
    GPU:
    GTX1080Ti
    Oops...I'm hit with this bug too. When I resume from sleep, my Samsung plugged in via HDMI no longer exists as an audio device. I have to reboot. So...they screwed up.
    So issue confirmed. I've been using my headset the last few days and didn't notice until I went to watch something online and...oops, no audio on the TV.
    A temp fix for this is to go into device manager, and delete the Nvidia HD driver and reboot. Windows will install an earlier Nvidia driver and, there you go.
     
    Last edited: Apr 5, 2020
  8. janos666

    janos666 Master Guru

    Messages:
    951
    Likes Received:
    132
    GPU:
    MSI RTX2060 6Gb
    There is a much more convenient workaround:
     
  9. HeavyHemi

    HeavyHemi Ancient Guru

    Messages:
    6,936
    Likes Received:
    930
    GPU:
    GTX1080Ti
    Sorry, one of the first things I tried. Does not work. What does work 100% and works resuming from sleep is the method I used. This is just the HD audio driver, not the video driver.
     

Share This Page