HDMI cable causing blurred screen

Discussion in 'Videocards - AMD Radeon Drivers Section' started by marthand, Dec 17, 2010.

  1. marthand

    marthand Master Guru

    Messages:
    344
    Likes Received:
    0
    GPU:
    ATI 5850+Nvidia 8800GTS
    Samsung PX2370 is connected to GPU by an HDMI cable.It causes screen blurry and looks smaller by leaving screen space

    Monitor is capable of 1920X1080

    When it connected to DVI-DVI i looks good.

    Using latest 10.12 catalyst
     
  2. maco07

    maco07 Active Member

    Messages:
    96
    Likes Received:
    0
    GPU:
    7970 3GB Boost
    You should follow Samsung manual instructions... (or at least try to read it, don't bite)

    You need to change HDMI label on Samsung to DVI-PC or something like that to achieve 1:1 Pixel mapping on Samsung TV's... and you have to connect to a specific HDMI labeled HDMI-DVI.
    Anything else will give you blurred image.
     
  3. marthand

    marthand Master Guru

    Messages:
    344
    Likes Received:
    0
    GPU:
    ATI 5850+Nvidia 8800GTS
    Its a monitor not a TV
     
  4. Mufflore

    Mufflore Ancient Guru

    Messages:
    13,040
    Likes Received:
    1,461
    GPU:
    Aorus 3090 Xtreme
    You probably need to set the scaling on the gfx card.
    Open CCC, Desktops & Displays
    Right click your active monitor (little icon) on the bottom left
    select configure.

    Select the scaling options tab and drag the slider all the way to the right to 0%.
     

  5. AATT

    AATT Master Guru

    Messages:
    202
    Likes Received:
    18
    GPU:
    GTX1080
    i tried diffrent monitors a few months ago until i found what i need
    my experience is stick with dvi cable its better

    hdmi for pc kinda suxX
     
  6. FDisk

    FDisk Master Guru

    Messages:
    766
    Likes Received:
    0
    GPU:
    ASUS STRIX GTX970 OC 4GB
    You have to set your monitor to "Just Scan" and not "16:9" mode.
    Then go to scaling options and drag the slider to 0%
    Also disable all the image processing features in your monitor if it got any.

    Anyway Those HDMI inputs are made for Cable boxes, DVD Players, Blu-Ray Players... and so on. The image enhance features are kicked in on most HDMI monitors when you use the HDMI connection. And for most cheap players those enhancements are not a bad idea. But horrible for PC.
    So yes, for a PC just use DVI. This way you will get the clearest signal possible without all the image improvements made for the players.
     
  7. mercury_22

    mercury_22 Member

    Messages:
    21
    Likes Received:
    0
    GPU:
    SAPPHIRE HD 7770
    In CCC set scaling Options to 0% Overscan and Pixel Format to Full RGB !
     

Share This Page