HD5970: Master GPU dead?

Discussion in 'Videocards - AMD Radeon' started by deeptheater, Feb 5, 2014.

  1. deeptheater

    deeptheater New Member

    Messages:
    8
    Likes Received:
    0
    GPU:
    Amd HD5970 2GB (Quadfire)
    Hello,

    i've been running a 2xHD5970 crossfire for more than a year without any issue.

    Yesterday i installed a 3 Dell U2412M eyefinity setup.

    It worked fine for a couple of hour. I reboot more than once.

    Then suddenly, after a Win reboot, it wasn't showing anything.

    POST sounded fine, so i changed the output to the second 5970 and everything was showing on the 3 displays.

    But, sadly, the main card, on GPU-Z, showed only one GPU (not recognized by CCC).

    Is there something I can try? It's like the master GPU has gone, while the slave is still alive (so no POST error even with just that card plugged, but no video output), but useless since i cannot enable crossfire in ccc.

    I've deeply checked CCC: under "Hardware", there's a Card unplugged with the Slave bios, so i can confirm Master GPU is not showing itself anymore.
     
  2. deeptheater

    deeptheater New Member

    Messages:
    8
    Likes Received:
    0
    GPU:
    Amd HD5970 2GB (Quadfire)
    Update: atiflash -i result is only slave cpu, no master found.
    I am hopeless, am i?
     
  3. sTOrM41

    sTOrM41 Master Guru

    Messages:
    504
    Likes Received:
    1
    GPU:
    GTX 970 @ 1500 MHz
    well..

    try it in an other pc,
    if its also not working its defect.

    question:
    can u still use the slave gpu for tricrossfire?
     
  4. deeptheater

    deeptheater New Member

    Messages:
    8
    Likes Received:
    0
    GPU:
    Amd HD5970 2GB (Quadfire)
    Tried and still can't get it working. Atiflash lists just cypress slave gpu. I cannot enable trifire though, maybe if it would be master...
     

  5. LNCPapa

    LNCPapa Master Guru

    Messages:
    421
    Likes Received:
    17
    GPU:
    2xEVGA 1080 Ti FTW3
    Hope your card wasn't from XFX. Otherwise you might still have a warranty on it (4-5 years depending on who from). If it's XFX it wouldn't matter if they still said you had a warranty, they rarely honor it anyway.
     
  6. sverek

    sverek Ancient Guru

    Messages:
    6,073
    Likes Received:
    2,955
    GPU:
    NOVIDIA -0.5GB
  7. Fox2232

    Fox2232 Ancient Guru

    Messages:
    11,809
    Likes Received:
    3,366
    GPU:
    6900XT+AW@240Hz
  8. deeptheater

    deeptheater New Member

    Messages:
    8
    Likes Received:
    0
    GPU:
    Amd HD5970 2GB (Quadfire)
    Ill try with hot air gun. How can i Know which gpu would be the right one?
     
  9. Ripshod

    Ripshod Active Member

    Messages:
    56
    Likes Received:
    0
    GPU:
    HIS HD7950 FAN 3GB
    I thought that trick only worked for old nVidia cards (was it the 8800GT?)
     
  10. PieEyedPiper

    PieEyedPiper Master Guru

    Messages:
    624
    Likes Received:
    10
    GPU:
    RX 580
    AFAIK, it's about getting solder to partially "re-flow". I've "repaired" XBOX 360's and PS3's in this manner.
     

Share This Page