HD 7950 Flickering problem

Discussion in 'Videocards - AMD Radeon' started by Consul, Oct 2, 2014.

Tags:
  1. Consul

    Consul Member

    Messages:
    16
    Likes Received:
    0
    GPU:
    Sapphire R9 280X Vapor-X
    Hello everyone;

    I have a flickering situtation on my SAPPHIRE AMD Radeon HD 7950 OC Edition. It is like, it flickers for a second and goes back to normal. I have tried things like downclocking in AMD Overdrive, 2D and 3D clocking in MSI Afterburner. I don't know what else to do, please help me with this situation.
     
  2. Steppzor

    Steppzor Master Guru

    Messages:
    823
    Likes Received:
    67
    GPU:
    MSI 3080 Ventus OC
    Do games and such work fine?

    Driver replacing you signal cable? Or tried a diffrent port?
    Do you get a pop up saying "Display driver stopped responding" or something?
     
  3. Consul

    Consul Member

    Messages:
    16
    Likes Received:
    0
    GPU:
    Sapphire R9 280X Vapor-X
    Sometimes flickers in game and by flickering, I don't mean texture flickering or something like that. It's screen flickering and happens for less than a second like a frame.
    What do you mean by a different port?
    And yes I used to get "Display driver stopped responding" but it's solved.
     
    Last edited: Oct 2, 2014
  4. Steppzor

    Steppzor Master Guru

    Messages:
    823
    Likes Received:
    67
    GPU:
    MSI 3080 Ventus OC
    By port i mean DP, DVI, HDMI.

    Have you tried another monitor also?
     

  5. Consul

    Consul Member

    Messages:
    16
    Likes Received:
    0
    GPU:
    Sapphire R9 280X Vapor-X
    I haven't tried any other port yet.

    I used to have another monitor while using this card. It flickered on that screen too. I used to have a HD 5770 and used both of my monitors on that and didn't have any problems. It sounds like a card problem but I want to be sure if anything is possible by any other way.
     
  6. Steppzor

    Steppzor Master Guru

    Messages:
    823
    Likes Received:
    67
    GPU:
    MSI 3080 Ventus OC
    I would try swithing DVI, DP or HDMI ports.. and the signal cable.. if not.. try using DDU to clean out the driver and install new drivers
     
  7. Consul

    Consul Member

    Messages:
    16
    Likes Received:
    0
    GPU:
    Sapphire R9 280X Vapor-X
    When I install my drivers I always use DDU. I'm hoping that port change will fix this. Will post the result here.
     
  8. Fox2232

    Fox2232 Ancient Guru

    Messages:
    11,810
    Likes Received:
    3,363
    GPU:
    6900XT+AW@240Hz
    Disable 3rd party OC of any kind.
    Restart.
    Got to CCC, enable Overdrive.
    In CCC create profile of your choice.
    Go to C:\Users\<Your_User>\AppData\Local\ATI\ACE\Profiles
    Open your profile file for editing.

    Code:
    <Feature name="CoreClockTarget_PCI_VEN_1002&amp;DEV_6798&amp;SUBSYS_0B001002&amp;REV_00_4&amp;744803D&amp;0&amp;0008A">
              <Property name="Want_0" value="30000" />
              <Property name="Want_1" value="112500" />
            </Feature>
    Change To:
    Code:
    <Feature name="CoreClockTarget_PCI_VEN_1002&amp;DEV_6798&amp;SUBSYS_0B001002&amp;REV_00_4&amp;744803D&amp;0&amp;0008A">
              <Property name="Want_0" value="45000" />
              <Property name="Want_1" value="112500" />
            </Feature>
    Code:
            <Feature name="MemoryClockTarget_PCI_VEN_1002&amp;DEV_6798&amp;SUBSYS_0B001002&amp;REV_00_4&amp;744803D&amp;0&amp;0008A">
              <Property name="Want_0" value="15000" />
              <Property name="Want_1" value="150000" />
            </Feature>
    Change To:
    Code:
            <Feature name="MemoryClockTarget_PCI_VEN_1002&amp;DEV_6798&amp;SUBSYS_0B001002&amp;REV_00_4&amp;744803D&amp;0&amp;0008A">
              <Property name="Want_0" value="75000" />
              <Property name="Want_1" value="150000" />
            </Feature>
    Save file and in CCC load your profile to enable minimal clocks.
    With this you change minimal card clock for GPU to 450MHz and vRAM to 750MHz.

    My card with this settings eats at idle 23W instead of 11W. I can't care less about that since flickers are what I care about.

    Note:
    - You may have several states: Want_0, Want_1, Want_2, Want_3
    - Ignore my values for Want_1, you have to alter only lowest state Want_0.
    - Don't mismatch CoreClockTarget with MemoryClockTarget
    - Do not use 3rd party OC if you use CCC Overdrive.
    - after making you custom profile you may copy paste entire content from: C:\Users\<Your_User>\AppData\Local\ATI\ACE\Profiles.xml into it (overwrite everything in your custom profile as it is duplicate)
    -> will be bit harder to find what you need but, you'll manage
     
  9. Consul

    Consul Member

    Messages:
    16
    Likes Received:
    0
    GPU:
    Sapphire R9 280X Vapor-X
    Done everything you said. Just gonna have to wait for it (and I hope it doesn't happen).
     
  10. Fox2232

    Fox2232 Ancient Guru

    Messages:
    11,810
    Likes Received:
    3,363
    GPU:
    6900XT+AW@240Hz
    Check with monitoring tool, that your minimal frequencies don't go below 450/750 GPU/vRAM.
    Not that GPU matters, issue is with power state switching on vRAM.
     

  11. Consul

    Consul Member

    Messages:
    16
    Likes Received:
    0
    GPU:
    Sapphire R9 280X Vapor-X
    It's like this: http://i.imgur.com/CzXzeEr.jpg
     
  12. Fox2232

    Fox2232 Ancient Guru

    Messages:
    11,810
    Likes Received:
    3,363
    GPU:
    6900XT+AW@240Hz
    Looks OK.
    (I meant something like GPUz/HWiNFO64 as both are very good at real time monitoring. But it is of little importance now.)
     
  13. Consul

    Consul Member

    Messages:
    16
    Likes Received:
    0
    GPU:
    Sapphire R9 280X Vapor-X
    You are the savior man. Thanks a lot. No more flickering. :banana:
     
  14. Consul

    Consul Member

    Messages:
    16
    Likes Received:
    0
    GPU:
    Sapphire R9 280X Vapor-X
    Well, unfortunately, it flickered once more. I have no hope for this card.

    EDIT: Oh, it flickered while I was writing this too.
     
  15. Fox2232

    Fox2232 Ancient Guru

    Messages:
    11,810
    Likes Received:
    3,363
    GPU:
    6900XT+AW@240Hz
    Too bad, either source of that flicker is other than power state switching or card is somehow defective more than others.

    Mine at default vRAM clocks flickers only if monitor refresh rate is over 60Hz or 2 and more screens are connected.
    And increasing base clocks solved it for many.
    You can try to keep vRAM clocks at constant maximum, it will increase idle power consumption by few more watts.

    If that does not help, return/rma card.
     

  16. Consul

    Consul Member

    Messages:
    16
    Likes Received:
    0
    GPU:
    Sapphire R9 280X Vapor-X
    The last thing I'm going to try is changing the cable from HDMI to DVI and if it flickers again, gonna RMA it.
     
  17. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,605
    Likes Received:
    249
    GPU:
    RX 580 8GB
    In MSI Afterburner, have you touched "Unofficial overclocking" by any chance? Have you tried different drivers?
     
  18. Consul

    Consul Member

    Messages:
    16
    Likes Received:
    0
    GPU:
    Sapphire R9 280X Vapor-X
    I didn't touch that in MSI Afterburner and yes I've tried different drivers of course.
     
  19. MaidenFred

    MaidenFred Active Member

    Messages:
    90
    Likes Received:
    2
    GPU:
    MSI 3070 OC
    Hello,

    I had same problem with my card, especialy in 2D mode and sometimes while playing.

    It was fixed by flashing with a newer bios...
     
  20. Consul

    Consul Member

    Messages:
    16
    Likes Received:
    0
    GPU:
    Sapphire R9 280X Vapor-X
    Sadly, my BIOS driver is released in 2014/04/18 and I have it installed.
     

Share This Page