HD 6770M vs OpenGL !!!

Discussion in 'Videocards - AMD Radeon Drivers Section' started by kt0uchb922, May 10, 2012.

  1. kt0uchb922

    kt0uchb922 New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    vga ati radeon hd 6770m
    I just buy new laptop name: HP Pavilion dv7t-6100 CTO Quad Edition Entertainment Notebook PC ! (vga radeon 6770m 1gb),every thing seem be okay but i can't play any game use OpenGL ! so laggg,such as: gta 4 ! max setting or low setting still lag and stuck,i try to update driver in hp website,i try to install amd mobility display driver 11.9,11.12,12.1,12.4a,but still lag,my bios is f1b and i change switchable graphic to fixed mode but it cant help !!!! wth,what can i do??? what version i can choose to play gta 4 or any game use opengl smoother !!!! plz help me...

    p/s: sorry for my badddddddddddddddddddddd english !!!
     
  2. ibitato

    ibitato Ancient Guru

    Messages:
    4,958
    Likes Received:
    1
    GPU:
    4870X2+4870 1GB on S T260
    GTA IV is a DirectX 9 game .....

    lol?
     
  3. Death_Lord

    Death_Lord Master Guru

    Messages:
    714
    Likes Received:
    7
    GPU:
    Aorus 1080 GTX 8GB
    GTA 4 is quite unoptimized, make sure you have the last patch, with my 6870 and a desktop pc runs okeyish but not maxed out as i would like it, So i bet it will not run any better on a laptop.
     
  4. Benik3

    Benik3 Master Guru

    Messages:
    490
    Likes Received:
    5
    GPU:
    Asus Radeon RX580 4GB
    For me I must have in CCC set choose graphic by power surce or manual, otherwise OpenGL also works very bad... (Lenovo TP Edge E520)
     

  5. SaiBork

    SaiBork Member Guru

    Messages:
    194
    Likes Received:
    1
    GPU:
    MSI GTX 980Ti Gaming 6G
    Also don't forget a 6770m is a mobile gpu which is not nearly as powerful as a desktop version.
     
  6. iBen95111

    iBen95111 Active Member

    Messages:
    60
    Likes Received:
    0
    GPU:
    AMD RX 480 8GB
    Try using Leshcat's drivers: http://drivers.leshcatlabs.org/
    April 18 UnifL works fine for me.
    Make sure CCC is using High-Performance GPU or else it uses Intel which is absolutely horrifying.
    I haven't tried OpenGL with GTA IV (I don't think you can)
     
  7. ibitato

    ibitato Ancient Guru

    Messages:
    4,958
    Likes Received:
    1
    GPU:
    4870X2+4870 1GB on S T260
    and remember that to this game , CPU hurts the most
    although OP has a quad.....
     
  8. kt0uchb922

    kt0uchb922 New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    vga ati radeon hd 6770m
    my old laptop core i3 2gb ram vga hd 5400 can play gta 4 well (low setting) ~24 fps !!! but this laptop core i7 8gb ram and vga hd 6770m 1gb (vga class 1) i don't think it cant play gta 4 ! low or max setting still lag ! wtf ! so sadddddddd
     
  9. xacid0

    xacid0 Master Guru

    Messages:
    442
    Likes Received:
    1
    GPU:
    Zotac GTX980Ti AMP! Omega
    Use MSI Afterburner OSD then check the clocks and gpu usage when u playing GTA4.
     
  10. popeye

    popeye Master Guru

    Messages:
    457
    Likes Received:
    0
    GPU:
    Nvidia GT 730M
    Yes, clocks are probably stuck at 100/150. You can also use GPU-Z to check clocks but need MSI Afterburner or Sapphire Trixx to raise them.
     

  11. link626

    link626 Member

    Messages:
    45
    Likes Received:
    0
    GPU:
    amd 6650m, nvda gtx660m

    popeye, you have idle stuck clocks too ? I got the same problem

    have you reported bug to amd ? maybe it will help get the problem fixed faster. >>> http://www.amdsurveys.com/se.ashx?s=5A1E27D27E29B0E3
     
  12. xacid0

    xacid0 Master Guru

    Messages:
    442
    Likes Received:
    1
    GPU:
    Zotac GTX980Ti AMP! Omega
    done. :D

    it happened in 12.4 and latest beta leaked v8.970 Apr18
     
  13. killer_939

    killer_939 Ancient Guru

    Messages:
    2,598
    Likes Received:
    0
    GPU:
    Radeon 7950 @ 1100/1500
    I can play GTA4 with enb on mid on my laptop Radeon 6770M at 35-60fps. Owns my ancient 8800GT in that game.
     
  14. kt0uchb922

    kt0uchb922 New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    vga ati radeon hd 6770m
    how can u play game with graphics card like 6770m @@ plz help,wich driver version you choose ???
     
  15. killer_939

    killer_939 Ancient Guru

    Messages:
    2,598
    Likes Received:
    0
    GPU:
    Radeon 7950 @ 1100/1500
    Atm it's 12.2. 12.3 and 12.4 leshcat drivers gave me BSOD's when putting the lid down or no screen turning on when taking it out of sleep x.x..

    This is the fps/graphics i get on my 6770m.
    http://img521.imageshack.us/img521/9695/gtaiv2012063022473920.jpg
     

  16. popeye

    popeye Master Guru

    Messages:
    457
    Likes Received:
    0
    GPU:
    Nvidia GT 730M
    Leshcat drivers are for switchable laptops. Do you have one. Just seeing your specs on the side here, you have desk top.
    If you have a switchable laptop then try the Intel 2559 driver included in several of leshcat packages.

    What model of laptop? There are some special install ticks for Sony/HP.
     
  17. killer_939

    killer_939 Ancient Guru

    Messages:
    2,598
    Likes Received:
    0
    GPU:
    Radeon 7950 @ 1100/1500
    hp dv6 with a radeon 6770m switchable, 2630qm etc x.x. I ticket the install for hp, fact is my laptop was either not stable with the newer drivers, would bsod when lid closed, screen wouldn't turn on after sleep or it would stay in 2d clocks when entering games so i went back to 2.2 and they are 100% perfect so far. No crashes and everything works! Only game i have tried tho is GTA4 to get that SS and test it doesn't go to 2d clocks tho, lol. Over gaming i think. :bang:

    Oh and yes i do have a desktop, its not very portable tho.. o.o
     
  18. popeye

    popeye Master Guru

    Messages:
    457
    Likes Received:
    0
    GPU:
    Nvidia GT 730M
    My clock throttles are very flaky also. Sometimes work, sometimes don't. I have to go into CCC Graphics OverDrive and uncheck it, apply, check again and apply. Then works for awhile.
     

Share This Page