1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HD 4770 softmod to FirePro V8700, success!

Discussion in 'Rivatuner Statistics Server (RTSS) Forum' started by Clint, May 28, 2009.

  1. Styler

    Styler Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    HD3850@FGL-7700
    gellmar
    Forgive me generous master, but this is bull**** :). Maya always was being only OpenGL cross-platform application.

    This is my old Maya test with X800GTO-256(AGP)@FireGL X3-256
    others comp. configuration in my info

    scene spec:
    1.076.400 - polygons (5 poly spheres)
    3 direction lights
    texture (1 procedural (simple 2D-perlin noise))
    1280x1024@100
    Driver settings: AA-off, AF-16x perf.
    ----------------------------------
    Catalist 6.9 (atioglxx.dll(6067))
    ----------------------------------
    12.5 fps - wire
    4.4 fps - shaded
    4.4 fps - shaded + backface culling
    4.4 fps - shaded + lights
    4.4 fps - shaded + lights + backface culling
    2.9 fps - shaded + lights + textured
    2.9 fps - shaded + lights + textured + backface culling
    2.9 fps - shaded + textured
    2.9 fps - shaded + textured + backface culling

    ----------------------------------
    FireGL 8.293 (atioglgl.dll(6068))
    ----------------------------------
    35.5 fps - wire
    67.9 fps - shaded
    94.3 fps - shaded + backface culling
    41 fps - shaded + lights
    51.3 fps - shaded + lights + backface culling
    13 fps - shaded + lights + textured
    16.1 fps - shaded + lights + textured + backface culling
    20 fps - shaded + textured
    30 fps - shaded + textured + backface culling
    ----------------------------------

    so... you may try to outstrip X3-256 for beginning ;)
     
    Last edited: Jul 27, 2009
  2. gellmar

    gellmar Member Guru

    Messages:
    146
    Likes Received:
    0
    GPU:
    Sapphire HD3850 1024MB
    Styler,

    it may be a bull****, but AFAIK Autodesk uses DirectX since 2008 as the primary platform for windows.

    http://www.mcadforums.com/forums/files/autodesk_inventor_opengl_to_directx_evolution.pdf

    Which version do I need to run your test? I will check your test and Maryus3D's one.

    gellmaR

    PS: Your GPU-Z shows 0x9515, and this is weird. V7700 should be 0x9511 (like shown in ATI Feature Test output), HD3850 - 0x9505. And 0x9515 = 0x9505 | 0x9511, that's weirdo ;)
     
    Last edited: Jul 27, 2009
  3. Maryus3D

    Maryus3D Active Member

    Messages:
    97
    Likes Received:
    0
    GPU:
    Zotac GTX 285
    Maya 2009 :). Is still OpenGL not DX :infinity: .
     
  4. gellmar

    gellmar Member Guru

    Messages:
    146
    Likes Received:
    0
    GPU:
    Sapphire HD3850 1024MB
    I have checked Bike and TextBench tests on Maya 2k9 x64 (Windows 7).

    TextBench gave me 16.5 fps (low quality) / 60 fps (high quality) - strange ;)
    Bike gave me 8.5 fps (low) / 2.5 (high)

    i could not run mental ray cause it ate all my memory :(

    gellmaR
     

  5. Maryus3D

    Maryus3D Active Member

    Messages:
    97
    Likes Received:
    0
    GPU:
    Zotac GTX 285
    wooowwww :( very bad news for maya users. A modded 8800 ultra gave 50 fps for the bike and a Quadro FX 580 gave 50 fps for both scenes. To bad. A don't think is your fault or radeon card fault. Is all about ATi stupid FirePro drivers. A real V5700 gave an awful results in maya :(. You can see on page 3.

    Anyway 10x gellmar :cheers:
     
    Last edited: Jul 28, 2009
  6. gellmar

    gellmar Member Guru

    Messages:
    146
    Likes Received:
    0
    GPU:
    Sapphire HD3850 1024MB
    I think the stupid problem is the lack of RAM on Win7 :(
    OS consumes 400 MB itself + maya 2009 unlim without scene 260MB + rendering on 1280*1024 = hmmmm, my 2GB were out and the swapping began. I will try XP64, it consumes 200MB itself (that's my modded OS ;)) Also I am trying to get a render internal dump for real V8700! It may work well with maya. If so, we solve our problems!

    gellmaR

    PS: I definitely need a new rig ;) And I know that because I can't run the upcoming SolidWorks 2010 :(( So I have to open a donation account for ATIFuse despite of this is my hobby :)
     
    Last edited: Jul 29, 2009
  7. Bluefirexp

    Bluefirexp Master Guru

    Messages:
    596
    Likes Received:
    0
    GPU:
    2x Gainward GTX460 GS 2GB
    @gellmar

    Donation is a good idea - if AtiFuse works like promised it will save me much time, so i'm going to donate. I hope we see it soon! :)
     
  8. Maryus3D

    Maryus3D Active Member

    Messages:
    97
    Likes Received:
    0
    GPU:
    Zotac GTX 285
    I hope ATi will fix the drivers. I think i will buy a cheap 8800GT and bios mod the card if ATi will not fix the drivers. Same happen on XP 32 & 64 take a look on page 3 on this thread and you'll see what is going on. Mental ray & maya software is optimized for CPU :(. A real FirePro V5700 give the same score as a regular radeon. So is not win7/xp/64&32 fault or yours, is ATi :(. To bad. :wanker:
     
  9. ultrabitch

    ultrabitch Member

    Messages:
    27
    Likes Received:
    0
    GPU:
    N/A
    Hallo :)
    I see there is some progress with the drivers, I just tested a laptop with 2600 hd card.
    This was on windows xp (server 2003 to be precise), driver 8.603. I modded the driver using device id 958f.

    In .inf I used the string: "ATI Mobility FireGL V5600"

    Display Properties -> Adapter tab shows: "ATI Mobility FireGL Graphics Processor (0x958F)"

    But I installed the classic control panel and it says (in Details tab):
    "Device ID 9581" (this is the original device id)

    The specview result for maya-02 is 96.14.

    The bike.ma on latest maya 2009 sp1a is
    smooth shade: 8.5 - 11 fps
    wireframe : ~30 fps
    high quality: 2.5 fps

    I tried also running specapc for maya 2009 and it could not run a complete run.. Also there are artifacts appearing in the hands scene. (I know these are high polygon count models, if that has to do with anything). Does anyone else notices these? All features though, like overlay seem to be there, sculpting works fine and some of my simple scenes work allright, till now i have been using it for 2-3 days (not very intensively though).

    Has anyone tried the newer driver?
    I would love to beta test ATIFuse, i have a clean install and spare room for vista/win 7 also.

    AFAIK control panel and/or CCC are responsible for applying the settings in ATI driver, it was called 'autodection' or something like that. Should I try with id 958C or install CCC ? I noticed that specview was a little jerky before installing the control panel (maybe this was a placebo effect though..)
     
  10. tanglangboxer

    tanglangboxer New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    Vapor-X Radeon 4870 1GB
    @gellmar

    I have a new rig right now that is itching to try your ATIFuse. I would also be happy to make a donation. I work a lot in CAD and Finite Element Analysis. I also dabble in 3D animation, so you would have plenty of test cases. Thanks for all of your work on this.

    Mantis
     

  11. Styler

    Styler Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    HD3850@FGL-7700
    Anybody with real FireGL card.

    Please, checking following:
    1. Install Driver
    2. Install CPanel (not CCC)

    will in adjusting the driver this tab (applications compatibles list)? Just like in picture?

    [​IMG]
     
  12. gellmar

    gellmar Member Guru

    Messages:
    146
    Likes Received:
    0
    GPU:
    Sapphire HD3850 1024MB
    Styler,

    I can ask my friends with V8700 to do this, however they don't have Maya :(

    gellmaR
     
  13. Styler

    Styler Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    HD3850@FGL-7700
    gellmar
    Thanks for this ;)

    regrettable :(

    Some words about "why this necessary". In previous driver's version (exactly in 8.301.0.0) acceleration in maya could be enabled only after activation Maya-compatibles from list. I think it still the same old song =).
     
  14. Maryus3D

    Maryus3D Active Member

    Messages:
    97
    Likes Received:
    0
    GPU:
    Zotac GTX 285
    Styler test with the bike and textbench scenes please :D.
     
  15. Styler

    Styler Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    HD3850@FGL-7700
    Maryus3D

    bike.ma on maya 2009 sp1a
    1680x1050@60

    smooth shade: 10.4 fps
    wireframe : 38.5 fps
    high quality: 0.9 fps

    ---
    It's not good result. As i said when we can unlock full FGL CP features, fps will be extremely high, particularly with "shade mode"+"backface culling" options.
     

  16. Maryus3D

    Maryus3D Active Member

    Messages:
    97
    Likes Received:
    0
    GPU:
    Zotac GTX 285
    Thenks Styler :).
     
    Last edited: Aug 2, 2009
  17. Maryus3D

    Maryus3D Active Member

    Messages:
    97
    Likes Received:
    0
    GPU:
    Zotac GTX 285
    Last edited: Aug 2, 2009
  18. gellmar

    gellmar Member Guru

    Messages:
    146
    Likes Received:
    0
    GPU:
    Sapphire HD3850 1024MB
    Folks, I guess I found why we have such confusing results in ATI mod... the driver gives the radeon settings to the render despite of the patch (i.e not all entries patched). However, I have no second machine again (it has gone with the friend cause it was has :()so I can only do static patches.

    gellmaR
     
  19. NormanBates

    NormanBates Master Guru

    Messages:
    376
    Likes Received:
    0
    GPU:
    ATI HD3870 / ATI HD4670

Share This Page