HD 2300 Modded Driver of latest 13.5 Beta 2 Release 32/64bit.

Discussion in 'Videocards - AMD Radeon Drivers Section' started by AmiloMan, May 28, 2013.

  1. AmiloMan

    AmiloMan Master Guru

    Messages:
    333
    Likes Received:
    7
    GPU:
    Gigabyte R9 270X 4GB
    HD 2300 Digital Fantasy Modded Driver of latest 13.5 Beta 2 Release 32/64bit.

    If you have a HD2300 or X2300 Legacy card you can give these drivers a go.
    Tested and working flawlessly on a Mobility HD2300.
    EDIT 1
    Windows 7 32/64
    Windows 8 32/64

    Edit 2
    They use dll's from 10.2 legacy drivers for compatibility with this DirectX 9 card. The newer Legacy driver dll's don't support DirectX 9 cards at all and that is why the older one's are used.No files are altered or changed in any way, just newer incompatible files are replaced with the older one's.
    Compared to the Legacy installation of 10.2 drivers these have better performance.

    See previous post for screen shots and what's new
    http://forums.guru3d.com/showpost.php?p=4606137&postcount=4

    You can grab them from this previous post:
    http://forums.guru3d.com/showthread.php?p=4606224#post4606224

    [​IMG]


    Known Issues :
    Windows Index random crash if you run it.
    Forcing Native mode in Firefox will cause Firefox to crash on some websites.
     
    Last edited: May 29, 2013
  2. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    Can you specify what Operating System these drivers are for? I think it would be time consuming to download a driver to only find out it does not support your Operating System.


    EDITED
    This Driver Should also support older graphic cards such as the ones listed below
    Due to using 10.2 Legacy Driver as it's base.

    ATI Radeon 9500 Series
    ATI Radeon 9550 Series
    ATI Radeon 9600 Series
    ATI Radeon 9700 Series
    ATI Radeon 9800 Series
    ATI Radeon X300 Series
    ATI Radeon X550 Series
    ATI Radeon X600 Series
    ATI Radeon X700 Series
    ATI Radeon X800 Series
    ATI Radeon X850 Series
    ATI Radeon X1050 Series
    ATI Radeon X1300 Series
    ATI Radeon X1550 Series
    ATI Radeon X1600 Series
    ATI Radeon X1650 Series
    ATI Radeon X1800 Series
    ATI Radeon X1900 Series
    ATI Radeon Xpress Series
    ATI Radeon X1200 Series
    ATI Radeon X1250 Series
    ATI Radeon X2100 Series
     
    Last edited: May 29, 2013
  3. AmiloMan

    AmiloMan Master Guru

    Messages:
    333
    Likes Received:
    7
    GPU:
    Gigabyte R9 270X 4GB
    Thanks for pointing that out , they are for :

    Windows 7 32/64
    Windows 8 32/64
     
  4. AmiloMan

    AmiloMan Master Guru

    Messages:
    333
    Likes Received:
    7
    GPU:
    Gigabyte R9 270X 4GB
    No it it will not because I specifically designed it for the HD 2300,it will NOT install on another machine.
    This is for HD 2300 only guys...sorry.
    Be patient I will release a modder soon for all DirectX9 cards :)
     

  5. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    I have a question for you... are you currently using the Dxva files from 12.8?
     
  6. AmiloMan

    AmiloMan Master Guru

    Messages:
    333
    Likes Received:
    7
    GPU:
    Gigabyte R9 270X 4GB
    No i'm not I told you we can't use anything higher than 10.2 on DX9 cards, DXVAchecker will be blank and no video playback.
    Using 10.2 DXVA ATM
     
  7. dellon132

    dellon132 Ancient Guru

    Messages:
    1,898
    Likes Received:
    0
    GPU:
    HD 5570 1 GB DDR3
    Just checking (I was looking at your old forum)... I think you will need to change the download link as it takes a really long time to download the driver. (I haven't taken a look at it yet.)

    When using the 10.2 Legacy driver did CCC have a tab called "My VGA Display or DVI"?
     
  8. AmiloMan

    AmiloMan Master Guru

    Messages:
    333
    Likes Received:
    7
    GPU:
    Gigabyte R9 270X 4GB
    I can't remember LOL its been a while since I used the old 10.2 drivers , yes I think I will add some alternate links in a few hours for guys who don't have rapidgator accounts.
     
  9. AmiloMan

    AmiloMan Master Guru

    Messages:
    333
    Likes Received:
    7
    GPU:
    Gigabyte R9 270X 4GB
    Last edited: May 30, 2013
  10. AmiloMan

    AmiloMan Master Guru

    Messages:
    333
    Likes Received:
    7
    GPU:
    Gigabyte R9 270X 4GB
    Posts your results once you have tried them out.
     

  11. Espionage724

    Espionage724 Guest

    Hmm, so this isn't compatible with a Radeon Xpress 200M/1150?
     
  12. AmiloMan

    AmiloMan Master Guru

    Messages:
    333
    Likes Received:
    7
    GPU:
    Gigabyte R9 270X 4GB
    yes, unfortunately I made it for the HD 2300 and X2300 series only.
     
  13. e295c

    e295c New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    Radeon X2300 HD
    Gateway E295c

    About to test these out.. I'll post back about my experience. Thanks for your effort.



    Had some issues and unfortunately did not work.
    kdbsync.exe stopped working something to do with amdocl.dll

    Driver did not install or work correctly on my system.

    Gateway e295c Win 7 pro 64
     
    Last edited: Oct 7, 2013
  14. AmiloMan

    AmiloMan Master Guru

    Messages:
    333
    Likes Received:
    7
    GPU:
    Gigabyte R9 270X 4GB
    Kbsync errors are annoying but you can ignore it. As for the driver not loading that might be because of your card's dev-id. What is your dev-id?
     
  15. e295c

    e295c New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    Radeon X2300 HD
    7211 Installed.. I got it after attempting the install of a separate catalyst package, no Kbsync error this time. Not sure if it working had anything to do with the other package attempt.

    ATI Mobility Radeon HD 2300 (Digital Fantasy MOD)

    Driver Version 12.102.3.0
    4/16/2013 versus
    the old 8.56.1.16 4/25/2009
    that windows 7 update installs.

    Notes:
    If you try to update the driver through windows, it will push it's driver back on.

    The mod driver will not load even after installing unless, disable driver signature enforcement is turned off every time or I imagine by completely turning the signature feature off. If windows loads without turning off device signature enforcement, you get: This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)

    No AMD graphics driver is installed or the AMD driver is not functioning. Please install the AMD driver appropriate for your hardware.

    Ran 3Dmark06, scored a 400 with the new mod driver, scored 432 with default Windows 07 Driver 8.56.1.16 ATI Mobility Radeon HD 2300 (Microsoft Corporation WDDM 1.1)


    Ran 3DMark2001 SE, Mod driver scored 9261, old driver scored 9327.

    I'm not sure of the benefits of using the mod driver. Great effort though..
     
    Last edited: Oct 9, 2013

  16. DrLightman

    DrLightman Member

    Messages:
    26
    Likes Received:
    0
    GPU:
    XFX 5870 XT
    Does anyone by any chance has the drivers? The links in the post above are both broken. Help would be very much appreciated. I need the drivers for an ATI X2300 and Windows 8.1, I would go with the Base Microsoft if I could rise resolution above 1024x768, while the laptop can go up to 1280x800 (Samsung R60Plus), but it doesn't let me go above 1024x768.

    Thank you
     
  17. DrLightman

    DrLightman Member

    Messages:
    26
    Likes Received:
    0
    GPU:
    XFX 5870 XT
    Thank you AmiloMan for getting back to me on this.
     
  18. domoreyoga

    domoreyoga New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    Mobility Radeon X2300
    I'm looking to try these drivers out on windows 10 on an old laptop if they are still available somewhere. The stock windows 10 drivers don't do a great job with the x2300.

    Any help would be greatly appreciated.
     
  19. k1net1cs

    k1net1cs Ancient Guru

    Messages:
    3,783
    Likes Received:
    0
    GPU:
    Radeon HD 5650m (550/800)
    Windows 10 has a newer WDDM that is 2.0.
    Win7 has 1.1, Win8 has 1.2, and Win8.1 has 1.3.

    A franken-driver made out of a Win7 driver set would be too much work.
    Even adding Win8 support was already pushing it.
     
  20. domoreyoga

    domoreyoga New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    Mobility Radeon X2300
    I see, too much to hope for then. Thanks for the reply.
     

Share This Page