Having an issue.. with Toshiba Satellite s50-b

Discussion in 'Videocards - AMD Radeon' started by Michael A Dean, Mar 9, 2019.

  1. Michael A Dean

    Michael A Dean New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    AMD Radeon R7 M260
    I recently reinstalled Windows 10 on my laptop with an AMD Radeon R7 M260 graphics card. I try to install its display adapter and I am welcomed with Intel Graphics HD installed and says my card is an Intel HD Graphics 4400.. which it is not. Tried using the DDU Installer and reinstalled my amd drivers and boom.. Intel again. Any ideas.. why this would happen.
     
  2. GlennB

    GlennB Master Guru

    Messages:
    207
    Likes Received:
    51
    GPU:
    Sapphire Vega 56 EK
    Your system has an Intel CPU which also comes with the Intel HD 4400 and has the AMD R7 as an extra card. The system can switch from card to card depending on the task it needs to do. If you are using a browser or other simple tasks it will use the Intel card and it will only switch to the AMD card when there is a need for it to conserve energy.
     
    Michael A Dean likes this.
  3. anticupidon

    anticupidon Ancient Guru

    Messages:
    4,014
    Likes Received:
    783
    GPU:
    integrated
    ^ Very clear explanation and true. Some OEMs have specific drivers for switching between GPUs. Installing generic drivers it's a hit or miss.
     
    Michael A Dean likes this.
  4. Michael A Dean

    Michael A Dean New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    AMD Radeon R7 M260
    Interesting. It used to display the amd display adapter as the main one but now it doesnt. Any recommendations on what to do? The system doesnt even recognize that the hardware exists within the system anymore.
     

  5. GlennB

    GlennB Master Guru

    Messages:
    207
    Likes Received:
    51
    GPU:
    Sapphire Vega 56 EK
    Start with installing the drivers provided by Toshiba as suggested by anticupidon. I have a laptop myself with both the Intel HD and a Geforce 730 and installing drivers from Nvidia.com never seem to work really well and requires a lot of tinkering to make it work properly.
     
  6. Chastity

    Chastity Ancient Guru

    Messages:
    1,978
    Likes Received:
    492
    GPU:
    Nitro 390/GTX1070M

Share This Page