1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

gtx1080 problems, fps drops, hitching etc(in games like overwatch, smite etc)

Discussion in 'Videocards - NVIDIA GeForce' started by BlackNova92, Jul 20, 2019.

  1. BlackNova92

    BlackNova92 Member

    Messages:
    17
    Likes Received:
    4
    GPU:
    16gb
    basically since the latest update, my gtx1080 can barely keep a stable 144fps, it will drop frames every couple minutes for no reason, plus i'm also playing at 720p @75% renderscale and basically everything on low/off.
    i got easily 200+up to 300 frames, now the game feels like utter garbage and i was wondering what can i do, seriously i tried everything, uninstalled drivers, the game, tried every possible driver version, checked temps etc. everything is fine.

    if you know something i could test/try, PLEASE let me know~~~

    regards.
     
  2. Hyderz

    Hyderz Active Member

    Messages:
    93
    Likes Received:
    22
    GPU:
    GTX 1070ti
    could be the psu not delivering enough juice to your gpu and system.
     
  3. Astyanax

    Astyanax Ancient Guru

    Messages:
    2,582
    Likes Received:
    650
    GPU:
    GTX 1080ti
    update as in?

    Driver?
    Windows?
     
  4. Ieppo

    Ieppo Member

    Messages:
    12
    Likes Received:
    0
    GPU:
    GeForce GTX 1080 GameRock
    If it's because overwatch update it may be audio bug that drops your fps. While in-game alt-tab to windows, put spatial audio on, go back to game,back to windows and disable spatial audio. After this if it was audio bug your fps should be back to normal. Also there have been a "bug" that gpu doesn't raise core clock speed when playing ow but i don't think that is that cause you have checked everything xD
     

  5. BlackNova92

    BlackNova92 Member

    Messages:
    17
    Likes Received:
    4
    GPU:
    16gb
    well my 1080 is bored(that is how it looks tbh) it won't boost if i play on low settings whatsoever.
    i don't have spatial audio on my current w10 version, would it work if i enable/disable stuff inside of my soundcard driver? like enable xear surround or the surround(environment)? no clue if that would make a difference tho since it's a completely different thing i guess.
     
  6. Caesar

    Caesar Master Guru

    Messages:
    632
    Likes Received:
    214
    GPU:
    GTX 1070Ti Titanium
    What i7 cpu you are using??

    Post some graphs with HWMonitor
     
  7. mbk1969

    mbk1969 Ancient Guru

    Messages:
    7,495
    Likes Received:
    4,035
    GPU:
    GeForce GTX 1070
    Have you tried to set power management mode to "Prefer maximum performance" (globally or for the game profiles) in NVIDIA Control Panel?
    Have you tried to switch to performance power plan in Windows Control Panel?
     
  8. Ieppo

    Ieppo Member

    Messages:
    12
    Likes Received:
    0
    GPU:
    GeForce GTX 1080 GameRock
    Well that sound issue only occurs if you have windows sonic or dolby atmos for headphone in windows. Setting doesn't have to be on for it to occur. If the problem is only in ow....try setting resolution scale to automatic(should set it to 141% after restart) and resolution to what your monitor supports.
     
  9. BlackNova92

    BlackNova92 Member

    Messages:
    17
    Likes Received:
    4
    GPU:
    16gb
    i tried playing with the auto render scale already, but for me it's a no-go tbh, since the higher renderscale adds inputlag(at least it feels like, basically, it feels a lot snappier on a lower render scale, if that makes sense),

    anyway, i will wipe my system, sadly... but if nothing else helps... it's not only in OW anymore btw, even in games like smite, my 1080 can't keep a solid 144fps anymore, it makes zero sense, really.
     
  10. A M D BugBear

    A M D BugBear Ancient Guru

    Messages:
    2,786
    Likes Received:
    163
    GPU:
    2 1080ti-XOC BIOS
    Ever tried testing your psu??? your +12v stability under load???

    If so, what is the +12v that the multi-meter is reading..

    Thanks again.
     

Share This Page