GTX 2070 sRGB output

Discussion in 'Videocards - NVIDIA GeForce' started by Tue Nguyen, Oct 27, 2018.

Tags:
  1. Tue Nguyen

    Tue Nguyen New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    GTX 2070
    Hi guys,
    Just got myself a big upgrade after like 10 year sor more.
    A VGA Palit GTX 2070 and LG 4k HDR wide gamut monitor (99% sRGB).
    Just wonder how can I enable sRGB output for the card to utilize the wide gamut feature of the monitor. And to see how my images in Lightroom CC look any better.
    I load the monitor ICC profile already, also tried to load the sRGB ICC provided in Windows.
    I have tried several setting that I can find from Nvidia Control panel but seem that no setting available.
    Is it not possible on the 2070, I have to go to 2080 or even a Quadro? If this is the case, I will stop thinking about this.
    Or what else should I do in Windows, color profile...?
    Thanks a lot.
     
  2. RealNC

    RealNC Ancient Guru

    Messages:
    3,142
    Likes Received:
    1,367
    GPU:
    EVGA GTX 980 Ti FTW
    sRGB is the default. You don't need to change anything. If your monitor supports actual HDR, then you can enable HDR in games that support it. You can also enable it for the Windows desktop, but this might break things (wrong colors and whatnot.)
     
  3. Tue Nguyen

    Tue Nguyen New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    GTX 2070
    So I understand that sRGB is default, even if it shown as RGB in "Color Output" field in Nvidia Control Panel. Is that true?
    HDR: I have to manually enable it in Windows display settings. And yes Windows 10 still bad at showing correct gamma (or contrast) in SRD windows... all look greyish... other than that HRD videos in Youtube look great. I have not owned any HRD games to try the feature, but I believe the monitor should switch to HDR mode when it receive HRD signals frm the computer.
     
  4. RealNC

    RealNC Ancient Guru

    Messages:
    3,142
    Likes Received:
    1,367
    GPU:
    EVGA GTX 980 Ti FTW
    Yes.

    Yep.
     

  5. FatBoyNL

    FatBoyNL Ancient Guru

    Messages:
    1,543
    Likes Received:
    29
    GPU:
    MSI 2070 Gaming Z
    You could try switching from HDMI to DisplayPort cable or the other way around.
    And please check if the Output Dynamic Range is set to Full, not Limited.
     
  6. Tue Nguyen

    Tue Nguyen New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    GTX 2070
    Thanks a lot mate.
     
  7. Tue Nguyen

    Tue Nguyen New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    GTX 2070
    I am on Displayport now and set color out put to 10 bit as well as Full for DR in Nvidia Control Panel.
     
  8. FatBoyNL

    FatBoyNL Ancient Guru

    Messages:
    1,543
    Likes Received:
    29
    GPU:
    MSI 2070 Gaming Z
    OK, but did that improve overall image quality on your monitor? ;)
     
  9. Tue Nguyen

    Tue Nguyen New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    GTX 2070
    It is the setup right after I plug the 2070 and the monitor in.
    Just tried to reduced the settings to 8bit/Limited, I can see more colors on my images, worth the investment actually.
     

Share This Page