GTA V Shadow Fix

Discussion in 'Game Tweaks and Modifications' started by mkeezay29, May 1, 2015.

  1. mkeezay29

    mkeezay29 Master Guru

    Messages:
    225
    Likes Received:
    0
    GPU:
    Zotac GTX 760 4GB
    This fixes the problem of shadows disappearing about 7 feet from your character, I found it very annoying, especially around chain link fences, they would just completely disappear just feet away, these shadows remain at a long distance, the links may slim out as you get further, but they remain, and more importantly it fixes ground shadows just appearing and disappearing depending on your distance.

    You Must Make The File "READ ONLY" After Any Editing, The Game Will Change Settings Back To Default Values If You Don't


    Only the next two values need to be changed, you need to open your settings.xml file in My Documents/Rockstar Games/GTA V/settings.xml

    Find these two values

    Code:
        <Shadow_SplitZStart value="X.XXXXXX" />
        <Shadow_SplitZEnd value="X.XXXXXX" />
    and change them to this
    Code:
        <Shadow_SplitZStart value="1.000000" />
        <Shadow_SplitZEnd value="0.999900" />
    To make Shadows even better you can make sure you have these enabled, or in the case of ShadowDistance put it anywhere from 1.000000 to 1.90000 without problems, although it will use more resources the higher the distance, putting it above 1.900000 can cause a small shadow glitch to the front right of your character.
    Code:
    <Shadow_Distance value="1.900000" />
    <Shadow_LongShadows value="true" />
    <Shadow_SoftShadows value="5" />
    <UltraShadows_Enabled value="true" />
    <Shadow_ParticleShadows value="true" />
    Code:
    <Shadow_SoftShadows value="4" />
    for AMD soft shadows, 123 for low medium high


    VIDEOS 1080p Better Shadows Video Now Up, 1080p Vanilla Soon


    Vanilla Shadows

    Watch Vanilla Shadows for Reference



    Improved Shadows (VIDEO 2 1080p)

    Watch Improved Shadows in Action



    IMAGES

    EDIT: Here are some pics of my shadows in when working properly

    [​IMG]

    [​IMG]

    [​IMG]


    [​IMG]

    [​IMG]

    BEFORE Shadow Fix (taken from user fabioid)


    [​IMG]
    [​IMG]
    [​IMG]
     
    Last edited: May 3, 2015
  2. gerardfraser

    gerardfraser Ancient Guru

    Messages:
    2,862
    Likes Received:
    502
    GPU:
    R9 290 Crossfire
    Thanks for sharing.I might try it out see how it goes.
     
  3. mkeezay29

    mkeezay29 Master Guru

    Messages:
    225
    Likes Received:
    0
    GPU:
    Zotac GTX 760 4GB
    You're welcome, I uploaded some videos in 720p last night, this was before the shadows are as good as they are now, but you can still see the improvement pretty easy, just watch the shadows of the chain link fence on the wall

    Vanilla version
    https://www.youtube.com/watch?v=nPLrrViwHqA

    My Version, uploading what shadows look like with current settings now, this is from yesterday
    https://www.youtube.com/watch?v=u3Fs_ftMWok
     
  4. Quentin's_SweetFX

    Quentin's_SweetFX Master Guru

    Messages:
    396
    Likes Received:
    0
    GPU:
    SAPPHIRE R9 OC 270X 4GB
    Thanks mate i needed this :)
     

  5. mkeezay29

    mkeezay29 Master Guru

    Messages:
    225
    Likes Received:
    0
    GPU:
    Zotac GTX 760 4GB
    You're welcome, in case I forgot to mention, make sure to make the file read only or it will get changed back when you enter the menu.
     
  6. dollmaster

    dollmaster Member Guru

    Messages:
    155
    Likes Received:
    4
    GPU:
    ASUS GTX 970 STRIX 4GB
    Shadows are still rendering as I walk. How can I fix it?
     
  7. mkeezay29

    mkeezay29 Master Guru

    Messages:
    225
    Likes Received:
    0
    GPU:
    Zotac GTX 760 4GB
    Did you remember to make the file Read Only?

    also open the file in your browser to make sure there aren't any errors

    The <Graphics> settings in your file should something like this, although your values for other properties might be different

    Code:
       <graphics>
        <Tessellation value="3" />
        <LodScale value="1.000000" />
        <PedLodBias value="0.000000" />
        <VehicleLodBias value="0.000000" />
        <ShadowQuality value="3" />
        <ReflectionQuality value="3" />
        <ReflectionMSAA value="2" />
        <SSAO value="2" />
        <AnisotropicFiltering value="16" />
        <MSAA value="0" />
        <MSAAFragments value="0" />
        <MSAAQuality value="0" />
        <TextureQuality value="2" />
        <ParticleQuality value="2" />
        <WaterQuality value="2" />
        <GrassQuality value="3" />
        <ShaderQuality value="2" />
        <Shadow_SoftShadows value="5" />
        <UltraShadows_Enabled value="true" />
        <Shadow_ParticleShadows value="true" />
        <Shadow_Distance value="1.900000" />
        <Shadow_LongShadows value="true" />
        <Shadow_SplitZStart value="1.000000" />
        <Shadow_SplitZEnd value="0.999900" />
        <Shadow_aircraftExpWeight value="0.999999" />
        <Shadow_DisableScreenSizeCheck value="true" />
        <Reflection_MipBlur value="true" />
        <Texture_MipLodBias value="0" />
        <FXAA_Enabled value="true" />
        <TXAA_Enabled value="false" />
        <Lighting_FogVolumes value="true" />
        <Shader_SSA value="false" />
        <DX_Version value="2" />
        <CityDensity value="1.000000" />
        <PedVarietyMultiplier value="1.000000" />
        <VehicleVarietyMultiplier value="0.100000" />
        <PostFX value="2" />
        <DoF value="true" />
        <HdStreamingInFlight value="true" />
        <MaxLodScale value="1.000000" />
        <MotionBlurStrength value="0.000000" />
      </graphics>
     
  8. dollmaster

    dollmaster Member Guru

    Messages:
    155
    Likes Received:
    4
    GPU:
    ASUS GTX 970 STRIX 4GB
    Here is like this:

    Code:
       <graphics>
        <Tessellation value="1" />
        <LodScale value="1.000000" />
        <PedLodBias value="0.000000" />
        <VehicleLodBias value="0.000000" />
        <ShadowQuality value="3" />
        <ReflectionQuality value="3" />
        <ReflectionMSAA value="0" />
        <SSAO value="2" />
        <AnisotropicFiltering value="0" />
        <MSAA value="0" />
        <MSAAFragments value="0" />
        <MSAAQuality value="0" />
        <TextureQuality value="1" />
        <ParticleQuality value="1" />
        <WaterQuality value="2" />
        <GrassQuality value="1" />
        <ShaderQuality value="2" />
        <Shadow_SoftShadows value="5" />
        <UltraShadows_Enabled value="false" />
        <Shadow_ParticleShadows value="true" />
        <Shadow_Distance value="1.900000" />
        <Shadow_LongShadows value="true" />
        <Shadow_SplitZStart value="1.000000" />
        <Shadow_SplitZEnd value="0.999900" />
        <Shadow_aircraftExpWeight value="0.990000" />
        <Shadow_DisableScreenSizeCheck value="true" />
        <Reflection_MipBlur value="true" />
        <FXAA_Enabled value="true" />
        <TXAA_Enabled value="false" />
        <Lighting_FogVolumes value="true" />
        <Shader_SSA value="true" />
        <DX_Version value="2" />
        <CityDensity value="1.000000" />
        <PedVarietyMultiplier value="1.000000" />
        <VehicleVarietyMultiplier value="1.000000" />
        <PostFX value="2" />
        <DoF value="false" />
        <HdStreamingInFlight value="true" />
        <MaxLodScale value="0.000000" />
        <MotionBlurStrength value="0.000000" />
      </graphics>
     
  9. mkeezay29

    mkeezay29 Master Guru

    Messages:
    225
    Likes Received:
    0
    GPU:
    Zotac GTX 760 4GB

    Your problem seems to be that because you have AnisotropicFiltering set to 0, it makes them blurry right in front of you no matter what, Anisotropic Filtering changes the way textures on the ground are displayed at oblique angles, having them at 0 will make the shadows on textures blurry no matter what you do, set it to 16, should fix the issue, P.S. - AF uses very little resources, no point in having it at 0 really.
    Also put Ultrashadows on True.

    If you are having issues with performance there are a few lines you change to keep the shadows by optimizing other values to make it run better, here are a few, there are more in the settings.xml in the games archives but I need to do more testing to see which ones work properly if I over ride them from the settings.xml in my documents folder

    Code:
        <LodScale value="0.800000" />
        <PedLodBias value="0.000001" />
        <VehicleLodBias value="0.000001" />
    For vehicle and ped bias you are adjusting their Level of Detail bias, the higher the value the more detailed characters look at a distance, so a value of 0.900000 is going to give you really high quality levels at greater distances, but the higher the value the more resources it eats up, you can put the main LODScale at 0.800000 instead of 1.000000 and get a jump in framerate with a pretty unnoticeable difference, below that you start noticing
     
    Last edited: May 1, 2015
  10. CK the Greek

    CK the Greek Maha Guru

    Messages:
    1,276
    Likes Received:
    10
    GPU:
    GB 2060S,Gsync,3DV2
    Ultrashadows setting is the "high shadows" ingame advanced graphics isn't it ? Well this eats a lot of gpu power no matter what PC you have.. nice try man however if it needs the ultrahigh settings is no good for performance reasons only. Better have that ugly shadow sh!t with 60fps.
     

  11. mkeezay29

    mkeezay29 Master Guru

    Messages:
    225
    Likes Received:
    0
    GPU:
    Zotac GTX 760 4GB
    I'm not sure what it is in game, even with settings maxed it says Ultra Shadows are disabled, you don't need Ultra Shadows (though it looks nicer), you just need to fix the split to keep shadow blurriness around your character to a minimum, and improve the transition from higher to lower quality shadows when approaching and moving away from shadows, it also stops shadow pop in from small objects that hang off buildings, usually as you get close to part of a building that's only popping out a foot or less the shadow will appear right in front of you, there is an example in both videos where I look at the top of the wall at an object that is popping out, in the vanilla it's partly shadowed, in the other it's fully shadowed.

    I have a 4GB 760 and was able to run it before the second update while using 3.3GB of Vram at about 45 FPS maxed, now it uses only 2.5GB after second update with all settings maxed, I think people with cards like 770s, 780s, 970s, 980s, 280x, 290x are going to be able to easily run it at or around 60 FPS without issue with Ultra Shadows, if not they can still achieve much better shadows.
     
  12. nanogenesis

    nanogenesis Maha Guru

    Messages:
    1,287
    Likes Received:
    0
    GPU:
    MSI R9 390X 1178|6350
    So, offtopic, pedLodBias and VehicleLodBias

    More means better or less?
     
  13. mkeezay29

    mkeezay29 Master Guru

    Messages:
    225
    Likes Received:
    0
    GPU:
    Zotac GTX 760 4GB
    For PedLODBias the higher the better, 1.00000 gives you no detail pop in as peds get closer, LODbias control the distance at which the game switches to lower level mip maps, by default the highest it will go through in game options is 0.200000, with high being at 0.100000, but if you want detailed Pedestrians no matter what distance just move it closer, or all the way up to 1.000000, even 0.500000 will make detail pop in completely unnoticeable, when you see your first crowd of people simply walk up and walk away to see they remain fully detailed instead of switching to lower res maps at about 20 feet.

    So more means better, the higher the distance before switching to lower res textures, same for car LODs
     
  14. LaciBognar

    LaciBognar Member

    Messages:
    20
    Likes Received:
    0
    GPU:
    MSI R9 280X 4G 3GB
    But this sure comes with a huge Performance impact doesn't it?

    I mean , does this tweak have any affect whether or not the "Extended Distance Scaling" is enabled or disabled ,or this is a different?

    The pop-ins are noticeable ,would this eliminate it?and if so , at what performance cost?
     
  15. mkeezay29

    mkeezay29 Master Guru

    Messages:
    225
    Likes Received:
    0
    GPU:
    Zotac GTX 760 4GB
    The Ped and Car LODs aren't huge resource hogs but they will eat up more resources at higher levels, I've found 0.500000 to be the sweet spot, and yes this value is changed by distance scaling in game, but will only go to a maximum of 0,200000, other things like Density can be put above 1.000000, but LOD bias has a max of 1.000000, keep in mind that increasing density is going to give you more people and cars, but it really hits performance, there is a line inside a file in the games archived files that limits cars to 130 on screen at once though and it can't be over written by the settings.xml, I tried it at 2.000000 and crashed the game, at 1.2 it's noticeably denser but takes about 8-10 FPS of my total FPS.

    For anyone here thinking this is for resource optimization, it's not, until we can edit files in OpenIV for GTA V I will not be able to create a proper optimization file, however I have extracted the games files and optimized values, the optimization files, and a handling file that uses GTA IVs handling.dat data for how cars handle are both almost done, but neither can be used until files in the games archives can be replaced.
     
    Last edited: May 2, 2015

  16. LaciBognar

    LaciBognar Member

    Messages:
    20
    Likes Received:
    0
    GPU:
    MSI R9 280X 4G 3GB
    Could you post your setting.xml with modded density?

    I am curios to see the difference
     
  17. nanogenesis

    nanogenesis Maha Guru

    Messages:
    1,287
    Likes Received:
    0
    GPU:
    MSI R9 390X 1178|6350
    Thank you for the detailed explanation. I do want more people in my screen.
    Hopefully there is a way to override the 130 limit.

    So I maxed out pedlodbias and vehiclelodbias to 1.0, put the 2 lod variables to 2.0 (even though 1.0 is limit) and put pedvariety and vehicle variety to 2.0, and density to 2.0
    Even though the framerate was good, the game was stuttering pretty bad, is this a directx11 bottleneck or engine bottleneck?

    Used the max settings for each variable along with 0.6 for both bias, and 1.3 density, its all back smooth.

    You can still see cars poping in the distance when driving on highways at high speeds with modded cars. I hope there is a 'true' ultra preset for GTAV.
     
  18. fabiobad

    fabiobad Active Member

    Messages:
    65
    Likes Received:
    0
    GPU:
    GTX 1060 ARMOR 6G OCV1
    mmm... this method doesn't work for the getting rid of the ugly shadow box that surround the player :/
     
  19. signex

    signex Ancient Guru

    Messages:
    8,708
    Likes Received:
    135
    GPU:
    Aorus RTX 2060 S
    Shadows didn't get any better for me, i really want to get rid of blurry ugly shadows in the distance and make them sharper.
     
  20. CK the Greek

    CK the Greek Maha Guru

    Messages:
    1,276
    Likes Received:
    10
    GPU:
    GB 2060S,Gsync,3DV2
    Results:

    Shadow_Distance value="1.900000" />
    this is the same setting ingame "extended shadow distance" which goes up to 2.0 (max)
    small difference with a small fps loss

    Shadow_LongShadows value="true" />
    same,ingame "long shadows" , nothing to do for better shadows..more accurate due to moving sun only. Very small difference, almost unnoticeable,no fps loss at all,

    Shadow_SplitZStart value="1.000000" />
    Shadow_SplitZEnd value="0.999900" />

    weird..I went to edit and I found already these values to my settings..anyway very small difference to very close shadows only with no fps loss.

    ALL these have nothing to do with the shadow box that many we have see (except "extended shadow distance" which makes it worse the more you extend them)


    If there was a possible way to do that you know that you won't be able to play the game,right? I mean you would see a slide show...
    It's like in Skyrim if you have played that game,the more far you want shadows to be rendered the uglier they are,same goes in this game.
    Try if you want this setting and check ingame:
    Shadow_Distance value="0.000100"
     
    Last edited: May 3, 2015

Share This Page