GTA V on AMD CrossFire - low GPU utilization

Discussion in 'Videocards - AMD Radeon Drivers Section' started by christal, Apr 19, 2015.

  1. nevernamed

    nevernamed Master Guru

    Messages:
    234
    Likes Received:
    4
    GPU:
    EVGA 1080 TI FTW3
    game is bottlenecking on cpu for me. hitting 97-98 on 2 cores.. gpu can handle a mxaa but for some reason that is a real frame rate killer even when its not maxing out the gpu. with it off the game is set on the highest setting in almost every situation except for advanced graphics and reflections. running 50-60 fps most of the time,but in busy areas hitting 45-50. lowering density didn't seem to help anything either.
     
  2. sammarbella

    sammarbella Ancient Guru

    Messages:
    3,929
    Likes Received:
    178
    GPU:
    290X Lightning CFX (H2O)
    It's time to update your CPU...
     
  3. Tronman

    Tronman Member Guru

    Messages:
    102
    Likes Received:
    0
    GPU:
    XFX 295x2
    Hi Plug2k/AMDMatt,

    I have a 295x2 on 15.4 betas pretty sure I have a similar issue. When I run the in game benchmark and I get to the jet flying into the city my game starts stuttering, chopping and seizing even though it says FPS is between 60-150. Afterburner doesn't seem to show that GPU clocks are dropping buts definitely what it feels like..

    EDIT: Just ran the benchmark with exact same settings but turned the MSAA back on and up to 4x and 80% of the stuttering is now gone. Plug2k is spot on. Afterburner is showing massive GPU utilisation drops and the game starts hitching for me. My clocks seem to be holding on the card however.
     
    Last edited: Apr 22, 2015
  4. Pill Monster

    Pill Monster Banned

    Messages:
    25,214
    Likes Received:
    9
    GPU:
    7950 Vapor-X 1100/1500
    Hey next time you're in game can you check task manager or AB after a good length of time and see what the commit amount is? Also vram load would be good to know.
     

  5. ApexiTT

    ApexiTT Active Member

    Messages:
    68
    Likes Received:
    0
    GPU:
    780ti Sli
    3 290xs cards and 100% usage. I have tuned the **** out of my system though.. Ram timings and perfect overclock. I'm also running in 4k.
     
  6. ApexiTT

    ApexiTT Active Member

    Messages:
    68
    Likes Received:
    0
    GPU:
    780ti Sli
    triple buffering enabled is Definitely what can cause that.. If that's not the case..Check your Ram timings.. Tighten the timings That will cure that 100%..
     
  7. sammarbella

    sammarbella Ancient Guru

    Messages:
    3,929
    Likes Received:
    178
    GPU:
    290X Lightning CFX (H2O)
    I have disabled v-sync from in game, i don't use it in CCC or any other place.

    I don't use radeonPro with this game and it's not even launched or in background.

    My clocks on both 290X are LOCKED at 1150/1600 so no loss of performance due to downclock.

    GPU usage range is as low as 45% in the outside.

    My RAM is CL7 at 1600 and it works well as usual.

    CPU has the 4 cores LOCKED at 4.1 GHZ and it's nowhere near to be bottlenecking the game with usages at max usage at 80% on any core.

    The MSI Lightning 290X cards have full EB Water Blocks and temp NEVER raise to 60 Cº the same for CPU who has also a block.

    The only moments i see 99% GPU usage from GPUs are inside building outside it varies from 45-80%, this range is close to 45-60% while driving.

    In-game settings are MAXED at 1080p and frames are as low as 40 driving.

    Can you please share your in-game settings to be able to play at 4K with a tri-fire?

    There are people here who can't max this game (60 fps V-Sync) at 4K with a quad without some graphic compromises and even lowering the FPS target.
     
    Last edited: Apr 27, 2015
  8. DiceAir

    DiceAir Maha Guru

    Messages:
    1,368
    Likes Received:
    15
    GPU:
    Galax 980 ti HOF
    i have same issue as you. fps drops etc. I also get stutter. I've tried lower the graphics setting but still same issue. I'm on 2560x1440 96hz
     
  9. motov8

    motov8 Member

    Messages:
    22
    Likes Received:
    0
    GPU:
    2x 280X
    I need to refresh this.

    I got 2x 280X and also got low GPU utilization, each gpu is like 30-50%, but like u said above when i turn on msaa on 2x,x4 or 8x my each GPU goes like 70-99%, but i got drops of fps to 40-50 which is annoying(when the drops comes in my gpu utilization isnt at max, its like 66-70%). Also on 280X i got in the right corner some kind of artifact - common problem on this series card.

    I got newest beta driver. I reinstalled driver using DDU, but i still didnt find solution (crossfire works fine on battlefield or 3DMark etc)

    I hope AMDMatt will find solution xD
     
  10. Garwinski

    Garwinski Member Guru

    Messages:
    185
    Likes Received:
    4
    GPU:
    XFX Fury X
    Isn't the work load on your GPU's increasing because you... well... increase load by GPU-exclusive jobs like MSAA, which does not need any other part of your pc to work hard (maybe your harddrive/ssd?), so the bottleneck for your GPU's won't block more GPU-utilization when turning MSAA on?

    Tell me if I am completely missing something here and my story does not make any sense, or if I am completely misinterpreting something.
     

  11. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,644
    Likes Received:
    268
    GPU:
    RX 580 8GB
    To get more GPU usage we need to stress the GPU more which results in lower FPS.
     
  12. Garwinski

    Garwinski Member Guru

    Messages:
    185
    Likes Received:
    4
    GPU:
    XFX Fury X
    Yea I thought it was seen as a fix for the bottleneck, but that is not the case, it just increases the load on the GPU, which shows an obvious bottleneck SOMEWHERE for gpu's.
     
  13. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,644
    Likes Received:
    268
    GPU:
    RX 580 8GB
    I just think it's poor optimization or an API/engine bottleneck.
     
  14. LtMatt81

    LtMatt81 Master Guru

    Messages:
    468
    Likes Received:
    7
    GPU:
    4x Fury X
    Thanks, we're aware of the stuttering in the benchmark sequence and are already investigating.

    In API/CPU limited scenarios it's perfectly normal to see gpu usage rise as you increase the image quality settings. I could show you 25 other games where the same thing happens on my setup.

    It doesn't always mean poor optimization or a poor Crossfire profile either. GTA V is a massive game, using no doubt a lot of draw calls and is heavy on the cpu. It's to be expected that at lower resolutions and settings the gpu's won't always be fully loaded as more emphasis is placed on the API/CPU. In these situations multi gpu, from either vendor, is going to see gpu usage drop. This is something you can see with a quick google of peoples setups and GTA V.

    Let's pretend that GTA V was patched in for Mantle/DX12/Vulkan support in the future, if that occurred this issue of gpu usage dropping would be reduced dramatically.

    As a regular user of DX11 and Mantle i can testify to a similar behaviour in Battlefield 4, Thief, Battlefield Hardline, Plants Vs Zombies, Civilization Beyond Earth, the list goes on. Try running 1080P medium settings on DX11 whilst using 2/3 gpu's and then Mantle, the difference in gpu usage is immediately noticeable.

    When all this is said and done though, GTA V runs superbly on my setup at 4K. I've tested on a HD 7990, a R9 295x2 and Quad 290X 8GB. I would be happy to drive around the city for 5 minutes benchmarking each card, if people are interested in the results.

    The HD 7990, which has 3GB of video memory, can run 4K comfortably at mostly very high settings and it is (I can't believe it's not) buttery smooth.
     
    Last edited: May 15, 2015
  15. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,644
    Likes Received:
    268
    GPU:
    RX 580 8GB
    AMDMatt. What I'm talking about here is crossfire GPU usage scaling. With a single card I would have 80/90 usage. When enabling both GPU's, the usage would drop to 40/40 or 50/50, so the FPS is basically the same as it was with a single GPU so you're not getting the extra FPS that you should be getting. Enabling both just to up MSAA to get more usage to then reduce your FPS is counter productive.

    Benchmark in GTA V. Pay attention to the max FPS results. There is very little difference here because of the scaling. This has to be either due to lack of optimization or an API/engine bottleneck.

    Single GPU:

    Code:
    Frames Per Second (Higher is better) Min, Max, Avg
    Pass 0, 28.499447, 124.493477, 56.541523
    Pass 1, 22.957323, 75.990715, 44.618694
    Pass 2, 21.045403, 99.341759, 54.985233
    Pass 3, 29.327866, 116.071716, 58.146553
    Pass 4, 26.860292, 88.720528, 51.753025
    
    Time in milliseconds(ms). (Lower is better). Min, Max, Avg
    Pass 0, 8.032549, 35.088402, 17.686117
    Pass 1, 13.159502, 43.559086, 22.412130
    Pass 2, 10.066260, 47.516315, 18.186701
    Pass 3, 8.615363, 34.097263, 17.197924
    Pass 4, 11.271349, 37.229675, 19.322542
    
    Frames under 16ms (for 60fps): 
    Pass 0: 134/522 frames (25.67%)
    Pass 1: 6/419 frames (1.43%)
    Pass 2: 72/510 frames (14.12%)
    Pass 3: 124/543 frames (22.84%)
    Pass 4: 328/5927 frames (5.53%)
    
    Frames under 33ms (for 30fps): 
    Pass 0: 521/522 frames (99.81%)
    Pass 1: 416/419 frames (99.28%)
    Pass 2: 509/510 frames (99.80%)
    Pass 3: 541/543 frames (99.63%)
    Pass 4: 5916/5927 frames (99.81%)
    
    Percentiles in ms for pass 0
    50%,	17.00
    75%,	18.00
    80%,	19.00
    85%,	22.00
    90%,	23.00
    91%,	23.00
    92%,	23.00
    93%,	24.00
    94%,	24.00
    95%,	24.00
    96%,	24.00
    97%,	24.00
    98%,	24.00
    99%,	25.00
    
    Percentiles in ms for pass 1
    50%,	22.00
    75%,	22.00
    80%,	23.00
    85%,	23.00
    90%,	23.00
    91%,	23.00
    92%,	23.00
    93%,	23.00
    94%,	23.00
    95%,	24.00
    96%,	24.00
    97%,	28.00
    98%,	31.00
    99%,	32.00
    
    Percentiles in ms for pass 2
    50%,	17.00
    75%,	21.00
    80%,	21.00
    85%,	21.00
    90%,	22.00
    91%,	22.00
    92%,	22.00
    93%,	22.00
    94%,	22.00
    95%,	22.00
    96%,	22.00
    97%,	22.00
    98%,	22.00
    99%,	22.00
    
    Percentiles in ms for pass 3
    50%,	17.00
    75%,	18.00
    80%,	18.00
    85%,	19.00
    90%,	19.00
    91%,	20.00
    92%,	20.00
    93%,	20.00
    94%,	21.00
    95%,	21.00
    96%,	21.00
    97%,	22.00
    98%,	22.00
    99%,	23.00
    
    Percentiles in ms for pass 4
    50%,	19.00
    75%,	20.00
    80%,	21.00
    85%,	22.00
    90%,	22.00
    91%,	22.00
    92%,	23.00
    93%,	23.00
    94%,	23.00
    95%,	23.00
    96%,	24.00
    97%,	24.00
    98%,	25.00
    99%,	27.00
    
    === SYSTEM ===
    Windows 8.1 Enterprise 64-bit (6.2, Build 9200)
    DX Feature Level: 11.0
    Intel(R) Core(TM) i7-3770K CPU @ 3.50GHz (8 CPUs), ~3.9GHz
    16384MB RAM
    AMD Radeon HD 7900 Series (AMD Radeon R9 280 || AMD Radeon HD 7900 Series), 6397MB, Driver Version 14.502.1014.0
    Graphics Card Vendor Id 0x1002 with Device ID 0x679a
    
    === SETTINGS ===
    Display: 1920x1200 (FullScreen) @ 60Hz VSync OFF
    Tessellation: 3
    LodScale: 1.000000
    PedLodBias: 0.200000
    VehicleLodBias: 0.000000
    ShadowQuality: 3
    ReflectionQuality: 3
    ReflectionMSAA: 8
    SSAO: 2
    AnisotropicFiltering: 16
    MSAA: 0
    MSAAFragments: 0
    MSAAQuality: 0
    TextureQuality: 2
    ParticleQuality: 2
    WaterQuality: 2
    GrassQuality: 2
    ShaderQuality: 2
    Shadow_SoftShadows: 4
    UltraShadows_Enabled: false
    Shadow_ParticleShadows: true
    Shadow_Distance: 2.000000
    Shadow_LongShadows: true
    Shadow_SplitZStart: 0.930000
    Shadow_SplitZEnd: 0.890000
    Shadow_aircraftExpWeight: 0.990000
    Shadow_DisableScreenSizeCheck: false
    Reflection_MipBlur: true
    FXAA_Enabled: true
    TXAA_Enabled: false
    Lighting_FogVolumes: true
    Shader_SSA: true
    DX_Version: 2
    CityDensity: 1.000000
    PedVarietyMultiplier: 0.800000
    VehicleVarietyMultiplier: 0.800000
    PostFX: 3
    DoF: true
    HdStreamingInFlight: true
    MaxLodScale: 0.400000
    MotionBlurStrength: 0.500000
    

    Crossfire:

    Code:
    Frames Per Second (Higher is better) Min, Max, Avg
    Pass 0, 22.658113, 127.125549, 63.991711
    Pass 1, 21.637417, 90.806854, 63.604912
    Pass 2, 30.743303, 114.983368, 71.128922
    Pass 3, 29.582205, 132.800140, 96.021576
    Pass 4, 13.729860, 129.424240, 66.384438
    
    Time in milliseconds(ms). (Lower is better). Min, Max, Avg
    Pass 0, 7.866240, 44.134300, 15.627024
    Pass 1, 11.012384, 46.216236, 15.722056
    Pass 2, 8.696910, 32.527409, 14.058979
    Pass 3, 7.530113, 33.804108, 10.414326
    Pass 4, 7.726528, 72.833954, 15.063771
    
    Frames under 16ms (for 60fps): 
    Pass 0: 363/598 frames (60.70%)
    Pass 1: 292/582 frames (50.17%)
    Pass 2: 399/642 frames (62.15%)
    Pass 3: 859/881 frames (97.50%)
    Pass 4: 4189/7339 frames (57.08%)
    
    Frames under 33ms (for 30fps): 
    Pass 0: 597/598 frames (99.83%)
    Pass 1: 581/582 frames (99.83%)
    Pass 2: 642/642 frames (100.00%)
    Pass 3: 880/881 frames (99.89%)
    Pass 4: 7308/7339 frames (99.58%)
    
    Percentiles in ms for pass 0
    50%,	15.00
    75%,	16.00
    80%,	17.00
    85%,	17.00
    90%,	18.00
    91%,	18.00
    92%,	18.00
    93%,	18.00
    94%,	18.00
    95%,	19.00
    96%,	19.00
    97%,	19.00
    98%,	20.00
    99%,	21.00
    
    Percentiles in ms for pass 1
    50%,	15.00
    75%,	17.00
    80%,	18.00
    85%,	19.00
    90%,	20.00
    91%,	20.00
    92%,	21.00
    93%,	21.00
    94%,	21.00
    95%,	21.00
    96%,	21.00
    97%,	22.00
    98%,	23.00
    99%,	25.00
    
    Percentiles in ms for pass 2
    50%,	14.00
    75%,	17.00
    80%,	17.00
    85%,	17.00
    90%,	18.00
    91%,	18.00
    92%,	19.00
    93%,	19.00
    94%,	20.00
    95%,	20.00
    96%,	21.00
    97%,	21.00
    98%,	22.00
    99%,	22.00
    
    Percentiles in ms for pass 3
    50%,	10.00
    75%,	11.00
    80%,	12.00
    85%,	12.00
    90%,	13.00
    91%,	13.00
    92%,	13.00
    93%,	13.00
    94%,	14.00
    95%,	14.00
    96%,	14.00
    97%,	15.00
    98%,	16.00
    99%,	16.00
    
    Percentiles in ms for pass 4
    50%,	15.00
    75%,	17.00
    80%,	18.00
    85%,	19.00
    90%,	20.00
    91%,	20.00
    92%,	20.00
    93%,	21.00
    94%,	21.00
    95%,	21.00
    96%,	22.00
    97%,	23.00
    98%,	24.00
    99%,	27.00
    
    === SYSTEM ===
    Windows 8.1 Enterprise 64-bit (6.2, Build 9200)
    DX Feature Level: 11.0
    Intel(R) Core(TM) i7-3770K CPU @ 3.50GHz (8 CPUs), ~3.9GHz
    16384MB RAM
    AMD Radeon HD 7900 Series (AMD Radeon R9 280 || AMD Radeon HD 7900 Series), 6397MB, Driver Version 14.502.1014.0
    Graphics Card Vendor Id 0x1002 with Device ID 0x679a
    
    === SETTINGS ===
    Display: 1920x1200 (FullScreen) @ 60Hz VSync OFF
    Tessellation: 3
    LodScale: 1.000000
    PedLodBias: 0.200000
    VehicleLodBias: 0.000000
    ShadowQuality: 3
    ReflectionQuality: 3
    ReflectionMSAA: 8
    SSAO: 2
    AnisotropicFiltering: 16
    MSAA: 0
    MSAAFragments: 0
    MSAAQuality: 0
    TextureQuality: 2
    ParticleQuality: 2
    WaterQuality: 2
    GrassQuality: 2
    ShaderQuality: 2
    Shadow_SoftShadows: 4
    UltraShadows_Enabled: false
    Shadow_ParticleShadows: true
    Shadow_Distance: 2.000000
    Shadow_LongShadows: true
    Shadow_SplitZStart: 0.930000
    Shadow_SplitZEnd: 0.890000
    Shadow_aircraftExpWeight: 0.990000
    Shadow_DisableScreenSizeCheck: false
    Reflection_MipBlur: true
    FXAA_Enabled: true
    TXAA_Enabled: false
    Lighting_FogVolumes: true
    Shader_SSA: true
    DX_Version: 2
    CityDensity: 1.000000
    PedVarietyMultiplier: 0.800000
    VehicleVarietyMultiplier: 0.800000
    PostFX: 3
    DoF: true
    HdStreamingInFlight: true
    MaxLodScale: 0.400000
    MotionBlurStrength: 0.500000
    

    Thanks for your reply.
     
    Last edited: May 15, 2015

  16. LtMatt81

    LtMatt81 Master Guru

    Messages:
    468
    Likes Received:
    7
    GPU:
    4x Fury X
    Is that behaviour replicated in game, or just in the benchmark sequence? We're aware that there are some problems with performance in the benchmark sequence, we're working closely with Rockstar to investigate that.
     
  17. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,644
    Likes Received:
    268
    GPU:
    RX 580 8GB
    Those are benchmark results with the latest drivers (15.4) and V-Sync disabled. The same behavior happens in gameplay too. The second GPU just takes half the load of the first and is only useful for upping the MSAA setting but in turn reduces the smoothness of the gameplay.
     
    Last edited: May 15, 2015
  18. LtMatt81

    LtMatt81 Master Guru

    Messages:
    468
    Likes Received:
    7
    GPU:
    4x Fury X
    Okay well i have a 7990 so share with me your settings and i will drive around the city to see if i can replicate it. I'm not interested in running through the benchmark sequence though, as we're already aware of that.
     
  19. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,644
    Likes Received:
    268
    GPU:
    RX 580 8GB
    I have changed the settings since the benchmark.
    Here are the settings that I use now from Documents\Rockstar Games\GTA V\settings.xml

    Code:
    <?xml version="1.0" encoding="UTF-8"?>
    
    <Settings>
      <version value="27" />
      <configSource>SMC_AUTO</configSource>
      <graphics>
        <Tessellation value="3" />
        <LodScale value="1.000000" />
        <PedLodBias value="0.200000" />
        <VehicleLodBias value="0.000000" />
        <ShadowQuality value="3" />
        <ReflectionQuality value="2" />
        <ReflectionMSAA value="2" />
        <SSAO value="2" />
        <AnisotropicFiltering value="16" />
        <MSAA value="2" />
        <MSAAFragments value="0" />
        <MSAAQuality value="0" />
        <TextureQuality value="2" />
        <ParticleQuality value="2" />
        <WaterQuality value="2" />
        <GrassQuality value="2" />
        <ShaderQuality value="2" />
        <Shadow_SoftShadows value="3" />
        <UltraShadows_Enabled value="false" />
        <Shadow_ParticleShadows value="true" />
        <Shadow_Distance value="1.200000" />
        <Shadow_LongShadows value="true" />
        <Shadow_SplitZStart value="0.930000" />
        <Shadow_SplitZEnd value="0.890000" />
        <Shadow_aircraftExpWeight value="0.990000" />
        <Shadow_DisableScreenSizeCheck value="false" />
        <Reflection_MipBlur value="true" />
        <FXAA_Enabled value="false" />
        <TXAA_Enabled value="false" />
        <Lighting_FogVolumes value="true" />
        <Shader_SSA value="true" />
        <DX_Version value="2" />
        <CityDensity value="1.000000" />
        <PedVarietyMultiplier value="1.000000" />
        <VehicleVarietyMultiplier value="1.000000" />
        <PostFX value="1" />
        <DoF value="false" />
        <HdStreamingInFlight value="true" />
        <MaxLodScale value="0.400000" />
        <MotionBlurStrength value="0.000000" />
      </graphics>
      <system>
        <numBytesPerReplayBlock value="9000000" />
        <numReplayBlocks value="36" />
        <maxSizeOfStreamingReplay value="1024" />
        <maxFileStoreSize value="65536" />
      </system>
      <audio>
        <Audio3d value="false" />
      </audio>
      <video>
        <AdapterIndex value="0" />
        <OutputIndex value="0" />
        <ScreenWidth value="1920" />
        <ScreenHeight value="1200" />
        <RefreshRate value="60" />
        <Windowed value="2" />
        <VSync value="0" />
        <Stereo value="0" />
        <Convergence value="0.100000" />
        <Separation value="0.000000" />
        <PauseOnFocusLoss value="0" />
        <AspectRatio value="6" />
      </video>
      <VideoCardDescription>AMD Radeon HD 7900 Series (AMD Radeon R9 280 || AMD Radeon HD 7900 Series)</VideoCardDescription>
    </Settings>
    The game shouldn't be in fullscreen mode as I don't play with crossfire right now.
     
  20. LtMatt81

    LtMatt81 Master Guru

    Messages:
    468
    Likes Received:
    7
    GPU:
    4x Fury X
    Can you just grab 3/4 screenshots of the settings from the graphics menu?

    EDIT

    Nevermind i just copied your settings into my XML file. :)
     

Share This Page