GTA IV Securom crash at startup [Steam]

Discussion in 'Games, Gaming & Game-demos' started by xankazo, Jan 13, 2011.

  1. xankazo

    xankazo Ancient Guru

    Messages:
    2,808
    Likes Received:
    1
    GPU:
    EVGA GTX 1060 SC (6GB)
    GTA IV Securom crash at startup [Steam] [SOLVED!]

    Everytime 4-8 times I try to open the game it crashes with this Securom error message:
    [​IMG]

    If I keep trying, it eventually starts and if it get to load the saved game it never crashes again. The problem is starting the game. I've tried reinstalling the Visual C++ libraries like advised in the game's page, but it doesn't help. Meanwhile this is what I'm getting everyday in the reliability record:
    [​IMG]

    I'm using the Steam version, BTW.
    :( :( :(
     
    Last edited: Jan 14, 2011
  2. MarkyG

    MarkyG Master Guru

    Messages:
    665
    Likes Received:
    1
    GPU:
    MSI Twn Frozr IV GTX 1070
    I had the same issue. If you're using Internet Explorer 9 Beta, uninstall it. After that, zero problems for me :)
     
  3. xankazo

    xankazo Ancient Guru

    Messages:
    2,808
    Likes Received:
    1
    GPU:
    EVGA GTX 1060 SC (6GB)
    OK, I do have IE9 installed. As soon as I get home I'll uninstall it (I always use Firefox anyways) and see if the problem is gone. Thanks for the reply.
     
  4. xankazo

    xankazo Ancient Guru

    Messages:
    2,808
    Likes Received:
    1
    GPU:
    EVGA GTX 1060 SC (6GB)
    Thank you! That really solved it. There's gotta be some incompatibilities between securom and IE9 beta.
     

  5. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    14,935
    Likes Received:
    5
    GPU:
    EVGA GTX 1080 Ti SC2
    The IE9 beta causes issues with other games too such as Lost Planet 2. If I open IE9 and a flash animation plays then close it, when I load the Lost Planet 2 (DX11) then I lose the audio and the video which plays on the main menu keeps restarting and doesn't play properly. I thought the game installation was corrupted and reinstalled it twice before I realised it was an issue caused by IE9. Doesn't bode well for the final release really if a browser causes games to crash/not work properly.
     
  6. MarkyG

    MarkyG Master Guru

    Messages:
    665
    Likes Received:
    1
    GPU:
    MSI Twn Frozr IV GTX 1070
    Sharing is caring ;)
     
  7. xankazo

    xankazo Ancient Guru

    Messages:
    2,808
    Likes Received:
    1
    GPU:
    EVGA GTX 1060 SC (6GB)
    That's right! and IE9 would've been the last of my suspects, since it was performing very solid. But because windows borrows many elements from IE itself, some screw may still be loose.
     

Share This Page