GTA iV and ATI CrossFireX - 3 GPUs

Discussion in 'Games, Gaming & Game-demos' started by ibitato, Jun 2, 2009.

  1. ibitato

    ibitato Ancient Guru

    Messages:
    4,958
    Likes Received:
    1
    GPU:
    4870X2+4870 1GB on S T260
    Hello to all

    I just installed the game, and only 2 out of 3 GPUs get loaded.

    I wonder if the standard CrossfireX profile for this game works just like that , but its a bit weird that having 3 GPUs , only 2 work.

    Also, this happens with Dead Space. Only 2 gpus work.

    Funny thing, that the GPUs that get loaded are:
    GPU 0 on my Saphire 4870 1GB
    GPU 2 on my 4870X2 , GPU 1 does nothing.

    Far Cry 2 or Crysis get nicely balanced over all 3 gpus.......

    any ideas ????

    should I just forget about it and enjoy the game ????

    I am pretty sure that if the 3 GPU were working , I would get better gamplay that I do right now......
     
  2. Texter

    Texter Ancient Guru

    Messages:
    3,175
    Likes Received:
    256
    GPU:
    Club3d GF6800GT 256MB AGP
  3. DSK

    DSK Banned

    Messages:
    17,917
    Likes Received:
    1
    GPU:
    HD5770/BenQ G2220HD
    dont worry max settings is only making my card use like 45% lol
     
    Last edited: Jun 2, 2009
  4. ibitato

    ibitato Ancient Guru

    Messages:
    4,958
    Likes Received:
    1
    GPU:
    4870X2+4870 1GB on S T260
    thanks ppl

    yea, but I still do not understand why it cannot use beyond 2 GPUS........ maybe its just the CrossFireX profile .......

    um, there is got to be an explanation.......


    PD: just started playing...... I will let you know how it goes in my setup, I just pumped all to max -.....
     

  5. DSK

    DSK Banned

    Messages:
    17,917
    Likes Received:
    1
    GPU:
    HD5770/BenQ G2220HD
    "C:\Program Files (x86)\Rockstar Games\Grand Theft Auto IV\LaunchGTAIV.exe" -availablevidmem 2.5 --percentvidmem 100

    cause it wil only let you use like 1GB of Vram thoses commands will give you 2.5GB.
     
  6. ibitato

    ibitato Ancient Guru

    Messages:
    4,958
    Likes Received:
    1
    GPU:
    4870X2+4870 1GB on S T260
    thanks I am going to test

    is that - and the -- or both - or both --
    weird comboi for command line argumnents

    /edit BTW how do I know commands are sucessfull??? I still see only iGB vram onm config
     
    Last edited: Jun 2, 2009
  7. The Postman

    The Postman Ancient Guru

    Messages:
    1,773
    Likes Received:
    0
    GPU:
    MSI 980 TI Gaming
    It only works with 2 gpus due to cpu limitations, it is confirmed by ati, have a good day.
     
  8. ibitato

    ibitato Ancient Guru

    Messages:
    4,958
    Likes Received:
    1
    GPU:
    4870X2+4870 1GB on S T260
    Thanks

    I guess I should start playing now ......
     
  9. DSK

    DSK Banned

    Messages:
    17,917
    Likes Received:
    1
    GPU:
    HD5770/BenQ G2220HD
    Sorry lol

    "C:\Program Files (x86)\Rockstar Games\Grand Theft Auto IV\LaunchGTAIV.exe" -norestriction -nomemrestrict -availablevidmem 2.5

    forget the 100% it dont work lol
     
  10. ibitato

    ibitato Ancient Guru

    Messages:
    4,958
    Likes Received:
    1
    GPU:
    4870X2+4870 1GB on S T260
    ok, I did a shorcut with it, how do I know it works ?
     

  11. DSK

    DSK Banned

    Messages:
    17,917
    Likes Received:
    1
    GPU:
    HD5770/BenQ G2220HD
    it will should in config

    like so

    [​IMG]
     
  12. ibitato

    ibitato Ancient Guru

    Messages:
    4,958
    Likes Received:
    1
    GPU:
    4870X2+4870 1GB on S T260
    what exactly did you do?

    is not working for me

    BTW I am unable to log into the social crap, my account, even though I signed and confirme is not working

    don't think has to do with it, BTW
     
  13. DSK

    DSK Banned

    Messages:
    17,917
    Likes Received:
    1
    GPU:
    HD5770/BenQ G2220HD
    Hmm you have to go into the gta4 folder and shortcut the launcher then put in the command in that target.

    and your firewall is probs block social club cause mine was.
     
  14. ibitato

    ibitato Ancient Guru

    Messages:
    4,958
    Likes Received:
    1
    GPU:
    4870X2+4870 1GB on S T260
    well

    It worked last time I ran the game , I think bc rocks B.S. was already running.... I don't know ........ tomorrow or the day after I will check. Finally I did a -bat file for the settings

    the game looks really FUN, I played for a bit, and I think I will not regret the 50 euros.

    I am still trying to figure out my settings.... distance view if too high its ruinming my gameplay ....... next time I play i'll try to figure out my sweet spot...

    Funny game, I was dating some chick and accidentaly hit her on the face......
    The game lets you re-try that one..... WTF??????? If my ex-wife and my actual fiance find out, they will call me whatever.......

    time to go to sleep ... I have to drive 800 km tomorrow (today in like 5 hours) ......
    meeting in Madrid and back to my place.... I can't wait to get my hands on back on the game.

    thanks for all the help , ppl
     
  15. The General

    The General Ancient Guru

    Messages:
    3,108
    Likes Received:
    5
    GPU:
    FirePro W5000 2GB

  16. ricardonuno1980

    ricardonuno1980 Banned

    Messages:
    4,407
    Likes Received:
    0
    GPU:
    GTX 780Ti Classified :D
    it's exact. the vsync@60Hz is enabled well!! :mad: because the performance is much smooth!!
     
  17. Iarwain

    Iarwain Banned

    Messages:
    3,048
    Likes Received:
    0
    GPU:
    4890 990//1120
    What did you just say? It decreases performance to give you a smooth untorn image. Having vsync off is just silly.
     
  18. TheHunter

    TheHunter Banned

    Messages:
    13,405
    Likes Received:
    1
    GPU:
    MSi N570GTX TFIII [OC|PE]
    yep it makes lags, if u didnt noticed yet...

    for a fast paced fps i would never recommend it on.

    No triplebuffer, frames to render ahead=1 won't make it as smooth and responsive as with off.
     
  19. ibitato

    ibitato Ancient Guru

    Messages:
    4,958
    Likes Received:
    1
    GPU:
    4870X2+4870 1GB on S T260
    Ok,
    I've been busy.
    so, I hope tonight I can get back to the game

    Just a few considerations:

    so, the game just runs 2 out of 3 gpus due to cpu limitations as reported on this thread.

    Well, WTF. They might have their reasons but, it surprises me. Dead Space, the same, 2 out of 3; but this one really runs smooth......

    the parameters posted on this thread, about running the game.

    They DO WORK, unlocking the mem settings etc but I am starting to think that they are NOT EFFECTIVE (at least on my setup).

    Even though I see now 2.5 GB vmem, if I configure more that 1GB in vewing distance the game gets real bad frame drops and stuttering etc ; specially if you jsut stand up, take the mouse and move it fast around the character.

    This might mean that even settings are unlocked, game or drivers only being used on 1GB out of the 3 GB possibles, on my crossFire.

    I pumped up everyother setting with no side effects, but this one hurts. Well, the car desity as well.............

    I am playing 1680x1050 ; no vsync in game, 3doverriver running

    Standing still, closed areas rock solid 60 fps. Driving around, messing ,,,,, etc never below 35/40 fps. the game runs smooth.

    Just to remind ppl (bc of the vsync issue brought up on the thread) that 3doverrider DOES FORCE 3xFUFFER for D3D games..... lots of ppl saying that 3xbuffer is only for opengl games.... but I've been reading and the hole idea for the tool is to force it on d3d games.

    So, bc the perf is not that great I am going to run the game tonight with no 3doverrider, nor vsync, etc. I am sure that in closed areas if I move to fast I am going to get teraing.... but bc most of the time y are in the open wide and frames keep on 40/50s fps I think is worth the shot to forget about vsync.
     
  20. ChaddlesMcGee

    ChaddlesMcGee New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    2xSapphire Radeon 4870x2
    Finally!

    I Have had problems with this stupid game crashing due to running out of video memory for ages and it has frustrated me to no end.
    Just like to say thanks Kylzer for posting those append strings for the launch shortcut. went from having 1000mb to 2500mb to play with and maxed everything out no worries :)

    I guess I should mention that I am running quadfire (2 x 4870X2) which gives me close to 4 gig of video ram. Oh and I am running a res of 2560 x 1600.
    It does stutter a little bit though and it can be annoying.
    But GTA IV will only use one of my 4870x2 cards so I guess it does not support more than a dual graphics card configuration.
    Other games like lego batman and UT3 can use up to 99% of all 4 GPUs!
     

Share This Page