GTA 4 PC problems

Discussion in 'Games, Gaming & Game-demos' started by H83, May 5, 2012.

  1. H83

    H83 Ancient Guru

    Messages:
    1,971
    Likes Received:
    2
    GPU:
    Asus ROG Strix GTX1070
    Hi Gurus,


    so i´ve just bought GT4 and episodes for PC despite everything i´ve read about how badly coded this game is. I thought i was doing a good buy because the game and episodes just cost me 20€ but know i´m starting to regret my purchase...


    I installed the game for the first time and the game was unplayable due to the severe slowdowns causing the game to almost stop... To remedy this i´ve updated the game to it´s latest version trough windows live and the slowdowns disappeared. The problem is that now the game crashes when i leave the apartment were we save the game!!! A message appears saying "GTA IV Fatal Error: Out of memory: please reboot you system". I´m tired of looking and trying fixes i´ve found on Google because nothing seems to work!
    I´m this close to trow this piece of **** out of the window!!!!


    Can someone help or should i just trade the PC version for the PS3 version???


    Thanks in advance!
     
  2. Xzibit

    Xzibit Banned

    Messages:
    4,383
    Likes Received:
    0
    GPU:
    7970 Windforce
    Try to lower the gfx settings. 4Gb... In what res are you playing?
    BTW, the game is patched with latest patch?
     
  3. Mikedogg

    Mikedogg Banned

    Messages:
    2,844
    Likes Received:
    0
    GPU:
    Radeon HD 4650M 1GB
    What size is your pagefile?
     
  4. H83

    H83 Ancient Guru

    Messages:
    1,971
    Likes Received:
    2
    GPU:
    Asus ROG Strix GTX1070
    It´s 4095mb if i´m not mistaken. Why?

    @Xbizit: the resolution is 1920x1080 and i´ve already tried lowering all the gfx settings to the minimum but id didn´t work. I think the game is patched with the latest patch but i´m gonna check it anyway.
     

  5. Mikedogg

    Mikedogg Banned

    Messages:
    2,844
    Likes Received:
    0
    GPU:
    Radeon HD 4650M 1GB
    Just thought it might be relevant.
     
  6. Xzibit

    Xzibit Banned

    Messages:
    4,383
    Likes Received:
    0
    GPU:
    7970 Windforce
    All should be fine with latest patch. I played in it 3 or months ago with some mods and no crashes.
    Try to turn off the shadows.
    BTW this game is very CPU dependent, even on SB rigs :nerd:
     
  7. IcE

    IcE Don Snow Staff Member

    Messages:
    10,654
    Likes Received:
    11
    GPU:
    Gigabyte 970 G1
    I'm able to play it fine, might be something configured improperly on your system.
     
  8. villa_youth

    villa_youth Master Guru

    Messages:
    808
    Likes Received:
    0
    GPU:
    780 Ti
    Are you using a 64 bit os ? I think GTA 4 tries to use more memory on a 64 bit os.
     
  9. gthegamedude

    gthegamedude Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    BFG 7800GS 256mb
    I'm playing this game right now. I only bought GTA 4, no DLC. My graphics are high for textures, medium for shadows, low for water and night shadows off. At 1680 X 1050 my win 7 64, e8400, 6gb, gtx560 rig runs this game pretty smooth. Sometimes when I load game, the graphics card stays in desktop mode and the game play crawls. I can tell right away if the mouse is lagging in the menu. A restart of computer is necessary to fix. That's been my only problem with this game on my rig. I can't imagine your rig having any problems running this better than mine.
     
  10. revo321

    revo321 New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    GTX 680
    I had this problem before. I don't remember exactly what i did, but i believe its something to do with the .exe of the game that's causing it.
     

  11. H83

    H83 Ancient Guru

    Messages:
    1,971
    Likes Received:
    2
    GPU:
    Asus ROG Strix GTX1070
    My rig is more than enough to play the game.


    The problem is that the game is always crashing at the same part and i don´t know why...


    I´ve sent an email to Rockstar support to see if they can help me. If they can´t, then i´ll return the game...
     
  12. gridiron whirlw

    gridiron whirlw Ancient Guru

    Messages:
    3,778
    Likes Received:
    0
    GPU:
    GTX 570 SLI
    Reinstall and patch the game to only 1.040

    More mods work for this version.

    Download xliveless...that makes the game modable and you dont need windows live to play the game.

    I also recommend Better City Texture pack....it is 7.5 GB download, but well worth it.
     
  13. Radiopassive

    Radiopassive Banned

    Messages:
    154
    Likes Received:
    0
    GPU:
    Gainward HD 4870 1G
    Oc

    Are all your OCed ddr2 sticks stable in memtest? What timing, 5-5-5-15? I wish you good luck in spending more time actually playing the game rather than playing around with the settings and stuff(installing´n´uninstalling 15gb game, trying which patch suits you most etc.)...:pc1::infinity:
     
    Last edited: May 6, 2012
  14. ])rStrangelove

    ])rStrangelove Ancient Guru

    Messages:
    3,802
    Likes Received:
    0
    GPU:
    EVGA GTX780 SC ACX 3GB
    Try disabling the auto capture feature for the ingame Rockstar video editor. Helped me with slowdowns, but apparently that shouldve been fixed via patches by now.

    You could try to use a commandline.txt with specific commands to get rid of any memory barriers & other stuff. I can post my commandline.txt later if you want.

    Also: your problem might be GFWL, in that case google for liveless.


    I understand that playing GTA4 on a PS3 is better than not playing it at all, but let me tell your eyes will cry (20 fps / slowdowns / objects appearing right in front of you when driving).
     
  15. killer_939

    killer_939 Ancient Guru

    Messages:
    2,598
    Likes Received:
    0
    GPU:
    Radeon 7950 @ 1100/1500
    I know 2gb ram ran run it flawlessly with maxed mods and everything from when i had my old 4gb ram kit die so it can't be ram. I own the game too and got fed up with it when i brought it so i just used patch 1.030 (i think) since anything after that would make it crash or lag very bad. I had to do that on my old E8400 tho but i still haven't let it update.
     

Share This Page