GRAW 2 Physx Crash

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by duralisis, Aug 19, 2008.

  1. duralisis

    duralisis Member

    Messages:
    16
    Likes Received:
    0
    GPU:
    XFX 8800GT 512MB "Alpha Dog"
    I picked up GRAW2 for cheap over the weekend and thought I'd check out the explosions and Physx additions. On a clean first time install while using 177.83 official with the latest included Physx drivers, the game crashes repeatedly after only a minute or so in (first level, run up the path, move around a bit, do some more and then crash...).

    I noticed in the config xml that it shows "HasPhysx=True", so I tried various methods of disabling Physx (control panel, manual set false in xml, in game config). The only one that worked well was to leave it enabled in the control panel, set Normal physics level in game, and exit completely, then go back in. Now it doesn't crash, but GRAW2 still runs pretty crappy.

    I switched to 177.89 and tried enabling Physx in game again. Physx Extreme is faster this time, but still crashes after a minute or two. So the only way I can get it to run is disabled (Normal).

    I made double sure it was Physx alone causing the crash. I disabled everything I could (including my X-Fi and running without sound) and tried conservative ingame settings and still the same result.

    But I still think it's odd that a game that's been out for a while now and was supposedly made to run very well on an 8800GT feels sluggish and choppy at 1920x1200 with everything high except AA and AF. I have to drop to 1440x900 to get a smooth framerate and that's without Physx. This is in stark contrast to UT3 and even junky old Warmonger.

    Here's the crash I get, it's the same everytime:

    Code:
    Crash in application version: 30899.3048
    
    Unhandled exception - -529697949
    
    C STACK:
                         kernel32   (???) : RaiseException
                            graw2   (???) : ???
                            graw2   (???) : ???
                              ???   (???) : ???
                              ???   (???) : ???
    
    Renderer: threaded
    Physics : threaded
    I remember a couple driver versions ago, UT3 would also crash with early Physx drivers, but 8.07.xx fixed that and official runs fine. It's too bad support is so application specific at this point. What's your experience in Graw2?
     
  2. RyPaul

    RyPaul Active Member

    Messages:
    55
    Likes Received:
    0
    GPU:
    Geforce GTS 450 1024M
    Same Problem

    I have the same problem the only way I can run it without crashes is to use low texture detail. It seems to crash once my Card's onboard memory is exceeded
     
  3. Dav100

    Dav100 New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    Zotac 8800GT 512mb
    Same Problem

    I have the exact same problem.
     
  4. ragtag

    ragtag Master Guru

    Messages:
    216
    Likes Received:
    0
    GPU:
    Asus GTX 980 SLI
    I had the same problem. Re-install the game worked fine. Now i can run it with Extreme physX in 1920x1200 without any chrashes.
     

  5. ajua

    ajua Master Guru

    Messages:
    211
    Likes Received:
    0
    GPU:
    XFX HD5850 Black Edition
    Last i played it i maxed out everything except the use of ultra high (don't remember the exact name on in-game settings) quality textures because it was disabled and i could only set it to high.

    Never had a crash. I guess i would be the PhysX drivers. I will try to install it again when i had the time i try it by myself.
     
  6. Necronaught

    Necronaught Member

    Messages:
    23
    Likes Received:
    0
    GPU:
    Gainward GTX 280 - 180.60
    what am I doing wrong. My FPS sucks with phsyx enabled. I hate the feature. So much for the 200 series. I have a spare 8800gtx but a crossfire mobo, could I install the gtx and use it for physx, or does the mobo have to be sli compatible?
     
  7. Kill4L

    Kill4L Master Guru

    Messages:
    382
    Likes Received:
    1
    GPU:
    GTX 1070 Laptop
    for physx there is no need to SLI support. you can install it without any problems
     
  8. Dav100

    Dav100 New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    Zotac 8800GT 512mb
    I dual boot XP and Vista and get this error every time in XP, tried everything with no avail.
    Tried vista today running the exe straight from the XP install and it works perfectly.

    I don't know if this will help anyone, but it fixed my problem.
     
  9. slickric21

    slickric21 Ancient Guru

    Messages:
    2,458
    Likes Received:
    4
    GPU:
    eVGA 1080ti SC / Gsync
    Same crash problem here as op with same error message.

    Only way to play is to disable physx in control panel (and ingame therefor)

    Read the comments about re-installing the game. Will give it a try later - but not optimistic about what it will acheive as I installed all my drivers (clean xp 32 install) then installed my games - GRAW2 inc after anyway.
     
  10. bozotheclown

    bozotheclown Master Guru

    Messages:
    859
    Likes Received:
    0
    GPU:
    2x8800GTS512@stock
    No problems whatsoever in my case.

    Vista x64, 177.92, 2x8800GTS512 in SLI, PhysX enabled all in game settings maxed out at 1280x1024 including physx and I can graw2 play smooth for hours and hours without any crash.
     

  11. Vector

    Vector Ancient Guru

    Messages:
    1,508
    Likes Received:
    0
    GPU:
    GTX 770 FTW 4gb w/bkplate
    try re-installing the game with the phyx driver that came with it
     
  12. duralisis

    duralisis Member

    Messages:
    16
    Likes Received:
    0
    GPU:
    XFX 8800GT 512MB "Alpha Dog"
    The included Ageia driver is pre-Nvidia and doesn't include GPU Physx acceleration. It's software only unless you have a PPU. This has the same effect as running with Physx disabled or "Physics - Normal" ingame.

    I did try installing the game on two other systems, one an with an 8600GT and the newest Physx driver, the other an older 6600GT system with legacy Ageia Physx installed and and older Forceware. On the 8600GT system, it still crashes under Physx in the first level (roughly about the time you start poppin' heads up the hill). With the older 6600GT system, performance is still crap, but obviously doesn't crash without Physx. However it does seem a bit smoother overall (I was artificially limited to low texture resolution by the game and had everything else about medium though).

    On either modern system there is much hitching and overall sluggishness for a game which should run like crazy on an 8800GT.
     
  13. Black_ice_Spain

    Black_ice_Spain Ancient Guru

    Messages:
    4,584
    Likes Received:
    17
    GPU:
    5700XT
    install the physx pack that comes with 177.92, and try, it fixes GRAW2 problems for meh.
     
  14. slickric21

    slickric21 Ancient Guru

    Messages:
    2,458
    Likes Received:
    4
    GPU:
    eVGA 1080ti SC / Gsync
    I installed the 177.92 drivers (which inc physx) on a fresh install of Xp32.

    Then installed GRAW2

    Result is crash if physx enabled.
     
  15. Black_ice_Spain

    Black_ice_Spain Ancient Guru

    Messages:
    4,584
    Likes Received:
    17
    GPU:
    5700XT
    aw :S, then i dont know, from what i can remember, only played 5min this game, it sucks imo xD

    i started a physx map and there it wasnt crashing, but idk if it still does in non-physx ones
     

  16. slickric21

    slickric21 Ancient Guru

    Messages:
    2,458
    Likes Received:
    4
    GPU:
    eVGA 1080ti SC / Gsync
    OK got it working.

    Uninstalled 177.92 & physx driver (whatever version was bundled)

    Installed 177.98 then seperatley installed PhysX8.08.18.

    GRAW2 extreme and high physx works.

    Not really to impressed tbh, the extreme setting on Ageia Island looks ridiculous all those leave floating around everywhere :wanker:
     
  17. duralisis

    duralisis Member

    Messages:
    16
    Likes Received:
    0
    GPU:
    XFX 8800GT 512MB "Alpha Dog"
    I just tried 177.98. Still crashes a few minutes in (no specific error in the message, see my original post), but the game plays very smooth even with Extreme phsyics (and then promptly crashes to desktop with "Error in application" like usual).

    Physx IS working as I can see instanced debris generated off shooting concrete and collisions for boards falling and such, but somethings causing it to repeatedly crash on most all systems with at least a G80 or G92's. Since it's a matter of time before it crashes and not one specific point or object, I'd hesitate to say it's some kind of buffer issue. Like a physics buffer gets filled up then overflows and takes the whole thing down. Perhaps someone close to NVidia could get them to take a look at this?
     

Share This Page