Graphics run smoothly when browser open in background

Discussion in 'Videocards - AMD Radeon' started by hdoous, May 25, 2012.

  1. hdoous

    hdoous New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    AMD/Radeon HD 6900M/2GB
    This is a rather complex problem. First I should give system specs:

    Alienware M17x R3
    OS: Windows 7 64-bit
    CPU: Core i7 2760QM 2.40 GHz Sandy bridge
    GPU: AMD Radeon HD 6900M 2GB
    16GB RAM

    I should also add that all of my drivers are up to date.

    Ok, so this problem began when I noticed the frame rate had dropped significantly when I started Diablo 3 versus the last time I had it started up. It was running fine on maxed graphics, but now it was very slow. I opened device manager to find that my comp had switched to integrated graphics due to the AC cord being unplugged and it switching to battery power, and normally I could do a Fn+F7 to switch graphics cards back to my discrete card, however now the discrete card had disappeared completely. After entering BIOS on restart, it said discrete graphics not detected. After a few restarts the card was detected again, however after another AC unplug it disappeared again.

    I contacted Alienware support and after a screen sharing session he somehow managed to get it to discover the card again (by luck). When it disappeared again I emailed support, and after numerous restarts I got it working again when Alienware support contacted me. Since I had temporarily fixed the problem, he couldn't do much for me but he (after opening a screen-sharing session) fiddled with my graphics settings and said there wasn't much he could do.

    So we get up to now. I was playing Diablo 3 when Alienware support called, and everything was running smooth. After he tweaked my graphics options, the framerate on Diablo 3 dropped significantly. I tried tweaking my graphics options, power options, and reset defaults to no avail. Then I had my browser open with a video about increasing performance, and tried one of the suggestions and it worked. Problem is, when I close the browser the framerate dropped again, so I've been running the game with my browser open to keep the framerate up.

    What I think is happening is that the sandy bridge system is not just switching to integrated graphics, but is also setting my graphics card to a completely off state instead of an idle state. I was wondering if anyone could help me figure out why the graphics run better when my browser is open, or how I can get it to stop switching to integrated graphics when unplugged. I'm fairly sure I'll end up having to send it in for warranty work, but is there any possibility of me figuring this out without doing that? I swear, this is the last ATI card I ever buy, I've had nothing but problems with them.
     
  2. automaticman

    automaticman Master Guru

    Messages:
    852
    Likes Received:
    0
    GPU:
    R9 290 Vapor-X
    use GPUz or CCC to check the clock speed of your card. It sounds like for some reason the card isn't running at full speed when the game is open, but detects the HW accelerated part of the browser and goes to full speed.

    Check CCC to make sure the game is set to run with high power graphics.
     
  3. hdoous

    hdoous New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    AMD/Radeon HD 6900M/2GB
    My core clock is 715MHz, and my memory clock is 900MHz, but I'm not sure if that's what they should be. The switchable graphics is set to high performance GPU, basically what the settings were before it started slowing down.
     
  4. automaticman

    automaticman Master Guru

    Messages:
    852
    Likes Received:
    0
    GPU:
    R9 290 Vapor-X
    and those clocks don't change whether the browser is open or closed?
     

  5. hdoous

    hdoous New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    AMD/Radeon HD 6900M/2GB
    They appear to be the same in ccc, and also when I run MSI Kombustor, no change.
     
  6. automaticman

    automaticman Master Guru

    Messages:
    852
    Likes Received:
    0
    GPU:
    R9 290 Vapor-X
    and diablo still runs slow with the clocks at that speed? I cant think of anything else that the browser would help with.
     
  7. automaticman

    automaticman Master Guru

    Messages:
    852
    Likes Received:
    0
    GPU:
    R9 290 Vapor-X
    unless it's just not using the discrete gfx at all. Try using afterburner to watch the usage in game.
     
  8. hdoous

    hdoous New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    AMD/Radeon HD 6900M/2GB
    *sigh*

    I ran afterburner with D3 on and with the browser open it ran at 715MHz, then I closed the browser and it still ran smooth at 715MHz, so...now the in-game issue seems to have been resolved, thanks. Any thoughts about the graphics card being randomly recognized on startup?
     
  9. automaticman

    automaticman Master Guru

    Messages:
    852
    Likes Received:
    0
    GPU:
    R9 290 Vapor-X
    bios quirkiness? motherboard issue? I don't have a huge amount of experience with laptops tbh.
     

Share This Page