graphic bugs on crysis

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by ToyTen, Aug 16, 2008.

  1. Frag-master

    Frag-master Ancient Guru

    Messages:
    2,473
    Likes Received:
    0
    GPU:
    ASUS GTX960 Mini OC
  2. ToyTen

    ToyTen Maha Guru

    Messages:
    1,218
    Likes Received:
    0
    GPU:
    MSI 1080 Gaming X
    I'm sorry I don't understand that "imao"

    English isn't my mother language. What does it means please ? I'd like to know please
     
  3. stromchin

    stromchin Master Guru

    Messages:
    236
    Likes Received:
    0
    GPU:
    7900GTX
    it means "xD"
     
  4. ToyTen

    ToyTen Maha Guru

    Messages:
    1,218
    Likes Received:
    0
    GPU:
    MSI 1080 Gaming X
    very very clever...
    ok, men can close this topic, if it is for such comments, Thank you those that helped me as they could.
     

  5. ToyTen

    ToyTen Maha Guru

    Messages:
    1,218
    Likes Received:
    0
    GPU:
    MSI 1080 Gaming X
    I'm back again because the issue remains as at the start of this topic:

    no OC on gpu's,
    no AA anisotropic filtering at all or some of it,
    Any FW graphic drivers from the first supporting PhysX on G80's till the last 180.43 whql

    It is playable without artefacts only with the 175.16 whql... it is a long time ago already :(

    What really bothers me is that the PhysX really improve the fluidity of Crysis/~Warhead ... .. . No issue on the others GRID/NFS ProStreet/FarCry2 I could play at.

    I did try unninstalling the game till its last folder, same as for the G.Drivers.

    TBH I'd be surprised if there was a solution, as not too much people have that issue(fortunately enough).

    Thx if...
     
  6. CambridgeBullet

    CambridgeBullet Member

    Messages:
    11
    Likes Received:
    0
    GPU:
    285GTX + 8800GTX (PhysX)
    I have the same exact issue. I use the 175.16 drivers and all was okay. But with the release of Farcry 2 and Fallout 3 I decided to upgrade to the 180.43 driver set for improvements in those releases. I had slight improvement in Crysis and did not notice any corruption in Crysis (but I only ran the benchmark). Soon after I got a hold of Warhead and yikes, same graphic glitches as above. So I went into the first Crysis and played a bit and had them there. I backed up the profiles from the 180's using nHancer and went back to the 175's and the issues went away.

    I tried all releases of drivers as they have been released and the last working set were the 175 series in regards to the Crysis corruption. But with the 180's I have also noticed corruption in Call Of Duty 4 when a flashbang grenade went off...a greenish tint/pixalation. Everything else works great....no other bugs seen in any other game or 3D application.

    My system specs:

    - E6700 @ 2.66ghz
    - 4 gb Mushkin 800mhz RAM (XP only displays 2.50gb)
    - EVGA 780i MB
    - XFX 8800GTX XXX Edition
    - BFG 8800 GTX OC Edition
    - SLI
    - Corsair HX1000 (1000 watt) Power Supply
    - Windows XP with Service Pack 3
    - Soundblaster Audigy Gamer
     
  7. Hekynn

    Hekynn Master Guru

    Messages:
    431
    Likes Received:
    0
    GPU:
    GTX 460 1gb MSI HAWK
    Try out the 178.24 drivers they fixed my bugs I had the same thing.
     
  8. SumLeetNub

    SumLeetNub Member Guru

    Messages:
    130
    Likes Received:
    0
    GPU:
    Asus 780Ti DirectCU II
    dude,

    uninstall ONLY the graphics card drivers in control panel. reboot into safe mode, run driver sweeper or driver cleaner and choose the option for cleaning nvidia graphics cards drivers (obviously). reboot, install the 180.43 drivers, reboot, enjoy.

    that certainly looks like driver corruption, not hardware failure (u state u dont have ur card OC'd) im suprised no-one has told u to re-format yet!!!!
     
  9. CambridgeBullet

    CambridgeBullet Member

    Messages:
    11
    Likes Received:
    0
    GPU:
    285GTX + 8800GTX (PhysX)
    Well, in my case, I use Acronis True Image, so reformatting is a thing of the past for me. And I do use Driversweeper and I go 1 step further and uninstall ALL things Nvidia, and after all is reinstalled I also update DirectX for good measure. I have been doing this for years.

    It is obvious this is a driver issue. Perhaps new is not always better and the fact that Nvidia is trying to support the new gpu's, us who use OLD cards such as the 8800's may begin seeing more and more issues as newer drivers come out. Hey, just ask some of the 7 series card owners how they felt when the 8 series was released.

    So lets skip the driver cleaning stuff and lets only hear from others who have had the same issues and how/if they fixed the issue. Stop posting the obvious.
     
  10. ToyTen

    ToyTen Maha Guru

    Messages:
    1,218
    Likes Received:
    0
    GPU:
    MSI 1080 Gaming X
    Ok, Thanx guys, I really appreciate :)

    As what SumLeetNub suggested was the simpliest to me, I am trying this at the moment and, trying under C. Warhead, I have very few artefacts to deplore... but still I have. Not hopeless I start to think I should find a final solution by re-formating my 1 year old OS(not an old one so...).
    This because artefacts do change from "acceptable" to unbearable when I turn on the G15 log functionnalities AND Fraps.... No link to the game excepted the OS I guess ?

    I rebooted the "Warhead" edition of the incriminated and beloved game without any of Fraps nor LCDClock / ~Media processus from Logitech and the issue isn't looking the same as said right above.

    BTW this OS hasn't been OC'ed since I have other rigs to put on benching :D So I do not know for sure if I have to reformat it.... hoping the answer is no... up to me to find it out:cheers:


    Don't know what to say as a conclusion excepted that I clearly see an improvement here :D

    Thank you all helping me fixing this
     

  11. SumLeetNub

    SumLeetNub Member Guru

    Messages:
    130
    Likes Received:
    0
    GPU:
    Asus 780Ti DirectCU II
    lol, sorry, when i said im suprised no-one has told you to format, i didnt mean for you to do it, its just thats usually the answer someone gives, formating means you dont have to think and find the remedy.

    try the uninstalling and installing new drivers method as in my other post. i have same cards and same chipset and i notice no problems at all with my machine ever, unless they are a sh1t driver release or i dont get rid of rogue files with DC.net. give it a whirl, patience is a virtue, it also means that if ya system goes titsup again then you know how to solve the problem and not have your head in the shed for a few days while youre trying to sort it out.
     
  12. SumLeetNub

    SumLeetNub Member Guru

    Messages:
    130
    Likes Received:
    0
    GPU:
    Asus 780Ti DirectCU II
    ps...why are u running fraps? are you checking the FPS??? I havent used fraps for ages but when i used to i found it slowed my system down (not sure what its like now tho so i cant comment). If its just the FPS your looking for then use either rivatuner or evga precision and use the OSD server that comes with them.

    also, i have the same keyboard (blue backlight and had no trouble with that) what driver version are you running.

    and as for lets skip the driver cleaning, if he does skip the driver cleaning, how is he at least going to find a cure IF he does have rogue files??
     
  13. otaku

    otaku Ancient Guru

    Messages:
    1,813
    Likes Received:
    1
    GPU:
    8800,640gts sli
    i had those exact issues with crysis after i installed new drivers. for me just going back or using driver cleaner didnt work it was a full reinstall and back to old drivers that fixed it
     
  14. scandalous

    scandalous Master Guru

    Messages:
    718
    Likes Received:
    4
    GPU:
    980TI Classified
    What I find disturbing is that this guy's dx9 crysis looks better than my dx10 crysis....

    I've got everything set on Very High, and my resolution on 1920x1200.
    No AA or AF.

    Is there something I need to do (cvar perhaps) to make crysis look beter then it does now?

    Specs:

    8800gtx (OC)
    intel 8200 (OC)
    4gb ddr2 800mhz
    raptor 150gb 10000rpm
    700w PS
    Nvidia 680i mainboard
     
  15. ToyTen

    ToyTen Maha Guru

    Messages:
    1,218
    Likes Received:
    0
    GPU:
    MSI 1080 Gaming X
    yup^^ you could try imrove youre IQ with this :)

    http://www.incrysis.com/forums/viewtopic.php?id=23117 :)
     

  16. ToyTen

    ToyTen Maha Guru

    Messages:
    1,218
    Likes Received:
    0
    GPU:
    MSI 1080 Gaming X
    @ Scandalous:

    Did my tip helped a bit ?


    For me, I'm unlucky 'cuzz I still have my issues under Crytek's games :(

    Not giving up ! Hate those artefacts :biggun:
     
  17. scandalous

    scandalous Master Guru

    Messages:
    718
    Likes Received:
    4
    GPU:
    980TI Classified
    Yeah it somewhat worked, but I didn't really optimized the graphics after I installed it. I think I had to change some options in the cvar I guess because some of those screen looked so good. Nothing like mine.
     
  18. otaku

    otaku Ancient Guru

    Messages:
    1,813
    Likes Received:
    1
    GPU:
    8800,640gts sli
    threre is not much you can do. under some drivers harware seems very eratic. it will haven you chasing your head round and round. basic thing is just go back to the drivers you know and start again. i know it blows and with luck you wont need a reinstall :banana:
     
  19. ToyTen

    ToyTen Maha Guru

    Messages:
    1,218
    Likes Received:
    0
    GPU:
    MSI 1080 Gaming X
    There was not much to do in deed :(

    I switched from XP32 to Vista32 and everything is allright for months now.

    It was related to my XP sp3 i finally guess. Thanks for the help received.

    Cheers
     

Share This Page