1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

GPU Monitor Vista Sidebar Gadget Available

Discussion in 'Rivatuner Statistics Server (RTSS) Forum' started by stangowner, Feb 15, 2009.

  1. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    14,225
    Likes Received:
    1,291
    Precision doesn't provide support for exporting data to third party applications. There is no way to make a gadget compatible with it, sorry.
     
  2. sm007h

    sm007h Member

    Messages:
    22
    Likes Received:
    0
    GPU:
    NVidia 8800 GTS 512mb
    Ah, I see. Thanks for responding. I was worried about that but I wasn't certain if the RTSS portion could be used to send the information somehow.

    It's not even that big of a deal, except maybe one day the Precision Tool will be able to monitor cpu's. Would have been cool if it was coded to allow plugins like RT.
     
  3. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    14,225
    Likes Received:
    1,291
    It couldn't be used for that, RTSS is a server for DISPLAYING statistics into OSD, not for collecting it and polling hardware. And the Precision is is coded in the way it was assumed by contract with EVGA and it contains predefined fixed functionality set defined by licensing terms. So don't expect major changes there.
     
  4. sm007h

    sm007h Member

    Messages:
    22
    Likes Received:
    0
    GPU:
    NVidia 8800 GTS 512mb
    I thought EVGA and Rivatuner tools polled the data and sent it to RTSS.
    Is it not possible to have the RTSS display to a gadget in a similar way it displays to OSD?
     

  5. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    14,225
    Likes Received:
    1,291
    I've already said that it is impossible.
     
  6. stangowner

    stangowner Master Guru

    Messages:
    606
    Likes Received:
    10
    GPU:
    2xMSI N550GTX-Ti Cy II OC
    Hi ChaddlesMcGee,

    So are you saying that when you open the gadget you can see GPUMonitor.exe in the process list. And when you close the gadget it goes away?

    When you first start the gadget, are you receiving and error that displays for a few seconds before the error switches over to could not read XML data? If so, please provide that error code.

    Please send me a PM and we'll resolve this off-line, and then post our findings should it help others.

    - Nick
     
  7. sm007h

    sm007h Member

    Messages:
    22
    Likes Received:
    0
    GPU:
    NVidia 8800 GTS 512mb
    Did you select hardware monitoring and configure it to run in the background?
    On the main tab, you click the first drop-down ("customize") and to the far right is the picture of a magnifying glass that says "hardware monitoring". After you open that, you should see a bunch of graphs and down in the bottom corner, on the far left, there is a round, red button. Hover over that button and it should say "enable background monitoring." Depress the button and then you can close everything (keeping rivatuner in your taskbar) and then the plugin should display the information correctly.

    Hope that helps :)
     
  8. stangowner

    stangowner Master Guru

    Messages:
    606
    Likes Received:
    10
    GPU:
    2xMSI N550GTX-Ti Cy II OC
    Thanks for the assistance sm007h. However, if the issue was with RivaTuner not running, or running without the hardware monitoring enabled, the error would be:

    "Failed to connect to RTHM shared memory. Please start RivaTuner and activate the low-level hardware monitoring module"

    His error is concerning the XML not being found. So either GPUMonitor.exe is not running, or the gadget can't read the resulting XML.

    - Nick
     
  9. ChaddlesMcGee

    ChaddlesMcGee New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    2xSapphire Radeon 4870x2
    Hmm

    Hi Nick,
    You mentioned something about ie7. I don't and have not used ie7 since the op-system install. I use Firefox, however I checked ie7 options and all settings pertaining to xml are set as default .

    I can understand how frustrating it must be to not be able to diagnose the problem straight up. I have been there with some of my own software creations so once again I would like to thankyou for your patience in this matter.
    :)
    -Chad
     
  10. ChaddlesMcGee

    ChaddlesMcGee New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    2xSapphire Radeon 4870x2
    Thanks Nick,
    Gadget is now working 100%
     

  11. stangowner

    stangowner Master Guru

    Messages:
    606
    Likes Received:
    10
    GPU:
    2xMSI N550GTX-Ti Cy II OC
    Error: Could not read XML Data - Patch Available

    It is possible for certain monitors to cause the gadget to throw an XML error like this:

    [​IMG]

    This error is related to an XML encoding issue and a patch is available. Please PM/email me if you are experiencing this issue so we can confirm the cause and apply the patch. The fix will be included in the next release.

    Many thanks to CircuitMonkey and ChaddlesMcGee for their assistance troubleshooting and testing to resolve this issue.

    Please Note: If you are also seeing this error prior to the XML error, this patch will not resolve the issue. Please contact me to troubleshoot those issues.

    [​IMG]

    - Nick
     
  12. sm007h

    sm007h Member

    Messages:
    22
    Likes Received:
    0
    GPU:
    NVidia 8800 GTS 512mb
    I've gotten both of those errors :(
    I thought it was related to the solution I wrote.

    I've only had the errors once or twice, so I don't know how they resolved since it wasn't because of what I wrote or how to reproduce them.

    Should I just PM you if I have the problem again or do you need some info from me now?
     
  13. stangowner

    stangowner Master Guru

    Messages:
    606
    Likes Received:
    10
    GPU:
    2xMSI N550GTX-Ti Cy II OC
    If it is working fine and updating the values at the configured interval (3 seconds by default), then there's not much we can troubleshoot. And no, these errors are very different from the resolution you posted, as indicated by my reply.

    If it errors again in the future, please make note of the exact error and let me know.

    - Nick
     
  14. snoogans

    snoogans Member

    Messages:
    17
    Likes Received:
    0
    GPU:
    EVGA/Zotac GTX 470 SLI
    Thanks for this Wonderful Gadget. It's working Great for me with no problems until now and i am using Vista X64Bit with SP2
     
  15. Sylvan

    Sylvan New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    XFX HD 4870x2
    I'm getting the same error with Rivatuner 2.24

    "Could not read XML data"
     
    Last edited: Mar 1, 2009

  16. stangowner

    stangowner Master Guru

    Messages:
    606
    Likes Received:
    10
    GPU:
    2xMSI N550GTX-Ti Cy II OC
    Please email me your "C:\Users\<username>\AppData\Local\Temp\GPUMonitor.xml" file to the email address listed in the gadget. As soon as I confirm it is the XML encoding issue, I'll send you a URL for the download and instructions to patch.

    Thx, Nick
     
  17. Mezevenf

    Mezevenf New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    ATI HD4870X2
    Hey,

    I too am having the above problem, if I attempt to look at the XML IE7 shows

    An invalid character was found in text content. Error processing resource 'file:///C:/Users/Mezevenf/AppData/Local/Temp/GPU...

    <monitor title="#0:Core temperature \ display IO

    I have emailed a copy of it to your address listed in the app, any help would be appreciated I'm looking forward to using this gadget as intended :)
     
  18. ChaddlesMcGee

    ChaddlesMcGee New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    2xSapphire Radeon 4870x2
    Hehehe.
    Interesting. good thing you got a patch now. :)

    Mezevenf...I had exactly the same problem. You just need the patch and it will fix the problem otherwise if you need an imidiate fix then disable all the coretemp\ display
    coretemp\mem
    coretemp\shader
    monitors in rivatuner .
     
    Last edited: Mar 1, 2009
  19. Mezevenf

    Mezevenf New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    ATI HD4870X2
    His patch worked a charm :) Thanks again Nick.
     
  20. Tom|Nbk

    Tom|Nbk Member

    Messages:
    15
    Likes Received:
    0
    GPU:
    ATi Radeon HD4870X2
    Can I have the patch please. Same XML problem.
     

Share This Page