1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

GPU Monitor Gadget 2.0 Released

Discussion in 'Rivatuner Statistics Server (RTSS) Forum' started by stangowner, Apr 6, 2009.

  1. stangowner

    stangowner Master Guru

    Messages:
    606
    Likes Received:
    10
    GPU:
    2xMSI N550GTX-Ti Cy II OC
    So you are stuck on #2 in the instructions, and receiving the error that says "Failed to connect to RivaTuner......"?

    In the RivaTuner window on the "Main" tab, click the "Customize" button in the "Target Adapter" section. This will create a flyout with several options. Click the icon of a chip with a magnifying box on it. This opens the hardware monitoring. Then make sure you also follow #4 to enable monitoring in the background.

    I don't have any step by step instructions more detailed then what is in the gadget yet. I am working on a video based RT guide which includes details on the gadget, keyboard, OSD, profiles, launcher, OCing, etc. It is only half baked right now, but I could get you a clip on the gadget portion if you really need it. Send me a PM if so.

    - Nick
     
  2. barracuda

    barracuda New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    BFG GeForce 8800GTS 512
    I want to thank you for making this awesome gadget, stangowner.

    I am curious as to what people are using as intervals for core/ambient temps. As it sits now for me my core is @ 50c and ambient is 45c, but the graph bar is maxed out.

    I'm just starting to get into OCing and haven't actually done anything to my 8800GTS 512 yet. Does anyone have any suggestions for what I could set the temp intervals to in order to get a more accurate graphical representation?

    Thanks for you time!
     
  3. stangowner

    stangowner Master Guru

    Messages:
    606
    Likes Received:
    10
    GPU:
    2xMSI N550GTX-Ti Cy II OC
    For temps, the gadget defaults to 20/75/80/85/90 °C. So the left edge of the bar (0% full) represents 20 degrees. And the right of the bar (100% full) is 90 degrees. If you prefer the bar to match percentage, change the lower limit from 20 to 0, and the upper from 90 to 100. Now something like a 75 degree temp would fill 75% of the bar. But if 50 is maxing out the bar, then you must have changed these limits.

    The 3 middle values indicate the color for the bar. So >85 the bar is red, 80-85 orange, 75-80 yellow and <75 is green. These should be fairly good starting points, but you can change as you feel fit. For instance, 75 is a fairly common temp to hit just gaming, so if you don't want it to turn yellow, then adjust those values. And some newer cards frequently run over 90 degrees. Too hot for my liking, but supposedly fine for some cards. Personally, if my core is hitting 90°, I'm shutting down whatever is causing that to happen (bechmark, etc).

    If you correct the bar display, and still need more accuracy then the bar itself, just make sure you select a display style which also has the number itself visible. Or use RivaTuner's hardware monitoring window.

    Hope that helps.
    - Nick
     
  4. barracuda

    barracuda New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    BFG GeForce 8800GTS 512
    thanks for your help! I don't know why, but these were my default values:

    [​IMG]

    I put in the numbers you listed and it is working fine now.

    thanks again.
     

  5. stangowner

    stangowner Master Guru

    Messages:
    606
    Likes Received:
    10
    GPU:
    2xMSI N550GTX-Ti Cy II OC
    It looks like the default °C values received a °F to °C conversion. Let me dbl check the code and see exactly what triggers the conversion and if I can reproduce the issue.

    Or is it possible that you entered the default °C values while in °F and changed back to °C.

    Glad its working now!
     
  6. tmsjava

    tmsjava New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    ATI/Radeon HD 4850/512
    Ok, see that's the problem.....under customize, I don't have a box with a magnifying glass!! Only have 3 options: low level refresh rate, low level desktop color scheme, and graphics report. I have version 2.24. Hmmm.....Maybe I don't have the correct version?

    T.
     
  7. stangowner

    stangowner Master Guru

    Messages:
    606
    Likes Received:
    10
    GPU:
    2xMSI N550GTX-Ti Cy II OC
    And in the combo box for the target adapter, it says "ATI Radeon HD 4800 series..."? What make/model card is it exactly?

    My wife also runs a 4850 (the 1 GB version) and RivaTuner shows the button and has no issues polling the hardware.
     
  8. tmsjava

    tmsjava New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    ATI/Radeon HD 4850/512
    Error

    It's a Radeon HD 4850 with 512 MB. In the Target Adapter box, it says "ATI Mobility Radeon HD 4850/Generic PnP Monitor".

    T.
     
  9. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    14,392
    Likes Received:
    1,415
    Then the answer into RivaTuner's readme in <System requirements> section.
     
  10. leper

    leper New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    ATI Radeon 4870 1GB GDDR5
    Beta Testing??

    Nick,

    Wassup bro? Do you have a patch I can try? Lets do some more beta testing on the new release/patch! if there is there a new release/patch I should say? I am game whenever you are ready. No pun intended!!! LOL

    BTW....I helped Nick with the beta testing of this gadget from the day that I got my new comp and video card (we go way back since we were kids growing up). I said it would be sweet if there was a sidebar gadget for video cards. Nick was like "Ahh, I programmed one." I was like get out of here I want to check it out. Anyways, Long story short I helped push him to release the first beta v1.0 and I was a beta tester from there on and I used it from the end user (dummy aspect seriously!!!) and he helped me out alot to get it working and I helped him fix some issues or basically notice the ones he already knew about. I hope I gave him some valuable information...lol...More like feedback. :)

    Great work on this Nick. I know you work many hours a week at your job and countless hours on this at night. I give you many props and proud of what you have accomplished on this gadget since long before December 2008 when I found out about this GPU monitor you programmed.

    I guess this is how you get paid back. With great positive feedback. Kinda like eBay!!! :flip2: :)

    Thanks,
    Leper aka Chris
     
    Last edited: May 22, 2009

  11. stangowner

    stangowner Master Guru

    Messages:
    606
    Likes Received:
    10
    GPU:
    2xMSI N550GTX-Ti Cy II OC
    Wsup kid,

    You and Evilmeat are the only 2 who have even mentioned the freeze issue I posted about earlier in this thread. And no one has mentioned the reorder issue at all.

    I gave Evilmeat a patch to test a few weeks ago, as it was happening so often. It did seem to fix his freezing issue, but I managed to introduce another bug that I need to iron out. Once I do that, I'll have a beta for you guys to hammer.

    But because these issues are so isolated, I decided not to rush the 2.1 version like I did 1.1, and instead incorporate some other improvements. So I've added some other stuff in addition to the 2 points I mentioned earlier.

    There are a few more display options, including a graph like the one in Rivatuner. So now you will be able to do something like this if you want. I just need to polish it a bit more.

    [​IMG]

    Been working on a few other projects as well. And my wife's alts are starting to outlevel my mains! Can't let that happen!

    I'll have something for you soon.

    - Nick
     
  12. rellikzephyr

    rellikzephyr New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    HIS 4890 1G OC 900/4000
    hey stangowner

    i also have the stops updating problem

    and it happens very regularly, i mean very

    closing and reopen gadget works for me tho little annoying

    just thought i would let u know another occurrence of it

    side note, i have 4890 and am using cfg file fix in rivatuner

    Thanks

    Excellent gadget by the way just excellent good work

    RellikZephyr
     
  13. stangowner

    stangowner Master Guru

    Messages:
    606
    Likes Received:
    10
    GPU:
    2xMSI N550GTX-Ti Cy II OC
    Hi RellikZephyr,

    I should have the 2.1 RC ready later tonight which includes that fix. PM me an email address and I'll send you some instructions for updating. Or you can just wait for the 2.1 release which should be along shortly now.

    - Nick
     
  14. stangowner

    stangowner Master Guru

    Messages:
    606
    Likes Received:
    10
    GPU:
    2xMSI N550GTX-Ti Cy II OC
    GPU Monitor gadget version 2.1 is now available. This update includes the following:

    - 8 new display styles including graphs (18 in total now)
    - multiple gadget support
    - a new hardware acceleration bar for displaying the state of DD/D3D8/D3D9/D3D10/OGL
    - added a few more monitor icons, and all monitor icons are now selectabe for the title icon
    - fixed reorder and refresh freeze bugs

    You can download the new version here.

    - Nick
     
  15. Ginger Fish

    Ginger Fish New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    XFX GeForce 9800GTX
    I have problem using GPU Monitor 2.1 gadget. After installation it doesn't work. In gadget settings this message: "Display adapter preferences not found". RivaTuner 2.24 installed, hardware monitoring enabled, using driver 186.18 in driver emulation mode. Configuration info in my profile. Using Windows 7 x64 edition. What's wrong? Beforehand thanks!
     
    Last edited: Jul 22, 2009

  16. stangowner

    stangowner Master Guru

    Messages:
    606
    Likes Received:
    10
    GPU:
    2xMSI N550GTX-Ti Cy II OC
    Can you please tell me what files exist in the "C:\Users\<username>\AppData\Local\GPUMonitor" directory?

    Also, please close and reopen the gadget. Tell me what error(s) display in the gadget itself, before trying to access the preferences.

    Did you ever run a previous version of the gadget? Or is this a new install?
     
  17. Ginger Fish

    Ginger Fish New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    XFX GeForce 9800GTX
    Sure. In the C:\Users\<username>\AppData\Local\GPUMonitor directory exist 2 files: prefMonitors_0.json and prefWindow_0.json. Gadget itself displays no errors. In gadget window this message: "Loading... Please see gadget settings for installation and configuration information". I didn't ever run previous version of this gadget. This is new install.
     
    Last edited: Jul 22, 2009
  18. stangowner

    stangowner Master Guru

    Messages:
    606
    Likes Received:
    10
    GPU:
    2xMSI N550GTX-Ti Cy II OC
    You have a file missing in that directory. There were no code changes in this area of the gadget from 2.0 to 2.1, so you would experience the same error even if you tried to run 2.0.

    The issue is the code that queries WMI to get information about the installed display adapters for the machine is failing. So something is wrong with the WMI on that PC. Normally, I would ask you to run the WMI Diagnostics Utility and fix the errors that are reported. This should resolve the issue with the gadget. However, I do not believe that M$ has updated that utility for Windows 7 and running the existing version does not work (I can confirm tonight, but I do not have access to a Win7 machine ATM - maybe they added a PowerShell diagnistic script in the windir\diagnostics directory, I'm not sure).

    For now, can you download and install the WMITools. These do work on Win7. Open the WMI Object Browser (must use IE) and see if you can get to the following object:
    root\CIMV2
    Win32_ComputerSystem.Name="<computername>"
    Win32_SystemDevices.PartComponent
    Win32_VideoController.DeviceID="VideoController1"

    Perhaps it will throw an error which we can try to resolve.

    So try that and let me know how you make out. And I'll let you know what I find tonight on my Win7 PC. Worst case, I can fabricate a file for you that will allow you to use the gadget, and just bypass the WMI stuff.

    - Nick
     
  19. burebista

    burebista Ancient Guru

    Messages:
    1,719
    Likes Received:
    24
    GPU:
    MSI GTX 1060 GAMING X 6GB
    Works OK here. Thanks a lot stangowner. :thumbup:

    [​IMG]

    One question though. It's possible to modify upper/lower limits for graphs? I'll never ever have 5000 RPM on my fans. :D
    For example in RivaTuner Hardware monitoring all are set to upper limit at 1500 RPM.
     
  20. stangowner

    stangowner Master Guru

    Messages:
    606
    Likes Received:
    10
    GPU:
    2xMSI N550GTX-Ti Cy II OC
    Sure, they are using the Min and Max limits on the advanced tab of the gadget options (they are not using what is in RivaTuner). You can also change the colors and color change intervals as well.
     

Share This Page