GPU Monitor Gadget 2.0 Released

Discussion in 'Rivatuner Statistics Server (RTSS) Forum' started by stangowner, Apr 6, 2009.

  1. stangowner

    stangowner Master Guru

    Messages:
    586
    Likes Received:
    0
    GPU:
    2xMSI N550GTX-Ti Cy II OC
    GPU Monitor Gadget 2.1 Released

    Version 2.0 of the GPU Monitor sidebar gadget is now available. This version adds extensive user customization options.

    General options and features:
    - Colors: background, border, title text, default monitor title/value/units text
    - Title: customize the text and icon
    - Filter to remove RivaTuner's monitors from display in the gadget
    - Flyout window provides additional information from RivaTuner and WMI
    - Ability to reset min/max values
    - Celcius/Fahrenheit

    You can also customize each monitor's display individually:
    - Colors: use default or override title/value/units text
    - Bar: specify min/max limits as well as color change limits
    - Choose from 10 different display styles
    - Choose from 20 different icons
    - Change displayed monitor title text
    - Add a separator to help group similar monitors
    - Copy settings from 1 monitor to another with control over what is pasted

    You can download the new version here

    Thanks,

    Nick

    EDIT: Notes for current version can be found here
     
    Last edited: Apr 14, 2010
  2. morbias

    morbias Don TazeMeBro Staff Member

    Messages:
    13,336
    Likes Received:
    4
    GPU:
    -
    Discussion on previous versions can be found here
     
  3. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    12,957
    Likes Received:
    45
    Good job!
     
  4. AnthonyB

    AnthonyB New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    2 x ASUS EN8800GT 512MB
    Great stuff Nick - love the new version!
     

  5. Shmeeg

    Shmeeg New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    Sapphire HD 4870 512mb
    Settings not being saved

    Hi guys,

    This site has helped solve many problems with my computer in the past whilst browsing the forums and I'm hoping you can help with this one.

    GPU monitor is by far the best monitoring tool out there, I love the way it combines everythin so you dont need oddly coloured gadgets tellin you different things, anyway...

    I'm using rivatuner 2.24 and Everest to get all of my sensor data, using 3 gpu monitors to display GPU, CPU and HD stuff. However, when I shut down or restart, the settings for the 3 instances all seem to copy each other, example:
    Using one instance to show HD temps, page file and memory usage, now when I restart, all 3 instances will have the same boxes ticked and will all show HD temps page file and mem usage...

    Hope this makes sense and looking forward to any (helpful ;D) responses.

    P.s. The names of the bars that you can edit (core temperature \shadercore --> Shader Temp) also reset.
     
  6. stangowner

    stangowner Master Guru

    Messages:
    586
    Likes Received:
    0
    GPU:
    2xMSI N550GTX-Ti Cy II OC
    Version 2.0 does not save separate preferences for multiple instances of the gadget. If you are using multiple instances of the gadget, the last one to save the preferences wins, and all the others will use them when loading. So for now, you'll have to get by with one gadget, and use the separator to organize them the best you can.

    I'm currently working on version 2.1 which currently is slated to have 2 improvements and 2 bug fixes resolved.

    Improvements
    1. Hardware acceleration will now have a dedicated area to display as it is poorly suited in the other display options. This will show you the state of DD/D3D8/D3D9/D3D10/OGL
    2. Add the ability to have multiple instances of the gadget (no longer sharing preference storage)

    Bug Fixes
    1. It is possible for the gadget to stop updating. This is caused by a rare unknown issue (possibly a timing issue reading ram). The fix will gracefully handle this situation so the gadget refresh will continue normally. Personally, I have only had this happen twice - about 5,000,000 gadget refreshes apart. I have only heard of one other user experiencing the issue. You can simply close and reopen the gadget to resolve the issue.
    2. It is possible during reorder or adding additional monitors in RivaTuner that some settings may be lost in the gadget. For instance, if you have 12 monitors and you reorder #12 up to #9, then you may loose the settings for #10-12 (#1-9 will not be affected). Deleting monitors or adding monitors to the end of the list (like adding a new plug-in) do not cause this to happen.

    I do not have a release date yet for 2.1. As soon as I do, I'll mention it in this thread.

    - Nick
     
  7. Shmeeg

    Shmeeg New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    Sapphire HD 4870 512mb
    Thankyou for the response,

    Glad to know it wasn't my Windows 7 :D (No problems whatsoever so far) (build 7077)

    Looking forward to 2.1
     
  8. Hilbert Hagedoorn

    Hilbert Hagedoorn Don Vito Corleone Staff Member

    Messages:
    29,842
    Likes Received:
    133
    GPU:
    AMD | NVIDIA
    Hey man, updating right now, thanks for the heads up !

     
  9. WiFiNodE

    WiFiNodE New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    GeForce 8800GT
    Thanks Nick for a great sutff.

    I used this version for weeks but somehow my Avast is continuous scanning on gpumonitor.json.

    I know i could configure to bypass .json for not scanning it, but just wondering whether any way to change the cache file (or whatever u named it) from .json to .log or other, which most antivirus will ignore by default.
     
  10. stangowner

    stangowner Master Guru

    Messages:
    586
    Likes Received:
    0
    GPU:
    2xMSI N550GTX-Ti Cy II OC
    The file is written as "%temp%\GPUMonitor.json" and is not user configurable. You'll have to add the exception for this one file. Thanks for mentioning, and I'll consider changing in future releases.
     

  11. meta-fm

    meta-fm New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    nvidia 9800gtx+
    Gpu Monitor will stop working if...

    ... I RDC the PC where it runs. Starting the GPUMonitor.exe will make ir run again but as soon as I restart the PC it won't work. I guess while I remote desktop the PC the OS tweak itself and then the autostart of the GPUMonitor.exe is broken. I'll try to diff the regedit settings if I have time.

    Thank you for the cool gadget.
     
  12. stangowner

    stangowner Master Guru

    Messages:
    586
    Likes Received:
    0
    GPU:
    2xMSI N550GTX-Ti Cy II OC
    I RDP to my work machine all the time. It is Vista Business SP1 32 bit. I've been using Win7 as a primary OS at home for the past few months (triple booting Vista 32, Win7 32 and Win7 64). It is easier for me to RDP to work to test the gadget when I'm coding then it is for me to reboot back into Vista. I notice that the Windows Sidebar does not start automatically, but opening that causes the gadget to open and it properly launches GPUMonitor.exe. So I'm not sure why you would be having an issue. RivaTuner, Windows Sidebar and the gadget are opening at login - but the gadget is not lauching GPUMonitor.exe?

    You did not mention, are you logging out (so RDP is a fresh login) or connecting to an existing session? I've tried both, and have not had any issues.

    The only other thing I can think of is that your WMI repository on the remote machine may be partially corrupted. The gadget uses WMI to launch GPUMonitor.exe. You can verify by running the WMI diagnostics found here.

    Please let me know how you make out.

    - Nick
     
  13. evilmeat

    evilmeat New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    9800GX2 @756/1782/2160
    I see this bug very often. It happened after one or two days without relogins or restarting the sidebar. Refresh interval is one second for me and i use monitor for all 4 CPU cores usage, all CPU & GPU temperatures and fans. In this case 5000000 refreshes likes as true in short time.
    I'l be waiting for 2.1 which fixes this bag. Thanx for good job.
     
  14. stangowner

    stangowner Master Guru

    Messages:
    586
    Likes Received:
    0
    GPU:
    2xMSI N550GTX-Ti Cy II OC
    I've been having some difficulty ensuring my fix works, because I can not reliably reproduce the issue. I have had it occur 2 more times - but about 1 1/2 weeks apart. I also set my refresh to 1 sec and leave it running 24x7.

    The next time it happens, can you please check the process list in the task manager and tell me if GPUMonitor.exe is listed?

    I'm just about done with the other points mentioned, plus added a few other minor things. If you experience it this often, would you like to beta test some updated code? If so, send me a PM.

    Thanks, Nick
     
  15. evilmeat

    evilmeat New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    9800GX2 @756/1782/2160
    GPUMonitor.exe is listed in processes in case of gadget stucks. I say more, if i restart sidebar, second copy of gpu monitor runs while old copy not unloads. And 3 and more copies after next and next sidebar restart.
     

  16. stangowner

    stangowner Master Guru

    Messages:
    586
    Likes Received:
    0
    GPU:
    2xMSI N550GTX-Ti Cy II OC
    Thanks for the info. This is what I would expect. I just wanted to confirm.

    When the gadget freezes, it no longer can run the code to stop the GPUMonitor.exe process. This is why it is creating multiple instances. Version 2.1 has code to ensure that only 1 instance of GPUMonitor.exe will run, as it will support multiple instances of the gadget.

    I received your PM. Give me a few days to finish one last thing, and I'll send you a 2.1 beta.

    Thanks,
    - Nick
     
  17. evilmeat

    evilmeat New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    9800GX2 @756/1782/2160
    And one thing more. gpumonitor.exe ALWAYS stay in memory after closing sidebar. No diffs gadget freezes or works normally. And always runs new copy of gpumonitor.exe.
    Thanx for your quick replies.
     
    Last edited: May 2, 2009
  18. stangowner

    stangowner Master Guru

    Messages:
    586
    Likes Received:
    0
    GPU:
    2xMSI N550GTX-Ti Cy II OC
    If you close the gadget, I would expect it to stay loaded if the gadget was frozen, because the code to close it will not run. However, it should close properly when the gadget is closed if the gadget is working normally.

    Closing the sidebar directly (not the gadget) does not send an unload event to the gadget, so it stays running. But reopening the sidebar does not create a 2nd instance. This is the way M$ implemented the sidebar.

    Can you please verify it unloads properly if you close a working gadget? If not, would you also mind running the WMI diagnostic utility to ensure it comes up clean? Please let me know.

    - Nick
     
  19. evilmeat

    evilmeat New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    9800GX2 @756/1782/2160
    In case of close gadget (not sidebar) gpumonitor.exe unloads from memory. It's correct. But i repeat in case of restart sidebar a new instance of gpumonitor is created. I PM for you link to my wmidiag logfile as you ask.
     
    Last edited: May 3, 2009
  20. tmsjava

    tmsjava New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    ATI/Radeon HD 4850/512
    I keep getting the error.....couldn't figure out how to set up RT for the gadget I guess. I tried to find the low level monitoring......where is it? I looked at the instructions on the gadget and saw the red box where I was supposed to click on RT to set it up, but those don't appear on my RT! Is there somewhere that has step by step instructions on how to set it up?

    Thanks,
    T.
     

Share This Page