GPU changing clock speed during games (R7950). Also Graphics Overdrive question.

Discussion in 'Videocards - AMD Radeon' started by ReBeL, Jul 17, 2014.

  1. ReBeL

    ReBeL Ancient Guru

    Messages:
    2,102
    Likes Received:
    3
    GPU:
    MSI RTX 2080 S 8GB
    I've noticed some hitching/stuttering in games and I'm 99% sure I've narrowed it down to clock speed variations. I can watch CCC during a game, and it will jump between 500, 880 and 960 MHz. It throttles down to 500 Mhz if the player is currently in a menu screen or talking to an NPC, and then it jacks back up to 880 or 960 when I (or my wife) get back into the actual gameplay, sometimes with a corresponding hitch/stutter. It doesn't make games unplayable or anything...it's just annoying and I would like to eliminate it.

    Anyway, I spent some time looking this up. I know there is at least one third party application available that will lock the speeds to be constant, but since I still want the lower clock speeds when we're not gaming, I would have to toggle this on and off every time we wanted to start a game. If that's my only option, so be it, but I'm hoping there's a better solution that will lower the clocks in 2D/desktop activity and raise them to a static speed when we're in game.

    Let me give you some more details about my set up. I'm gaming on a 50" plasma LG TV via HDMI from the PC, which is in an adjacent room. I haven't been able to determine if this same issue occurs when playing on on a single PC monitor, because I would have to ALT+TAB out of the game to see CCC, which probably would throttle the clock speeds.

    I'm using Catalyst 14.4

    I do not have Afterburner installed right now, but based on what I've read elsewhere, it doesn't offer a solution. If that's not the case, by all mean please let me know.

    Second question:

    Graphics overdrive is disabled in CCC, with the GPU overdrive speed set at 960 MHz. I know the stock GPU clock on my R7950 is 880 MHz. Even though I have graphics overdrive disabled, as I mentioned above, the GPU clock still often goes up to 960 MHz during games. Should that be happening? I did buy this card used....is it possible this has been set in the card's BIOS somehow?

    If I enable graphics overdrive, the fan speed immediately jacks up to 70% right there in desktop, which is totally unnecessary. Might have something to do with the "power level" setting, which I admit I haven't taken time to research yet. That's something I'm not familiar with, because I never saw it as an option in CCC when I had my 6870 HD.
     
  2. crz

    crz Member Guru

    Messages:
    186
    Likes Received:
    0
    GPU:
    GeForce GTX 1070 ARMOR 8G
    Bitcoin/Litecoin mining BIOS maybe? Or 7950 w/ boost BIOS?

    Try to flip the BIOS switch on the graphic card, reboot and check how the backup BIOS performs.
     
  3. ReBeL

    ReBeL Ancient Guru

    Messages:
    2,102
    Likes Received:
    3
    GPU:
    MSI RTX 2080 S 8GB
    I fixed the 70% speed issue. I didn't notice before that manual fan speed control was checked down at the bottom, and it was getting activated when I checked Enable Graphics Overdrive. I unchecked Manual Fan Control, and that took care of it.

    I suppose that's quite possible. I'll check into it.
     
  4. Pill Monster

    Pill Monster Banned

    Messages:
    25,214
    Likes Received:
    9
    GPU:
    7950 Vapor-X 1100/1500
    To stop GPU clocks jumping around move the PowerTune slider to 20%.

    *Btw 880mhz is stock only on Rev1 7950's, later R2 versions have anywhere from 900mhz -1050mhz boost clocks.
     
    Last edited: Jul 17, 2014

  5. ReBeL

    ReBeL Ancient Guru

    Messages:
    2,102
    Likes Received:
    3
    GPU:
    MSI RTX 2080 S 8GB
    I'll try that, thanks.

    I see. I'm sure I probably have the later revision. The manufacture date in the SN is May 2013.
     
  6. ReBeL

    ReBeL Ancient Guru

    Messages:
    2,102
    Likes Received:
    3
    GPU:
    MSI RTX 2080 S 8GB
    Setting the power limit to 20% didn't stop the fluctuating clock speeds.

    For gaming I make my TV in the living room the primary display and use it via HDMI. Maybe it has something to do with that?

    Eh, it's not really that big of a deal. Lately we haven't noticed the stutters as much.
     
  7. WittyScreenName

    WittyScreenName Banned

    Messages:
    42
    Likes Received:
    0
    GPU:
    Sapphire r7 260x 2gb

    That is not the case,Afterburner is my go-to program to get around PowerTunes dynamic core clock(and static memory clock),which does cause major stuttering.


    After downloading MSI afterburner you need to set clock profiles for your 2D and 3D speeds.
    Use the sliders to set your stock core and memory speed(880/1250 or overclock if you're comfortable),click "Apply" then "Save" and select Profile 1

    Next lower the core and memory sliders as far as they'll go,Apply and Save to Profile 2.
    Now go into Settings and find the "Profiles" tab on the right and save your profiles to the appropriate slot,like this.

    Next you need to disable PowerTune(Previously called PowerPlay)
    like this,which is located in the General Tab in the Settings Window.

    Reboot and now MSI Afterburner should be in control of your clocks.
     
  8. ReBeL

    ReBeL Ancient Guru

    Messages:
    2,102
    Likes Received:
    3
    GPU:
    MSI RTX 2080 S 8GB
    I'm not at home right now, but I'm pretty sure the cutoff on the low end of the core was 400 MHz. I can't remember the memory limit right now. Do you know if there's a way to make it go lower than that?
     
  9. WittyScreenName

    WittyScreenName Banned

    Messages:
    42
    Likes Received:
    0
    GPU:
    Sapphire r7 260x 2gb
    Ive heard reports of people lowering the sliders to the limit,applying,closing MSI AB then restarting it where the clocks will be the same frequency but the sliders will have room to go lower once again. Ive never been able to make it work though.

    Ive also heard about "hacks" you can make in catalyst Control Center powerstates,but we're going around those powerstates to begin with.

    While Afterburner is running,you can hit the "Reset" button and that should* take your card clocks to the PowerTune 2d levels of 150/300 core/mem,but thats where people reported big problems with flash and some webpages.

    *Sometimes my memory likes to ramp up to full speed and stay there after hitting reset,just like it sometimes happens after closing a 3D application while PowerTune is active.
     
    Last edited: Jul 23, 2014
  10. Pill Monster

    Pill Monster Banned

    Messages:
    25,214
    Likes Received:
    9
    GPU:
    7950 Vapor-X 1100/1500
    Just to clear a few things up:

    Firstly, disable unofficial overclocking on GCN cards, it's only there for compatibility and is unstable. Do not use it. I repeat. Do not use it.

    -In fact Rebel I wouldn't be surprised if it was the cause of your black screens in FNV.

    -PowerTune cannot be disabled, only adjusted. And PowerTune has nothing to do with unofficial overclocking either, they're 2 different things.

    -Clock speed adjustments in AB apply to 3D clocks only. The 2D profiles in AB are ignored.

    -there are no "hacks"to control P-States". AMD have 2D, 3D and UVD modes, that's it. 2D and UVD adjustments must be done via BIOS mod (which is what I did btw).


    -Flash video and HW accelerated browsers both use UVD clocks and are know to be very unstable. Disable HW acceleration if you get instability.

    Catalyst Overdrive and AB conflict with each. Overdrive must be disabled in CCC if AB is used for overclocking. Also, fan speed has to be set to auto in CCC.
    Preference is to completely stop CCC from running at Windows startup, 2nd preference is delay AB so it runs after CCC not before when booting.

    -Rebel, if adjusting PowerTune slider to 20% didn't stop fluctuations then it hasn't been applied properly. This may be due to CCC conflict unless you did it in CCC not Afterburner.

    As mentioned above AB is by far the better application to use, CCC and Overdrive are pretty crap. I think a lot of your troubles will cease by not using catalyst.


    But yeah def disable Unofficial OC man. It causes jumping vcore and desktop artifacts all sorts of crap.
     
    Last edited: Jul 27, 2014

  11. WittyScreenName

    WittyScreenName Banned

    Messages:
    42
    Likes Received:
    0
    GPU:
    Sapphire r7 260x 2gb
    Uhm..what? No?

    So the 2D profile in AB i just a lower clocked 3D?

    Point is,it DOES stop the fluctuating clock speeds. You cannot say it doesnt,im watching it. He said he's narrowed it down to speed fluctuations and this stops it.

    Ive had many people follow my above steps and it's improved lots for each one.

    Edit;
    Power slider does not equal PowerTune slider,just to clear that up.
    The Power slider wont stop fluctuations,it's only a max limit,not minimal.

    That's why im telling him to disable it(PowerTune) in AB and let AB control the clocks.

    And it appears the Power states were for Nvidia Inspector.
     
    Last edited: Jul 27, 2014
  12. Pill Monster

    Pill Monster Banned

    Messages:
    25,214
    Likes Received:
    9
    GPU:
    7950 Vapor-X 1100/1500
    Yep, it's set by the BIOS. AB has no power over 2D clocks.

    No it doesn't. The 3D clocks fluctuate because the card is trying keep within the TDP limit set by the PowerTune slider. That's what the slider is for.

    2D clocks always stay the same.

    Yes actually it does, just to clear that up.

    Wrong again, it will.

    Again, wrong.

    PowerTune does not control clocks. It only adjusts TDP limit within the range hard coded into the BIOS. IT CANNOT BE DISABLED.


    UOC is included with AB for compatibility with older cards. Unwinder even warns in tooltips against using UOC because it's so unstable.
    PowerPlay "without" option is for GPU's that do not support PowerPlay. That's why is says "without" instead of "disabled".

    The point is UAC should never be used on 7xxx or 2xx or 6xxx cards.


    You're not familiar with AB and you don't understand how AMD GCN architecture, so please just stop handing out bad advice.


    And btw don't talk BS about being part of G3D "old timers" club since 2003, we all know that's not true.
     
    Last edited: Jul 27, 2014
  13. WittyScreenName

    WittyScreenName Banned

    Messages:
    42
    Likes Received:
    0
    GPU:
    Sapphire r7 260x 2gb
    So even with the "powertune" slider +20%,the ~500mhz core clock i was getting in Guild Wars 2 is due to what? Im pretty sure it doesnt have to limit my clocks by half to stay in the TDP limit.
    800-900mhz in Tomb Raider 2013.


    I am familiar with AB and RT,i admit im new to AMD GPUs. But after having this for months and after months of looking for a way to stop PowerTune from controlling my 3D Clocks,this worked.
    I was off by 2 years,i joined in 2005. Dont remember how long i lurked.
    Im LowBudgetGamer

    You obviously dont know what you're talking about there.
     
    Last edited: Jul 27, 2014
  14. ReBeL

    ReBeL Ancient Guru

    Messages:
    2,102
    Likes Received:
    3
    GPU:
    MSI RTX 2080 S 8GB
    I was able to stop the clock speed fluctuations by following the instructions in post #7. However, AB causes game crashes (I posted in another section about it), and I'm tired of spending time trying to figure out how to fix it. I'd rather just deal with the occasional stutter from the clock speed variations. It's really not that bad.
     
  15. WittyScreenName

    WittyScreenName Banned

    Messages:
    42
    Likes Received:
    0
    GPU:
    Sapphire r7 260x 2gb
    Since you edited that bit in. It can be disabled.
     

  16. Pill Monster

    Pill Monster Banned

    Messages:
    25,214
    Likes Received:
    9
    GPU:
    7950 Vapor-X 1100/1500
    Man you're frustrating.

    I told u that the "without" option is for using UOC on GPU's that don't support PowerPlay.
    If a GPU has PowerPlay you select "with" If it doesn't, you select "without". It's for really old gpu's.. It's not there to DISABLE IT.

    How much clearer can that be?


    And back to the main crux of this argument; let me clarify;

    POWERTUNE CAN NOT BE DISABLED ON GCN CARDS
    .

    Get that through your fukn head.
     
    Last edited: Jul 27, 2014
  17. Pill Monster

    Pill Monster Banned

    Messages:
    25,214
    Likes Received:
    9
    GPU:
    7950 Vapor-X 1100/1500
    The guy who told u that doesn't know what he's saying.

    I'm 38, I've been using AB since RT in 20005 mate and I know how it works. However I'm happy not to help if not to help if you're not gonna listen anyway

    Btw I'm running AB with Skyrim and FNV with the same card yet I don't seem to have any trouble. Neither does anyone else....




    I'm gone.
     
    Last edited: Jul 27, 2014
  18. Pill Monster

    Pill Monster Banned

    Messages:
    25,214
    Likes Received:
    9
    GPU:
    7950 Vapor-X 1100/1500
    Here's an idea, why don't we just get Unwinder to sort you out. Would that be OK?

    Maybe he can explain in a language u can understand how unofficial overclocking is not recommended because it is unstable as hell and causes crashing. Like in the OP's case.

    And yes I believe I do know what I'm saying, since I'm 38yr old Engineer at Fujitsu, they don't pay me for nothing, but I do this in my own time.

    And also I've been a solid part of this great site since 2007...so please stop with the old timer crap, cuz I've never seen you before.

    Half the OP's problem would be cus of ur bs advice to use UOC.
     
    Last edited: Jul 27, 2014
  19. WittyScreenName

    WittyScreenName Banned

    Messages:
    42
    Likes Received:
    0
    GPU:
    Sapphire r7 260x 2gb
    OP had a problem with stuttering due to clock frequency changes and made a thread about it before i gave him advice,advice that did stop the clock fluctuations by the way. He did not make the thread because of my advice.

    I stopped using the LowBudgetGamer moniker in 2007 and ended up forgetting my password and the password to the email it's associated with.I did not make another account (this one) untill i figured out what was wrong with the 3D clock speeds in games,as you can see by my first post.

    I've been overclocking this way for months and i dont get screen flickering,black outs,bluescreens,restarts...nothing.

    Maybe that's just me?

    I would attribute OPs recent crashing issue(i read the thread) with FNV and AB to mods,personally.

    Im the only person who's been able to produce results,thank you.

     

Share This Page