GetDeviceRemovedReason when playing Battlefield 3

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by mp_3, Mar 11, 2013.

  1. mp_3

    mp_3 Active Member

    Messages:
    60
    Likes Received:
    0
    GPU:
    MSI N580GTX Twin Frozr II
    Hello,

    For the last week I have been receiving the following error only when playing Battlefield 3: http://d.pr/i/cdg8

    I have tried reinstalling Battlefield 3, reinstalling DirectX, downgrading to an earlier graphics driver and also reinstalling Windows 7. All without any luck.

    I have no idea how to solve this issue. Do you guys have any suggestions?

    Thank in advance.
     
  2. Pill Monster

    Pill Monster Banned

    Messages:
    25,214
    Likes Received:
    9
    GPU:
    7950 Vapor-X 1100/1500
    Anything overclocked?
     
  3. mp_3

    mp_3 Active Member

    Messages:
    60
    Likes Received:
    0
    GPU:
    MSI N580GTX Twin Frozr II
    No, nothing overclocked.
     
  4. Pill Monster

    Pill Monster Banned

    Messages:
    25,214
    Likes Received:
    9
    GPU:
    7950 Vapor-X 1100/1500
    Only time I've seen that error is when my GPU was overclocked too far.

    Try reducing clock speeds and see if that helps, if it does then you may want to RMA your card.
     

  5. dnottis

    dnottis Master Guru

    Messages:
    695
    Likes Received:
    0
    GPU:
    EVGA SSC 970 GTX 4GB
    there have been a few rare driver sets that this happened with too. try modded 314.09s.
     
  6. andressergio

    andressergio Master Guru

    Messages:
    895
    Likes Received:
    0
    GPU:
    GALAX GTX 1080Ti HOF SLI
    happens when CPU/GPU OCd but yes i admit that i was getting a lot of that on latest drivers now on 311.06 none
     
  7. bishi

    bishi Master Guru

    Messages:
    561
    Likes Received:
    11
    GPU:
    GTX 1080 SLI
    device removed.... maybe its loose? :D

    re-seat the card
     
  8. dsbig

    dsbig Ancient Guru

    Messages:
    4,055
    Likes Received:
    42
    GPU:
    EVGA RTX 2070
    do u have power managment set to performance or adaptive?

    I cant leave mine on adaptive because I get the same error in some games, that as soon as gpu usage dropped it was lowering the voltage and gpu speed while the game was going
     
  9. ZosmaV

    ZosmaV New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    POV GTX 660 2GB
    I get exactly the same error, only in bf3, i do have power managent as Performance, gtx 660 with or w/o oc, same problem, drivers 314.14.
     
  10. -Tj-

    -Tj- Ancient Guru

    Messages:
    17,230
    Likes Received:
    1,947
    GPU:
    Zotac GTX980Ti OC
    I had that 2-3 times with some newer driver (I think 310.xx) and only if I Oc'ed the gpu to far. Driver reinstall fixed it.


    Also while you're at it disable ingame Origin chat to see if it helps.
     

  11. BaDmOfO

    BaDmOfO Maha Guru

    Messages:
    1,401
    Likes Received:
    1
    GPU:
    2 x Evga sc GTX 780
    I receive the same error about once a gaming session. A clean driver install seems to fix it for a couple of days then it starts happening all over again. I'm glad to see it's not just me.
     
  12. mp_3

    mp_3 Active Member

    Messages:
    60
    Likes Received:
    0
    GPU:
    MSI N580GTX Twin Frozr II
    I have tried installing the 314.14 beta driver from nVidia and the first day it went well. Now I am getting the error again.

    I don't know what to do next.
     

Share This Page