GeForce Game Ready Driver 358.91 WHQL

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by maur0, Nov 9, 2015.

  1. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    16,037
    Likes Received:
    561
    GPU:
    EVGA GTX 1080 Ti SC2
    Just updated to Windows 10 Pro Build 10586 from Build 10240 and already I have seen THREE instances of the display driver crashing and recovering just while on the desktop, which is worrying. Granted, I was using the latest version of Chrome (64-bit) but it was never an issue on Build 10240 even when playing games. :3eyes:

    Windows 10 was already running the v358.91 WHQL drivers when I booted into it post-update but maybe I should do a clean reinstall of the driver just in case?
     
  2. OrdinaryOregano

    OrdinaryOregano Master Guru

    Messages:
    433
    Likes Received:
    5
    GPU:
    MSI 1080 Gaming X
    Well, the 'Update' is deployed more in the form of an Upgrade, you may have noticed during the installation that it has the whole screen like when you Upgrade from Win # to Win10. I'm going to treat it exactly like an Upgrade and reinstall all drivers I usually do because of that.
     
  3. Glottiz

    Glottiz Master Guru

    Messages:
    581
    Likes Received:
    184
    GPU:
    TUF 3080 OC
    most of the time "game ready" is just marketing buzzwords. i really wish someone did professional driver performance reviews where they tested every new WHQL (and maybe some beta) drivers and compared results with older drivers over the period of last year or two. it's a bit weird that no one does this properly since drivers are such a big part of overall performance you get from your hardware, we are always forced to believe that latest driver is the best driver, which is almost never the case.
     
  4. ipredator

    ipredator Master Guru

    Messages:
    542
    Likes Received:
    0
    GPU:
    Quadro K5000M
    Just as the other 35X.XX drivers this one causes my GPU to drop utilization (to 40-60%) as soon as the card hits 76°C. The FPS go down correspondingly, of course. No fun since the max fan starts kicking in at 78°C.

    Rolled back to 347.88, the last driver where my GPU stays at 99%.

    Is there any point in reporting this issue elsewhere?
     

  5. dreamlord

    dreamlord Member Guru

    Messages:
    134
    Likes Received:
    3
    GPU:
    GTX 650 1GB DDR5
    why to 347.88?

    why didn't you stay on 353.62?
     
  6. ipredator

    ipredator Master Guru

    Messages:
    542
    Likes Received:
    0
    GPU:
    Quadro K5000M
    I firstly rolled back from 358.91 to 353.62, and firstly thought it would fix it. But in my testing for 5 minutes my GPU didn't hit 76°C, so I didn't notice the utilization drop. When I tested for a longer period, I found out it is affected just the same... I even re-installed Windows 10 to confirm it is the driver's problem.
     
  7. dreamlord

    dreamlord Member Guru

    Messages:
    134
    Likes Received:
    3
    GPU:
    GTX 650 1GB DDR5
    but you said games worked fine on 353.62?

    i don't see reason for downgrading driver even further to win7/win8.1 one if games work ok.

    also, why 347.88, why not 347.25 or .52? :)
     
  8. ipredator

    ipredator Master Guru

    Messages:
    542
    Likes Received:
    0
    GPU:
    Quadro K5000M
    I said in the other thread, 353.62 works fine in terms of BC2. That is because newer drivers cause utilization issues in BC2 immediately when loading the map (many people suffer from it, check out the non-sticky thread below). That is the reason why I initially thought 353.62 fixes my utilization issue. It turned out that additionally to the general BC2 utilization issue I suffer from utilization drops as soon as my card hits 76°C in ANY game.

    Older drivers like 347.25 or .52 could also work, 347.88 is just the "most recent" driver (not that recent, being from March) that didn't cause my overall utilization issue.

    If you want to know, why I didn't notice it sooner... The sad answer is that I mainly played Dota 2 recently, which never causes my GPU to get that hot.

    *Edit: You said you don't see reason to downgrade the driver to a pre-Windows 10 one. Yeah, it is actually really sad I am forced to do that. I would never downgrade so far just for one game, but sadly the heat-caused utilization bug is present on all W10 drivers so far and affects EVERY game.

    Just to compare the driver behaviour:

    On 347.88 the heat goes up to 78°C, max fan kicks in, goes down to ~75°C and up again, utilization 99%.

    On 35X.XX the heat goes up to 76°C, utilization drops to 40-60%, FPS go down, heat goes down slightly, gameplay is ruined.

    I can provide MSI Afterburner logs, if necessary. Just tell me how to attach them.
     
    Last edited: Nov 13, 2015
  9. BNSoul

    BNSoul Active Member

    Messages:
    63
    Likes Received:
    0
    GPU:
    Gigabyte WF 660 Ti OC 3GB
    Last edited: Nov 13, 2015
  10. ipredator

    ipredator Master Guru

    Messages:
    542
    Likes Received:
    0
    GPU:
    Quadro K5000M
    Thanks, I'll give those dev drivers a shot.
     

  11. Makurth

    Makurth Member

    Messages:
    14
    Likes Received:
    0
    GPU:
    GALAX - GTX 970 EXOC
    Thanks a lot for sharing the information!!!!
     
  12. Anarion

    Anarion Ancient Guru

    Messages:
    13,604
    Likes Received:
    379
    GPU:
    GeForce RTX 3060 Ti
    Hmm... I'm getting some kind of TDR's in SWTOR with these but they do not show up in event log. When that happens GPU is stuck at ~540 MHz.

    Could be related to Windows 10 TH2 update too... NVIDIA has compatibility issues with TH2 update maybe?

    EDIT:
    Yeah... Something is not quite right. I'm going to try 358.87's to see if they don't cause TDRs in SWTOR.

    EDIT2:
    Hmmm.... It looks like Windows 10 TH2 is indeed the problem. :/
     
    Last edited: Nov 14, 2015
  13. Monchis

    Monchis Maha Guru

    Messages:
    1,303
    Likes Received:
    36
    GPU:
    GTX 950
    Nvidia control panel is acting wonky after setting custom resolutions on my secondary display. I can set a couple at first, at times they disappear, at times they don´t change the resolution, at times it refuses to swap displays, etc. This on windows 10, didn´t happen on win7.
     
  14. Cave Waverider

    Cave Waverider Maha Guru

    Messages:
    1,156
    Likes Received:
    148
    GPU:
    RTX 3090 ROG Strix
    I myself haven't experienced any TDRs with TOR on Windows 10 64 Bit Build 10586.3 so far (upgraded from 10240) with 358.91 WHQL drivers. Can you tell me when it happens most frequently in the game so I can try to reproduce it?
     
    Last edited: Nov 14, 2015
  15. Anarion

    Anarion Ancient Guru

    Messages:
    13,604
    Likes Received:
    379
    GPU:
    GeForce RTX 3060 Ti
    Seems to happen quite often on Dromund Kaas while in combat.

    EDIT:
    358.59 drivers seem to work just fine, no "TDR like crashes that do not appear in event logs" so far.
     
    Last edited: Nov 14, 2015

  16. Scerate

    Scerate Maha Guru

    Messages:
    1,042
    Likes Received:
    0
    GPU:
    2080@2.1/1070N@2.0
    yep got TDRs too with my card even at stock, just playing Blade and Soul CB and i can play sometimes 10 mins and then get 4-5 crashes in a row or i can play 2h and then get the crashcleave. Using W10 TH2 too btw. Will roll back to 358.59 too
     
  17. CrazyGenio

    CrazyGenio Master Guru

    Messages:
    447
    Likes Received:
    32
    GPU:
    Msi rtx 2080ti trio
    i don't have any TDr in W10 TH2, but i found performance loss in old games, i played TW2 and i found some huge (very huge) framedrops especially in crowded scenes , (that din't happened before), same in Team Fortress 2 in 16vs16 full maps, i've found drops even to less than 30 fps.

    I did a clean install using this iso https://www.microsoft.com/en-us/software-download/techbench , i still have poor perfomance in DX9 games.

    Dx11 games are fine. i even scored a little better in the benchs but no for much so i think that's not important.
     
  18. ipredator

    ipredator Master Guru

    Messages:
    542
    Likes Received:
    0
    GPU:
    Quadro K5000M
    Thanks for the suggestion! I tried it and unfortunately it is also affected by this utilization problem.

    BTW, I tried working around it, setting my fan to run at 100% when 74°C are reached (now, at auto it starts 100% at 77°C...). Unfortunately, I was unable to do so with any software I tried (HWinfo64, Nvidia Inspector, MSI Afterburner, SpeedControl) because my fans seem to be locked.

    My only option now is to keep using 347.88, pray that a future driver won't be affected by this utilization bug or somehow force my GPU to stay below 76°C...
     
  19. BNSoul

    BNSoul Active Member

    Messages:
    63
    Likes Received:
    0
    GPU:
    Gigabyte WF 660 Ti OC 3GB
    I had that bug on my 660 Ti 3 GB with pretty much all newer drivers except 356.04, I'm sorry it didn't work out for you, also sorry for the time / troubles.
     
  20. ipredator

    ipredator Master Guru

    Messages:
    542
    Likes Received:
    0
    GPU:
    Quadro K5000M
    Don't be sorry, I'm happy to try anything to get this fixed :)
     

Share This Page