GeForce 442.59 Game Ready Driver Download & Discussion

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by Alberto, Mar 10, 2020.

  1. Mufflore

    Mufflore Ancient Guru

    Messages:
    11,645
    Likes Received:
    740
    GPU:
    1080Ti + Xtreme III
    Thats the Vidco19 bug.
     
    -Tj- and JonasBeckman like this.
  2. tsunami231

    tsunami231 Ancient Guru

    Messages:
    10,073
    Likes Received:
    464
    GPU:
    EVGA 1070Ti Black
    is that what the problem is on the youtube. my dad keep complain to me about when he on is iPad that it not loading tell me interent is not, and I keep telling him it not the interent it youtube
     
  3. Mufflore

    Mufflore Ancient Guru

    Messages:
    11,645
    Likes Received:
    740
    GPU:
    1080Ti + Xtreme III
    Yep, Covid-19 mutated unfortunately.
     
  4. tsunami231

    tsunami231 Ancient Guru

    Messages:
    10,073
    Likes Received:
    464
    GPU:
    EVGA 1070Ti Black
    Nice it biologic and digital virus! Progress. Joking aside
     

  5. -Tj-

    -Tj- Ancient Guru

    Messages:
    16,660
    Likes Received:
    1,629
    GPU:
    Zotac GTX980Ti OC
    lol :p


    I see, well firefox youtube is ok. Just links in steam chat windows. Started just around the time I updated to this driver.. that's why i suspect it.


    EDIT:
    when I tried it now, some small 20sec video, it played ok, but when I tried the link I posted with video specific time it fails.
     
  6. -Tj-

    -Tj- Ancient Guru

    Messages:
    16,660
    Likes Received:
    1,629
    GPU:
    Zotac GTX980Ti OC
    Ok so Installed new 442.74 driver and it played fine - the video with custom time location, but I also restarted PC in that time. Google said pc restart can fit it.. so not sure, will see later.


    eDIT: Now its happening @ steam ingame overlay and build-in browser, even with new 442.74.. meh.
     
    Last edited: Mar 19, 2020
  7. Astyanax

    Astyanax Ancient Guru

    Messages:
    5,278
    Likes Received:
    1,573
    GPU:
    GTX 1080ti

    Youtube is suffering from service congestion due to all the stuff going on.
     
    Last edited: Mar 21, 2020
  8. Shayne

    Shayne Master Guru

    Messages:
    350
    Likes Received:
    4
    GPU:
    MSI RTX 2070 Armor
    Makes no sense to who you? When the internet came on line in 95 download.com was one of the first site to be dedicated to download appz. Think it still exists? All that build and run their own box do not need appz anymore. Foobar, MPC, Photoshop, Autocad and such have been chosen and a windows appz store is useless to some. I am vpn'd and firewalled up and don't do facebook you make a presumption that makes no sense.
     
  9. Smough

    Smough Master Guru

    Messages:
    374
    Likes Received:
    54
    GPU:
    GTX 1060 3GB
    I think I agree with you, I installed 442.19 drivers and I was having odd lag issues at some games (mind you this was a clean install with DDU) and I couldn't find any issues on my computer, then I downgraded to 441.87 drivers and the games are as they used to be, The Division 2 is super smooth as it should be, with the 442 driver it would lag a lot and that game barely has fps drops for me, I know it, I have played it for too long.
     
    loracle likes this.
  10. Astyanax

    Astyanax Ancient Guru

    Messages:
    5,278
    Likes Received:
    1,573
    GPU:
    GTX 1080ti
    Ioracles 3dmark issues don't translate into actual game performance or lag issues Smough.

    He also hasn't properly reported them, since ManuelG seemed unaware of any reports.
     

  11. -Tj-

    -Tj- Ancient Guru

    Messages:
    16,660
    Likes Received:
    1,629
    GPU:
    Zotac GTX980Ti OC
    Yeah it was steam vidco19 infection, they made a cure now and also updated chromium to the latest.

     
    Mufflore likes this.
  12. superleeds27

    superleeds27 Member

    Messages:
    32
    Likes Received:
    3
    GPU:
    Inno3D GTX560 TI
    Hmm. I've had a few issues lately with the Division 2. Almost feels like huge frame drops, so much that the game comes to a halt/lag for like 1-4 seconds, before kicking back in. It almost feels like it's going to crash to desktop!

    Not sure if it's driver related or just Division 2 patch related
     

Share This Page