GeForce 388.31 WHQL Game ready Download & Discussion

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by zandathrax, Nov 15, 2017.

  1. Dagda

    Dagda Master Guru

    Messages:
    271
    Likes Received:
    48
    GPU:
    RTX 2080 super
    yeah do not use dx12, i have stable 144fps on BF2 on a single 1080ti meanwhile on dx12 i lose 20 fps and yes is a sttuterfest ar least for a period of time then it becames stable, anyway regarding of the theme at hand maybe people pick it because is new tech, people always choose the new stuff because usually people thinks that new=better and that wont apply in most cases in hardware probably that statement is true but in software it depends on many factors.
     
  2. khanmein

    khanmein Ancient Guru

    Messages:
    1,647
    Likes Received:
    72
    GPU:
    EVGA GTX 1070 SC
    Build 17046
    • We fixed a community reported issue where display colors became distorted after upgrading on some TV’s and monitors that incorrectly advertised support for 10/12 bit wire formats.
    • We fixed an issue from the previous flight that could cause heavily-threaded DirectX 12 apps to crash on launch after the first launch.
     
  3. GhostXL

    GhostXL Ancient Guru

    Messages:
    6,084
    Likes Received:
    54
    GPU:
    Merc 319 6800 XT
    I had Green screens claiming I had memory stability issues in the last build 17040. Never had them before, and I don't have them in this build either. I wonder if it was just me or they fixed that and didn't put it in the notes. Everything is rock solid, so I know I don't actually have hardware issues.
     
  4. khanmein

    khanmein Ancient Guru

    Messages:
    1,647
    Likes Received:
    72
    GPU:
    EVGA GTX 1070 SC
    I didn't install any preview before, so I'm not sure, but I'd like to ask your ASRock Z97 Extreme 6 really have 3 x PCIe 3.0 lanes?
     

  5. Xtreme512

    Xtreme512 Master Guru

    Messages:
    702
    Likes Received:
    20
    GPU:
    GTX1060 6GB
    the last method I wrote didnt work. now, from gpedit windows update section just set enable automatic updates to local admin choose and disable device driver installation. its 100% working.
     
  6. CrazyT666

    CrazyT666 Member

    Messages:
    42
    Likes Received:
    2
    GPU:
    GTX 1080 TI
    I have a little trouble on my setup since this driver!

    My main monitor resets after every restart/cold boot from windows back to 60hz
     
  7. SSJBillClinton

    SSJBillClinton Master Guru

    Messages:
    745
    Likes Received:
    119
    GPU:
    RTX3090 EVGA FTW
    Works for me (1080ti) and my girlfriend (980ti). However, as I mentioned earlier in this thread I have been having issues with shadowplay and various games when installing a new driver over a previous one since these 388.xx drivers, and have been having to completely wipe with DDU prior to installing any new drivers. Give it a shot!
     
  8. Keesberenburg

    Keesberenburg Master Guru

    Messages:
    852
    Likes Received:
    24
    GPU:
    EVGA GTX 980 TI sc
    I hope it is also for HDR colors
     
  9. GhostXL

    GhostXL Ancient Guru

    Messages:
    6,084
    Likes Received:
    54
    GPU:
    Merc 319 6800 XT
    Running PCIeX16 3.0 @ x8 as we speak. GPUZ and in BIOS shows it. Runs x8 for SLI.

    SLI working like a charm here. Never had SLI issues since the GTX 780's.

    x16 single or x8 x8 SLI.


    I'd still be on my ASUS Maximus Hero VII, but something blew it out. Not sure why, but the north end of the board failed on it.

    Irritating, but this ASRock is a solid repalcement. I was not going to pay over 400USD for a used Hero VII. Got the ASRock TPM Module for it and running Bitlocker. No slowdowns at all. Boots as fast as ever. So why not.
     
    Last edited: Nov 24, 2017
  10. khanmein

    khanmein Ancient Guru

    Messages:
    1,647
    Likes Received:
    72
    GPU:
    EVGA GTX 1070 SC
    I thought your motherboard can run x16 for SLI.

    ASRock guy mentioned ASRock Z97 Extreme 6 had 4 @ PCIe 3.0 lanes. (Weird, what I know is 2 only)

     

  11. elite69

    elite69 Master Guru

    Messages:
    559
    Likes Received:
    25
    GPU:
    EVGA GTX 1060 6GB
    mgs 5 runs like crap with this ones frame drops its a mess.
     
  12. the_mts

    the_mts New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    1080 Ti
    Okay, I will try this. It seems that it isn't just Destiny 2. Shadowplay will just stop working all of a sudden no matter which game I play.
     
  13. hyperboarean

    hyperboarean New Member

    Messages:
    8
    Likes Received:
    3
    GPU:
    GTX 770M 3GB
    I can't overclock my GPU (GTX 770M) anymore with 388.31?
     
  14. vf

    vf Ancient Guru

    Messages:
    1,821
    Likes Received:
    93
    GPU:
    AMD Radeon™
    While unrelated, geez! That FOV is awful. Everyone loves the fisheye?
     
  15. Chastity

    Chastity Ancient Guru

    Messages:
    2,726
    Likes Received:
    915
    GPU:
    Nitro 5700 XT
    If you are using a custom resolution with higher refresh rate, try adding the new setting with CRU to the EDID. I had to do this with the new laptop to get it to boot to 100Hz. It otherwise defaulted to 75Hz.
     

  16. Retow

    Retow Active Member

    Messages:
    77
    Likes Received:
    1
    GPU:
    GTX780 ti
    Just a a heads up regarding Windows Pro Insider Preview and this driver:

    I have missed a few pages in this thread so if it has been mentioned forgive me.

    I noticed release 17040 and 17046 would boot normally on initial boot and then to a blank screen with a cursor post "user config"

    I tracked this down to my habit of manually setting MSI mode on the Nvidia driver and Nvidia HD Audio each time I updated and this proved to be the cause of the failure to display the log in screen.

    Perpetual "Getting devices ready..." or blank screen with mouse cursor.

    I noticed some other sources on the web suggested PhysX was the culprit but that wasn't the cause or solution in my case.

    I would recommend that on initial boot configuring the legacy F8 boot menu in windows 10 so you can easily boot to safe mode uninstall the NVIDIA driver and continue without restoring windows to a previous flight.

    bcdedit /set {current} bootmenupolicy Legacy
    bcdedit /set {bootmgr} displaybootmenu yes


    Which was taken from https://www.tenforums.com/tutorials/22455-enable-disable-f8-advanced-boot-options-windows-10-a.html just in case you have multiple OSs/boot loaders installed.

    Saved me a fair few hours.

    The last version without this issue for me was 17035.
     
  17. X7007

    X7007 Ancient Guru

    Messages:
    1,582
    Likes Received:
    29
    GPU:
    Sapphire 6900XT
    When they released new drivers to fix 3D in powerdvd that not working at all??

    ALSO , Don't enable MSI for NVidia cards ........ Only NVidia Mobility, Quadro , AMD Desktop and Mobility are MSI compatibility
     
  18. Memorian

    Memorian Ancient Guru

    Messages:
    3,104
    Likes Received:
    255
    GPU:
    RTX 3080
    MSI mode works fine with NVIDIA GeForce cards.
     
  19. blackdragonbird

    blackdragonbird Member Guru

    Messages:
    102
    Likes Received:
    15
    GPU:
    GTX 1070 G1 Gaming
    I use MSI mode for my 2 cards without issue there. I use the MSI_UTIL executable that I fount in the therad about MSI mode in Guru3D.
     
  20. tsunami231

    tsunami231 Ancient Guru

    Messages:
    11,703
    Likes Received:
    838
    GPU:
    EVGA 1070Ti Black
    Nvidia dont enable it by defualt on desktop cards for some reason

    MSI works for some not so much for other as pointed out above, I use to force set the gpu to msi just so it didnt share irq but i never saw any difference with using "irq" or "msi" Never really thought about setting nvidia HD audio to msi either cause almost never used the hdmi out on it, but now i do, but the thing about that is I dont know which HD audio is realteks and which is Nvidia cause only device manager "devices by type" show then as realtek hd audio and nvidia hd audio every other view show it as HD audio and HD audio even MSI_uti found here show them listed as HD audio last i checked, so i dont wont to play with msi on audio
     

Share This Page