1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

GeForce 295.51 Driver released

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by Hu1kamania, Jan 31, 2012.

  1. kroks

    kroks Active Member

    Messages:
    66
    Likes Received:
    10
    GPU:
    GTX 980 Ti
    me too
    you need to disable sli for this game
    it's like this since 295.51 and same problem with 295.73 "whql" :(
     
  2. Datacide

    Datacide New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    GeForce GTX 590 3GB
    Yeah, that doesn't do it for me. I left the control panel to "application controlled" for AA and turned it right off in Civ V and it still is a super-seizure scramble-fest. I didn't try the other suggestion of turning off SLI...but you might as well ask me to chop off a hand. :)

    Guess I'll be reverting back as well...I play Civ V via email and I can't look at that mess on a daily basis.

    Poor job nVidia, poor job.
     
  3. Datacide

    Datacide New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    GeForce GTX 590 3GB
    Actually, this was posted on the nVidia forums...hopefully they'll roll out new drivers quickly this time to address the issue. So the suggestion to disable SLI above seems like the "fix" for now...pain in the ass is what it really is.

    "R295.73 WHQL End user Bugs Submitted - QA Repro Pending Fix/Fixed in future driver release
    -Civilization 5 has tiled flickering corruption with SLI enabled. FIXED
    -SLI settings not available/driver issues when SLI enabled following installation and then system is reboot, disabling ethernet controller/using PS/2 keyboard workaround FIXED
    -Low performance in certain Source games with VSYNC disabled Repro"
     

Share This Page