Geforce 290.53 Driver released.

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by HeavyHemi, Dec 21, 2011.

  1. kiju

    kiju New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    EVGA 570GTX
    Anyone have their clocked switching constantly i mean with the old 285.62 i was watching flash videos with the 451 mhz and 51 Mhz when browsing, now they are jumping from 51 to 451 to full 3D when i just browsing.
     
  2. mystiky

    mystiky Active Member

    Messages:
    64
    Likes Received:
    0
    Here is a question then:

    I installed Intel Chipset Device Software 9.1.2.1008, when I did my system ONE year ago from scratch. I am using ASUS P6X58D Premium motherboard, which is a an X58 type system.

    Should I look for a newer version of this or just leave it as is.

    What is the latest version if so.
     
  3. cricket bones

    cricket bones Master Guru

    Messages:
    737
    Likes Received:
    126
    GPU:
    EVGA 980 TI FTW
    Hand cranking an internet download is awful. Christ, man...is a few minutes too much so your amazing computer machine does stuff....then does it wrong so you can run to an internet forum and whine about it?

    So much whining.
     
  4. A7MaD512

    A7MaD512 New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    gtx 560ti
    i tried the new driver and the performance is same in bf3 but i got frame drop cuz of gpu usage drop and in cod black ops online same drop happen . i have this problem since i bought the gtx 560ti don't know wht is the problem but the previous beta was more stable
     

  5. Burnt_Ram

    Burnt_Ram Ancient Guru

    Messages:
    5,926
    Likes Received:
    0
    GPU:
    Zotac GTX 1050 Ti
    one thing i noticed with these is that when my cards hit 98-99% usage in BF3 they dont stutter like they did with last beta. keepers for now.
     
  6. Soundcreepy

    Soundcreepy Member Guru

    Messages:
    195
    Likes Received:
    0
    GPU:
    PNY 780 Enthusiast 3gb
    Ok, for the uninstall/upgrade method, which is best? Should you still use Driver Cleaner in safemode before installing the new drivers? Or is Nvidia Clean install enough?
     
  7. Uncle Dude

    Uncle Dude Ancient Guru

    Messages:
    2,312
    Likes Received:
    5
    GPU:
    GTX 1080 Ti
    My desktop appeared a little blurry after installing these. Digging around the control panel, I discovered my refresh rate was set to 24Hz. All is good after switching back to 60Hz. Might be worth a look for some of you having issues...

    Cheers. :)
     
  8. CrazyT666

    CrazyT666 Member

    Messages:
    43
    Likes Received:
    3
    GPU:
    GTX 1080 TI
    modified bin or standard bin?

    I mean Win + sp1 and security updates in your custom bin?
     
  9. Anarion

    Anarion Ancient Guru

    Messages:
    13,605
    Likes Received:
    380
    GPU:
    GeForce RTX 3060 Ti
    Mass Effect antialiasing bug is still there and so is 2D clock bug if you use higher refresh rate than 60Hz.
     
  10. Arctucas

    Arctucas Ancient Guru

    Messages:
    2,134
    Likes Received:
    44
    GPU:
    eVGA RTX2080 FTW3
    Fair enough...

    Here is what I did this afternoon:

    Broke my RAID0 array into four individual disks,

    Ran secure erase to zero each drive,

    Rebuilt the array; RAID0 with 128K stripe size.

    Reinstalled Windows (7 Ultimate x64),

    Installed the 9.3.0.1019 immediately after Windows install completed, before anything else,

    Rebooted,

    Installed 290.53 Forceware,

    Rebooted and it appeared the drivers took, however,

    Installed 10.8.0.1003 RST,

    Rebooted,

    No nVIDIA drivers found.

    Installed 285.86 Developer drivers,

    Rebooted and the nVIDIA drivers are installed.

    After installing Service Pack 1 and all Windows updates, and all the other application I use, the 285.86 drivers remain installed.

    Any other ideas?
     

  11. splinter6

    splinter6 Member

    Messages:
    10
    Likes Received:
    0
    GPU:
    Gigabyte 980ti G1
    I use a Samsung s23a750d 120Hz monitor and after installing this driver, my graphics card stops outputting the signal over displayport and I have to plug in my hdmi cord... Does anyone else have trouble with using displayport with this driver? Or know anything I can tweak to get it working again? thanks
     
  12. braudrist

    braudrist Active Member

    Messages:
    54
    Likes Received:
    0
    GPU:
    RTX 2080 Ti
    Sorry for off-topic but really, a prestigious company like Intel should really make an effort to update their website with the latest Intel Chipset drivers. When you Google 9.3.0.1019, Intel's website isn't even listed.
     
  13. Saifz

    Saifz Master Guru

    Messages:
    490
    Likes Received:
    0
    GPU:
    460 Zotac 1gb 800/2000
    ^ i had trouble finding chipset drivers from amd too
     
  14. TheDeeGee

    TheDeeGee Ancient Guru

    Messages:
    7,354
    Likes Received:
    1,528
    GPU:
    NVIDIA GTX 1070 8GB
    Why arn't they on the Intel Site? Are these Fan Based Drivers or something?
     
  15. Rusty_

    Rusty_ Member

    Messages:
    30
    Likes Received:
    0
    GPU:
    GTX 560 TI
    so are these worth installing?
     

  16. Wolfseven

    Wolfseven Member Guru

    Messages:
    169
    Likes Received:
    0
    GPU:
    MSI NGTX580 1.2gb
    yes and yes
     
  17. BaneComes

    BaneComes Banned

    Messages:
    461
    Likes Received:
    0
    GPU:
    580GTX Twin Frozr II/OC
    honestly not really
     
  18. TheDeeGee

    TheDeeGee Ancient Guru

    Messages:
    7,354
    Likes Received:
    1,528
    GPU:
    NVIDIA GTX 1070 8GB
    How can you say that? Not a single PC configuration handles a Driver the same as it did for you.

    @Rusty_

    They work perfectly fine for me, but as i wrote above it might not be the same for you.

    All you can do is give them a try, if they work...they work if not go back to the ones you had :)
     
  19. Jagman

    Jagman Ancient Guru

    Messages:
    2,258
    Likes Received:
    321
    GPU:
    MSI 16GB RX6800
    Very true about drivers, everyone seems to have different experiences. Fingers crossed I haven't had any major issues other than the annoying "driver stopped responding" bug. BTW has anyone had this in 290.53?
     
  20. TheDeeGee

    TheDeeGee Ancient Guru

    Messages:
    7,354
    Likes Received:
    1,528
    GPU:
    NVIDIA GTX 1070 8GB
    That used to be famous for me with the 285.XX, but i havn't had any with the 290's.

    Seems these work better for the 500 series.
     

Share This Page