Games with the Unity engine stutter

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by PapaJohn, Dec 10, 2020.

  1. Guzz

    Guzz Member Guru

    Messages:
    154
    Likes Received:
    32
    GPU:
    GTX 970
    Have you checked what the driver's overlay shows?
    [​IMG]

    You must see "FULLSCREEN YES", otherwise the option "-window-mode exclusive" does not work for this game.

    [​IMG]
     
    PapaJohn likes this.
  2. MrBonk

    MrBonk Ancient Guru

    Messages:
    3,188
    Likes Received:
    168
    GPU:
    MSI RTX 2080
    I haven't played as many UE4 games, but many that I have don't that much. (Those aren't open world games, like Iron Rain, Fighting Ex Layer recently. What little I played of Dragon Quest XI S on PC so far has had zero stutter for example.). But UE3 definitely yes. Played Shadow Complex again recently and there's nothing you can do that can get it NOT to stutter. I spent hours tweaking all kinds of stuff trying to get it to improve. It always stutters in the same locations as it chokes on loading data.

    RE3 was completely stutter free for the most part in my experience. RE2 and REVII both had a lot of stuttering in the same repeatable areas as the engine chokes on loading data. I had to spend a lot of time trying to find the right settings that would minimize it as much as possible for the latter 2.
    I've not found many games where it this actually works. I probably just have the wrong unity games. But i've yet to find one that I own where it actually works.
     
  3. painter

    painter Maha Guru

    Messages:
    1,068
    Likes Received:
    5
    GPU:
    GTX 1060 6GB
    Thanks.... But, that line is not there for me. Maybe I need to update nV Inspector or something? I'm on 2.3.0.2.

    Edit: Just updated to 2.3.0.12 and that line is still missing.
     
  4. Memorian

    Memorian Ancient Guru

    Messages:
    3,087
    Likes Received:
    243
    GPU:
    RTX 3080
    Try Forza Horizon 4, it's silky smooth even if you reach 400+ km/h. I'm playing AC: Valhalla now and i'm getting occasional micro-stuttering when i'm reaching buildings. Game installed in NVMe. I think it's the API, because Origins/Odyssey were smooth as butter.
     
    BlindBison likes this.

  5. Astyanax

    Astyanax Ancient Guru

    Messages:
    9,472
    Likes Received:
    3,307
    GPU:
    GTX 1080ti
    These kinds of stutters should clear up with ReBar, because they are more the transfer into graphics memory than anything.

    the big stutters in Unity not so much, you're waiting on the cpu to finish unpacking and streaming the data in that case.
     
  6. Guzz

    Guzz Member Guru

    Messages:
    154
    Likes Received:
    32
    GPU:
    GTX 970
    Select "Show unknown settings from NVIDIA predifined profiles" and this line will appear.
    [​IMG]
     
    PapaJohn likes this.
  7. Ohmer

    Ohmer Member

    Messages:
    25
    Likes Received:
    20
    GPU:
    MSI 1080Ti DUKE OC
    @PapaJohn

    The only game I have from your list is Pillars of Eternity, and though it DID give me some problems with occasional stuttering, it was Pathfinder Kingmaker that really had me pulling out the last of what little hair I had left. Tried all the usual tweaks/fixes and nothing worked, until the following.

    I'll just copy/paste 2 posts I made in another forum from July 2019, as they're pretty self explanatory.
    Confirmed that it still works exactly as it did then, (for Pillars also) and is the ONLY thing that works 100% for me. Hope it helps.

    _______________________________________________________________________________________________
    • Just wanted to add some extra findings after playing some more with the performance fix provided earlier in the thread.
    Seems that wasn't the end of the story. Even though game performance went up considerably, and the stutter/hitching went way down, it still wasn't perfect. After bashing my head against the wall some more looking for that "buttery smooth at all times" experience, I remembered back to release of Ryzen 1 and how a limited number of games were performing better with multi-threading (SMT) turned off.

    Since my last post, I've tried a few other Core Affinity combinations, even locking the game to 8 discrete threads on unique cores, but no luck, none as good as 4C/8T. Couldn't see how the game would perform better with even fewer threads, since the output.log file TELLS you that the game is creating 8 worker threads... Well, blindsided by that one!

    So, set the game to just use the first 4 cores with a single thread each, and frack me, the performance has jumped up even further again, and the hitching has completely gone!!

    On a side note VRR only works for my setup (2700X/1080Ti) in Full Screen Exclusive mode, but now at least it's finally working properly, so very happy camper.

    Not sure if all this is a peculiarity of the Unity Engine, the way Owlcat coded the game, my setup, or a combination. Would be interesting to see what others make of it.
    _______________________________________________________________________________________________
    • I've been reading a ton of stuff about Unity and other games using the engine, and nothing really conclusive. Command line switches and other stuff, but there's only so much the end user can do of course. The solution above works for me (and others, but not all, depending on which board you're on) and I can enjoy playing the game fully now, so that's the main thing. =)
    Just for the hell of it I ran some numbers - Fresh saved character standing in the Banquet Hall, VSYNC off, VRR off, no frame limiter etc. Graphics settings on HIGH, FS Exclusive.
    Interesting just how much the FPS changes doing nothing but changing the Core affinity, and tabbing back into the game:
    8 core / 16 thread = 142 FPS
    4 core / 8 thread = 163 FPS
    4 core / 4 thread = 179 FPS
    Truly an Upside-Down Bizarro World game this one. upload_2021-1-15_23-40-53.gif
    _______________________________________________________________________________________________
     
    PapaJohn likes this.
  8. kman

    kman Member Guru

    Messages:
    102
    Likes Received:
    8
    GPU:
    1080ti Strix
    Is this similar to what you get ?

    I play in fullscreen exclusive always when available and also later on I tried using "-window-mode exclusive" and while it did increase my fps alot and made camera movement much more smooth it still didn't remove the random/not so random stutter.
    This is on my current rig 3080(had a 1080ti when I made this vid) with a 9900k,16gb ddr4,970 evo SSD

    I said it before but when I had my 4790k I didn't get not 1 stutter and I didn't need to limit my fps or do anything else on any unity game.
     
    Last edited: Jan 16, 2021
    PapaJohn likes this.
  9. WhiteLightning

    WhiteLightning Don Illuminati Staff Member

    Messages:
    28,801
    Likes Received:
    1,651
    GPU:
    GTX1070 iChillx4
    Have you tried setting process priority to 'below normal' ?
     
    PapaJohn likes this.
  10. BlindBison

    BlindBison Master Guru

    Messages:
    491
    Likes Received:
    78
    GPU:
    RTX 2080 Super
    Strangely, and this might just have to do with the patch version I played it on or perhaps a Ryzen issue of some sort, but when I played Assassin's Creed Odyssey, it was smooth mostly of the time but would have these weird hard hitches seemingly at random every so often -- I spent forever trying to find a work around/capping fps externally and internally/paying with various graphics settings and couldn't solve it. Even if I just panned the camera in a circle it would be smooth then hitch, smooth then hitch. This was on G-Sync too -- never figured out why, but that was quite sometime ago.
     

  11. Astyanax

    Astyanax Ancient Guru

    Messages:
    9,472
    Likes Received:
    3,307
    GPU:
    GTX 1080ti
    That is caused by VMProtect.
     
    BlindBison likes this.
  12. Ohmer

    Ohmer Member

    Messages:
    25
    Likes Received:
    20
    GPU:
    MSI 1080Ti DUKE OC
    Pillars 1 was never close to being that bad for me, though the spikes did look kind of similar. Much smaller, much shorter duration, and much less frequent if I recall. I just loaded it up again, and now it seems to run almost perfectly even without any core/affinity changes (so kudos Obsidian I guess).

    As I said though, my issue is with Kingmaker. The frame times would jump all over the place, sometimes the frame rate would just plummet, and it was basically unplayable for me. I was seeing stutter much like in your video, every few seconds, just running up and down the same corridor.

    All I can suggest is give it a try. 4 cores only, single thread each. I thought to myself "why should I have to cripple my CPU to get this garbage game engine to run properly?". LOL soon forgot about that when it solved the problem completely =)
     
  13. Memorian

    Memorian Ancient Guru

    Messages:
    3,087
    Likes Received:
    243
    GPU:
    RTX 3080
    I didn't have stutter issues in Odyssey/Origins, despite both of them using VMProtect. I was using ISLC back then because of the standby memory bug.
     
  14. painter

    painter Maha Guru

    Messages:
    1,068
    Likes Received:
    5
    GPU:
    GTX 1060 6GB
    LMAO... all these years using this and I had no idea you could reveal all this :rolleyes: Is there anything else useful among all these parameters?
    Anyway, thanks for pointing this out... Will just have to put up with some stuttering it seems.
     
  15. CrunchyBiscuit

    CrunchyBiscuit Master Guru

    Messages:
    284
    Likes Received:
    63
    GPU:
    AMD Radeon HD6950 2GB
    Ahhhh stuttering, hitching and frame skipping, lovely, isn't it?

    The main reason I refund so many games (like, 9 out of 10).

    Unity uses pretty bad defaults, but in the hands of competent developers, Unity can work wonders. Same goes for UE, by the way.
     

  16. kman

    kman Member Guru

    Messages:
    102
    Likes Received:
    8
    GPU:
    1080ti Strix
    Yea you should try POE2.It's usually big cities that give that frequent hitching.When im out on the map (or somewhere not a city) its much more toned down but still kinda happens.
     
  17. BlindBison

    BlindBison Master Guru

    Messages:
    491
    Likes Received:
    78
    GPU:
    RTX 2080 Super
    Well, that sucks -- kinda ruins the experience tbh
     

Share This Page