Games with the Unity engine stutter

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by PapaJohn, Dec 10, 2020.

  1. PapaJohn

    PapaJohn Master Guru

    Messages:
    213
    Likes Received:
    15
    GPU:
    Aorus Xtreme 1080Ti
    Hi guys, I'll make this brief -

    All games work fine on my 3600/1080ti combo. It's literally only some Unity engine created games that cause me issues. GPU usage is never an issue, it's basically like bad frame pacing, hitches and generally like it's out of sync. Judder and jitter.

    On my setup -

    Unity engine games with issues -

    Cloudpunk
    Dear Esther Landmark Edition
    Return Of The Obra Dinn
    PGA Golf 2K21
    Those Who Remain
    The Light Remake
    Gone Home
    Event 0
    Pillars Of Eternity
    Kona

    Unity engine games, no issues -

    Ori And The Blind Forest
    Race The Sun
    The Novelist
    Lumo
    The Fall Part 1 & 2



    Things I've tried to rectify the issues include -

    -window-mode exclusive
    Frame cap in RTSS of 60
    Maximum performance power setting in Nvidia CP
    Windows game mode on and off
    Vsync on and off

    Any other people have issues with these games previously and rectified them? Or, any other suggestions would be greatly appreciated, thanks.
     
  2. artina90

    artina90 Member Guru

    Messages:
    117
    Likes Received:
    38
    GPU:
    RTX 2080Ti
    There is nothing you can do, it's up to the developers.
     
    BlindBison and PapaJohn like this.
  3. emperorsfist

    emperorsfist Maha Guru

    Messages:
    1,405
    Likes Received:
    771
    GPU:
    NVIDIA GTX 1080 8Gb
    Unity games have this problem often, a lot of times it's not really "your" issue, but a problem with the engine. You mentioned Kona - have you tried using Ssync via RTSS? Also, I've noticed that some Unity games "need" Vsync ON (in engine, not through drivers) to be smooth.
     
    PapaJohn likes this.
  4. PapaJohn

    PapaJohn Master Guru

    Messages:
    213
    Likes Received:
    15
    GPU:
    Aorus Xtreme 1080Ti
    OK I'll try a few of them with their native vsync options and report back, thanks. What's Ssync on RTSS? Or is that a typo? I have tried using the framecap feature in both RTSS at 60 or via Nvidia Inspector with Frame Limiter V3@60fps.
     

  5. emperorsfist

    emperorsfist Maha Guru

    Messages:
    1,405
    Likes Received:
    771
    GPU:
    NVIDIA GTX 1080 8Gb
    Under frame limit in RTSS, you'll find a "scanline sync" option. Turn it to any number besides 0 to find activate it. If you want to know more about the feature, you can read up on it on this site, or just google it - try to find the article from Blur Busters.
     
    PapaJohn likes this.
  6. Astyanax

    Astyanax Ancient Guru

    Messages:
    9,531
    Likes Received:
    3,330
    GPU:
    GTX 1080ti
    Unity engine has a by default synchronous (locked IO) resource streaming implementation that causes the gam to hitch and stutter any time a new resource is loading as you traverse the world.

    This makes the default unity implementation terrible for open world games.
     
    PapaJohn likes this.
  7. PapaJohn

    PapaJohn Master Guru

    Messages:
    213
    Likes Received:
    15
    GPU:
    Aorus Xtreme 1080Ti
    Never noticed that before, thanks again, I'll be sure to read up on it. Always nice to have multiple options when trying to fix issues.

    Also good to know, thanks. I honestly believe some developers work wonders with the engine but some games are crying out for those finishing touches that provide a polished experience for the end user.
     
  8. Martigen

    Martigen Master Guru

    Messages:
    456
    Likes Received:
    209
    GPU:
    GTX 1080Ti SLI
  9. kman

    kman Member Guru

    Messages:
    106
    Likes Received:
    9
    GPU:
    1080ti Strix
    I never had issues with unity games until I upgraded my cpu from 4790k>9900k.Now pretty much every unity game has some form of stutter.
     
    PapaJohn likes this.
  10. Astyanax

    Astyanax Ancient Guru

    Messages:
    9,531
    Likes Received:
    3,330
    GPU:
    GTX 1080ti
    reduce the framerate.
     

  11. nanogenesis

    nanogenesis Maha Guru

    Messages:
    1,301
    Likes Received:
    6
    GPU:
    MSI R9 390X 1178|6350
    Okay now this makes sense why genshin impact stutters so much. It drove me crazy thinking perhaps its due to a bad ram overclock, or some other issue I cba to troubleshoot.
     
  12. MrBonk

    MrBonk Ancient Guru

    Messages:
    3,191
    Likes Received:
    169
    GPU:
    MSI RTX 2080
    Most Unity games only support borderless and I think the engine doesn't properly support flipmodel either. Meaning DWM handling Vsync which I assume can help attribute to problems in Windows 10. (I haven't tested many in recent memory, but I don't recall ever seeing a Unity game on W10 that doesn't support FSE actually have any tearing because it's always borderless. In that scenario I don't think Scanline Sync would actually help)
    On my W7 machine I almost always have to run Unity games with scanline sync because a lot that i've tried won't allow you to actually force FSE mode and this becomes the only way to get Vsync that doesn't stutter or adds noticeable latency from DWM/Aero.
     
    PapaJohn likes this.
  13. Memorian

    Memorian Ancient Guru

    Messages:
    3,093
    Likes Received:
    245
    GPU:
    RTX 3080
    Unreal Engine stutters too. Very few games are completely stutter-free. RE 2/3 remakes, Forza Horizon 4, DOOM Eternal are some of them. When games start utilizing DirectStorage API, then maybe we won't be seeing stutters anymore.
     
    BlindBison likes this.
  14. artina90

    artina90 Member Guru

    Messages:
    117
    Likes Received:
    38
    GPU:
    RTX 2080Ti
    You can use -window-mode exclusive as a shortcut argument to launch most games in exclusive fullscreen.
    Sadly, as I posted before in this thread, most games seem to have bigger problems that are only fixable by the developers.
    Unity leaves too much in hands of the developers, the engine is not stutter free out of the box.
     
    PapaJohn and BlindBison like this.
  15. tfam26

    tfam26 Master Guru

    Messages:
    236
    Likes Received:
    117
    GPU:
    nvidia 30 series
    Interesting.

    Not likely it would ever happen (?), but would retrofitting RBAR support for Unity solve this?
     

  16. Astyanax

    Astyanax Ancient Guru

    Messages:
    9,531
    Likes Received:
    3,330
    GPU:
    GTX 1080ti
    probably not.
     
  17. BlindBison

    BlindBison Master Guru

    Messages:
    491
    Likes Received:
    78
    GPU:
    RTX 2080 Super
    It's crazy how many garbage Unity games there are in terms of microstuttering behavior -- don't even get me started on how almost none of them have a fullscreen exclusive mode...

    Actually that might be related since windowed mode forces triple buffered "fast sync" which looks very jittery if not at tremendously high framerates (unless you override this with G-Sync ON for windowed mode or some such, but even that I've read elsewhere on this forum can have issues).
     
  18. BlindBison

    BlindBison Master Guru

    Messages:
    491
    Likes Received:
    78
    GPU:
    RTX 2080 Super
    Nailed it, it is insane how many Unreal Engine 4 games on PC microstutter like crazy (have tested the same games on multiple PCs). For example, Outer Worlds has frequent microstutters for me barring an aggressive fps cap of 30 (tested on both an 8700K + 1080 Ti PC as well as a 3900X + 2080S PC). Same thing happens in Arkham Knight which is just a mess even now (constant microstuttering if I don't cap the game externally to around 30 fps). And all of this still happens with G-Sync enabled.

    Even Borderlands 3 microstutters frequently and iirc that's also unreal engine 4. Not sure if it's something to do with the engine being optimized first for consoles, but dang if I haven't had a bad experience with UE4 games on PC.

    Even back in the Unreal 3 days I still see issues like this (Arkham City doesn't run much better than Arkham Knight with frequent microstutters flying through the city even on my 3900X + 2080S + NVMe build). I can pretty much only think of Gears 5 as a decently optimized PC version of an unreal 4 game off the top of my head.

    People talk crap about Cyberpunk's PC performance (not unreal engine obviously), but for me that game has been very "smooth" for the most part/hasn't had a ton of microstutter/has had good framepacing with uncapped fps which has been a dramatic improvement VS many other shoddy PC versions.

    Good example with DOOM Eternal -- that game and its predecessor 2016 are probably the "smoothest"/least stuttery games I've ever played. Very high performance with no microstutters to think of (except perhaps during checkpoints, but that's to be expected seems to me).
     
    Last edited: Jan 14, 2021
  19. haste

    haste Maha Guru

    Messages:
    1,161
    Likes Received:
    352
    GPU:
    GTX 1080 @ 2.1GHz
    This video is full of BS. And don't update your non physics scripts via FixedUpdate();
     
  20. painter

    painter Maha Guru

    Messages:
    1,068
    Likes Received:
    5
    GPU:
    GTX 1060 6GB
    I bought my first Unity based game 'Eastshade' a couple of weeks back, and have found the stuttering to be awful. I've tried all sorts of things, including adding -window-mode exclusive to the launch parameters. Turning off the in game v sync helped with the most serious panning judder, but it still looks a mess when looking around, or panning the viewpoint. I would be reluctant to buy another Unity based game if this is a common problem. Considering it seems to be used by a lot of tiny indy devs, you would think this would be resolved by the Unity devs, or at least give a helping hand the those that use it.
     

Share This Page