Games unplayable after Win10 upgrade (HD8970M)

Discussion in 'Videocards - AMD Radeon Drivers Section' started by kabutoboy, Aug 1, 2015.

  1. kabutoboy

    kabutoboy Member

    Messages:
    14
    Likes Received:
    0
    GPU:
    HD8970M
    1. Yes, it's running in full screen.
    2. Yes, it's on my laptop monitor.
    3. Well, The Sims 4 also runs poorly, even GPU-Z's stress test in fullscreen. And the log says the clock always stays at 300MHz. But I'll try it just to be sure.

    It is MSI Z70 2BA-2291TH (http://notebookspec.com/notebook/6162-MSI-Z70-2BA-2291TH.html)
    And here is CPU-Z's full report (http://pastebin.com/S8sWK4Qj)

    How do you force redetection of GPU? I actually reset Windows from zero though.

    Also, the RadeonPro is all greyed out. Afterburner unadjustable too. Even after I've activated OverDrive via WHQL UnifL (double checked). So I guess it's BIOS-related then?
     
  2. Spartan

    Spartan Master Guru

    Messages:
    676
    Likes Received:
    2
    GPU:
    R9 290 PCS+
    Is RadeonPro detects your HD8970M? You should see it under the OverDrive tab at "Select GPU to be configured". If you can see your card there, then you have to set up profiles for your games to use RP's OverDrive function. To do this click on "Add new profile" at the top of RP's window, select your game's exe (the actual one, not a launcher or something), click on the padlock under the OverDrive tab, hit yes, tick the box "Enable Graphics OverDrive", now you should be able to tick the box next to "Always use highest...".

    Edit: I forgot you should change "32 bit" at the bottom right corner in RP to "32/64 bit" by clicking on it.

    Edit2: ... Make sure you apply the changes after you set the profile.
     
    Last edited: Aug 3, 2015
  3. fez

    fez Master Guru

    Messages:
    208
    Likes Received:
    0
    GPU:
    Club3D Radeon 7870 2gb
    weird, maybe some motherboard drivers are missing ? run Device manager, see if there are some warnings/errors. search button on task bar, type in device manager.
    and you could try out MSI live update program, see if it finds some newer drivers for you. http://download.msi.com/uti_exe/LiveUpdate.zip
     
    Last edited: Aug 3, 2015
  4. isidore

    isidore Ancient Guru

    Messages:
    6,251
    Likes Received:
    36
    GPU:
    RTX 2080TI GamingOC
    did you removed all Intel drivers that are related to the Intel GPU?
    Also check if you have a new bios for your laptop and flash it, but be careful: make sure it's the proper bios and you have the laptop battery charged and mounted (in case of power loss).
     

  5. kabutoboy

    kabutoboy Member

    Messages:
    14
    Likes Received:
    0
    GPU:
    HD8970M
    Here is the in-game screenshot and my settings. Am I doing it right?

    [​IMG]

    By the way I tried removing the WHQL UnifL drivers and let Windows 10 find and install its own drivers. And now the clock runs like a pulse while idle. (See the screenshot)

    There's this one.

    [​IMG]
    I'll try the MSI live update. Thanks.

    Edit: It says the platform doesn't support this application.

    You mean remove Intel drivers but leave the AMD ones there and see how it runs?
    Where should I be looking for my laptop's BIOS? I've never done this before.
     
    Last edited: Aug 3, 2015
  6. Spartan

    Spartan Master Guru

    Messages:
    676
    Likes Received:
    2
    GPU:
    R9 290 PCS+
    Sorry, but I have no idea what's with your HD8970M.
     
  7. fez

    fez Master Guru

    Messages:
    208
    Likes Received:
    0
    GPU:
    Club3D Radeon 7870 2gb
    Ok now we are getting somewhere, it's most probably your graphics driver. Right click and update them manually after u show the pic of your switchable graphics tab and under device manager "display adapters" tab ( there should be 2).

    are you sure you have MSI :D?

    my laptop had the same problem, but those lesh catalyst drivers fixed it for me....long ago tho.
     
  8. isidore

    isidore Ancient Guru

    Messages:
    6,251
    Likes Received:
    36
    GPU:
    RTX 2080TI GamingOC
    1. Yes of course, remove the Intel display driver from control panel Leave only your AMD display driver.
    2. Search your producers website i.e. MSI for your laptop model and go to downloads and check there.
    3. That's normal, as i doubt MSI supports W10 so fast. Like i said W10 drivers should be the best stand.

    Did you tried a clean install and only the AMD driver installed? no other software/drivers from MSI or Intel.
     
    Last edited: Aug 3, 2015
  9. kabutoboy

    kabutoboy Member

    Messages:
    14
    Likes Received:
    0
    GPU:
    HD8970M
    There you go (Note: I uninstalled lesh and used the Windows 10 ones)

    Switchable Graphics Tab (Is this it?)
    [​IMG]
    Device Manager > Display Adapters
    [​IMG]
    AMD
    [​IMG]
    [​IMG]
    Intel
    [​IMG]
    [​IMG]
    GPU-Z
    [​IMG]
    [​IMG]
    CPU-Z
    [​IMG]
    [​IMG]
    [​IMG]

    Still stuck at 300MHz.

    No, I installed Intel driver first then reboot and installed AMD.

    I'll try removing the Intel driver first and see how it goes.

    Thanks a lot guys.
     
  10. isidore

    isidore Ancient Guru

    Messages:
    6,251
    Likes Received:
    36
    GPU:
    RTX 2080TI GamingOC
    Are you sure your laptop is: MSI Z70 2BA-2291TH ? I can't find on MSI's page any Z70 products.
     

  11. kabutoboy

    kabutoboy Member

    Messages:
    14
    Likes Received:
    0
    GPU:
    HD8970M
    Maybe it's only sold in Thailand. So I guess it's not officially supported? Even the officially supported ones still have to wait for official driver and firmware.

    By the way I uninstalled the Intel driver. Not from the Control Panel though. Couldn't find both AMD and Intel there. So I uninstalled from the Device Manager.

    First reboot I got blank screen. So I forced shutdown and start the system again and now it's running. Brightness is unadjustable and I see screen tearing while dragging windows.

    Here is the info...

    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]

    So my guess would be it doesn't even use the AMD card?
     
  12. isidore

    isidore Ancient Guru

    Messages:
    6,251
    Likes Received:
    36
    GPU:
    RTX 2080TI GamingOC
    Yeah most definitely windows does not use your AMD gpu if your windows is acting like it does not have a proper display driver.

    just check th.msi.com and your laptop is nowhere to be found, maybe it's time to contact there support and explain that with windows 10 your amd gpu is not used as primary.

    Also are you sure there's no option in bios to select the primary display adapter ?
     
  13. kabutoboy

    kabutoboy Member

    Messages:
    14
    Likes Received:
    0
    GPU:
    HD8970M
    Here's the post by the verified MSI Thailand facebook page (in Thai).
    And the (kinda) thorough review of the notebook (in Thai).

    And here's all the BIOS settings I could find

    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
     
    Last edited: Aug 3, 2015
  14. fez

    fez Master Guru

    Messages:
    208
    Likes Received:
    0
    GPU:
    Club3D Radeon 7870 2gb
    whats the error on the PCI DEVICE under device manager?
     
  15. Spartan

    Spartan Master Guru

    Messages:
    676
    Likes Received:
    2
    GPU:
    R9 290 PCS+
    Manufacturers should really learn to provide better BIOS imo, I had a very limited one myself on my old mobo, fortunately, my current mobo has a pretty decent one.

    However it still weird to me, every page I found says you should have an R9 M290X 2GB and not an HD8970M.
     

  16. kabutoboy

    kabutoboy Member

    Messages:
    14
    Likes Received:
    0
    GPU:
    HD8970M
    It's Realtek PCIE CardReader. I installed the driver and now it's not showing the error anymore.

    Had that wonder too. According to this, R9 M290X is a rebranding of HD8970M. Maybe my model was the old one. TBH I didn't do quite enough research before buying. Totally my bad. It's been working fine before the upgrade though.

    The only options left seem to be flashing BIOS or wait for the driver update?
     
  17. aaronne

    aaronne Member

    Messages:
    27
    Likes Received:
    4
    GPU:
    MSI 1060 mxm 6GB
    Hi! Before flashing bios (if you haven't problem before the only thing thats change is the UEFI boot compatibility) so

    I would suggest to you to search the windows 8.1 (or 8) driver's from MSI, you need at least the Intel Chipset and Intel iGpu ones anf if present the softwares for the "fn"hotkey and the onscreen display, after that all your settings seems to be fine so its only a drivers related issue (if you have never seen artifacting or glitching screens, but I want to exclude this), for my games I still use 15.6b on Win10 x64(hd4000+7970m here) all the other bring me to StutterFest.
    Remeber to use DDu's cleaner as you ever done.

    Regards
     
  18. kabutoboy

    kabutoboy Member

    Messages:
    14
    Likes Received:
    0
    GPU:
    HD8970M
    Thank you very much. I'll try it and report back the result.
     

Share This Page