Games unplayable after Win10 upgrade (HD8970M)

Discussion in 'Videocards - AMD Radeon Drivers Section' started by kabutoboy, Aug 1, 2015.

  1. kabutoboy

    kabutoboy Member

    Messages:
    14
    Likes Received:
    0
    GPU:
    HD8970M
    After upgrading to Windows 10 my HD8970M is behaving very strangely.

    The Witcher 3 used to run fine before upgrading, but now it can't even run The Sims 4.

    Here's the log while running The Sims 4
    pastebin[.]com/TpnYfCbS

    And here's what GPU-Z says about my gpu
    gpuz.techpowerup[.]com/15/08/01/fyv.png

    I've been searching everywhere and it seems I'm the only one having the problem after the upgrade :(

    Anybody have an idea what might cause it?

    Thanks
     
  2. fez

    fez Master Guru

    Messages:
    208
    Likes Received:
    0
    GPU:
    Club3D Radeon 7870 2gb
    check if your switchable graphics is working (add witcher exe file), seems it uses less powerful one (INTEL). Maybe it doesn't detect it automatically.
    right click on desktop - switchable graphics.
     
  3. Extraordinary

    Extraordinary Ancient Guru

    Messages:
    19,503
    Likes Received:
    1,550
    GPU:
    ROG Strix 1080 OC
    Have you tried reinstalling the GPU drivers?

    Use DDU to remove the old ones in safemode first
     
  4. kabutoboy

    kabutoboy Member

    Messages:
    14
    Likes Received:
    0
    GPU:
    HD8970M
    Yes, I reinstalled it. Didn't fix the problem.

    Turns out fez is right. My computer didn't switch the GPU for me. Although it did before the upgrade. However I reselect the option to High Performance and it's using the HD8970M now. But it's running poorly.

    The GPU Core Clock is locked at 300MHz / 950MHz
    The GPU Memory Clock locked at 150MHz / 1250MHz
    Power consumption is ~70W where it was ~120W before while running games on Win8
    Strangely, the GPU load is 100%

    I had this problem with Win8 too. A sleep or hibernation usually cause it. But after a restart it used to be fixed. Now that only hope isn't working anymore.

    Do you have any idea what might cause it?

    Thanks
     

  5. fez

    fez Master Guru

    Messages:
    208
    Likes Received:
    0
    GPU:
    Club3D Radeon 7870 2gb
  6. gijs007

    gijs007 Active Member

    Messages:
    81
    Likes Received:
    0
    GPU:
    AMD Sapphire R9 290
    I'm having the same issue with a fresh install. It appears that that the dwm.exe is using up to 12% CPU.. Games appear to stutter. (e.g. GTA V)
     
  7. kabutoboy

    kabutoboy Member

    Messages:
    14
    Likes Received:
    0
    GPU:
    HD8970M
    Do I need to uninstall the previous version? Or I just let the WHQL-UnifL do the work?

    Strange. Mine is only using ~0.5%
     
  8. Blackfyre

    Blackfyre Maha Guru

    Messages:
    1,089
    Likes Received:
    73
    GPU:
    RTX 2070 Super
    I have had the exact opposite experience. Every game that had micro-stuttering issues under Windows 7 & 8.1 has been running very smoothly and with higher framerates under W10.
     
  9. kabutoboy

    kabutoboy Member

    Messages:
    14
    Likes Received:
    0
    GPU:
    HD8970M
    After downloading and extracting the WHQL UnifL,
    I installed it everyway I could.

    1. Installed it right away without removing the previous drivers, overriding both AMD and Intel. Brightness was unadjustable. Didn't fix the throttle problem.
    2. Uninstalled AMD and Intel drivers (WHQL UnifL). Installed both from WHQL UnifL again. Didn't fix the throttle problem.
    3. Tried installing Afterburner to manually adjust the clock. Everything was unadjustable (e.g. Power Limit, Core Clock, Memory Clock).So I googled this another problem and tried
    4. Uninstalled Afterburner and AMD drivers (WHQL UnifL). Reinstalled WHQL UnifL AMD drivers. Reinstalled Afterburner. Activate Overdrive using UnifL Tools. Still not able to adjust the GPU and the throttling still exist.

    What could have been the problem here?

    I'll never buy AMD again
     
    Last edited: Aug 2, 2015
  10. fez

    fez Master Guru

    Messages:
    208
    Likes Received:
    0
    GPU:
    Club3D Radeon 7870 2gb

  11. isidore

    isidore Ancient Guru

    Messages:
    6,263
    Likes Received:
    51
    GPU:
    RTX 2080TI GamingOC
    I love how people always blame AMD even though you are gaming on a laptop and windows 10 so there could be a lot of other reasons why your gpu is not utilized 100%.
    So before jumping to conclusions do:

    1. a bios restore to factory and set the amd gpu as primary card.
    2. second put the gpu un full power mode, no power saving crap.
    3. third be sure your laptop drivers support windows 10 and it's features, i recommend removing all the laptop drivers and let windows 10 use it's default ones, most likely they are newer then what you can get from the producers page atm. I had a similar problem with my asus rog when i went to windows 8.1, at the time there where no drivers/software for my power management application and the one i had installed was not compatible with windows 8.1, gpu was running in 2d mode even thought my windows settings where to full power mode. Issues got fixed as soon as i removed the old asus rog drivers.

    Cheers.
     
  12. kabutoboy

    kabutoboy Member

    Messages:
    14
    Likes Received:
    0
    GPU:
    HD8970M
    Oh, I forgot to add. I did use DDU in every step. Unfortunately it still didn't fix the problem. Thanks for the notice anyway :)

    I'm sorry I said that. I'm not quite knowledgeable in these fields.

    1. How exactly do I do that? For the record, there's no GPU-related options in my BIOS.
    2. Yes, it's on the full power mode. But the clock's still locked.
    3. This seems like it should work though. I'll try it and report back right away.

    Thanks!
     
  13. fez

    fez Master Guru

    Messages:
    208
    Likes Received:
    0
    GPU:
    Club3D Radeon 7870 2gb
    what do you mean "didnt fix throttle problem". You have to still set the exes manually and then try if the graphics runs good.
     
  14. kabutoboy

    kabutoboy Member

    Messages:
    14
    Likes Received:
    0
    GPU:
    HD8970M
    I mean that the Core Clock is still locked at 300MHz and Memory Clock at 150MHz.

    And yes, I've set the exe's manually to High Performance but the GPU just won't run at its full speed.
     
  15. Spartan

    Spartan Master Guru

    Messages:
    676
    Likes Received:
    2
    GPU:
    R9 290 PCS+
    If I were you I would try RadeonPro, it has an option in it's OverDrive tab: "Always use highest performance clocks while gaming". However, I don't know if this can help you or not.
     

  16. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    7,465
    Likes Received:
    495
    GPU:
    Sapphire 7970 Quadrobake
    I have a very very weird problem with Assassin's Creed Unity. The game runs MUCH faster on Windows 10 (talking about 10-20% faster and more at times), BUT sometimes it will bug out and it will reduce the framerate to half. I have tested it repeatedly. Places that would have 50-55fps would barely get 25. I haven't managed to find what triggers it. It's not VSYNC, and it's not the framelimiter from RadenPro. It's not the fullscreen or bordereless mode. I have noticed in general that there might be an issue with some titles and double or triple buffering in Window 10. Vsync is not working at all in AC Unity for example.

    Does anybody have similar experiences?
     
  17. kabutoboy

    kabutoboy Member

    Messages:
    14
    Likes Received:
    0
    GPU:
    HD8970M
    Alright so I tried removing the laptop drivers but no luck. Then I tried resetting the Windows using the second option(Clean drive C). And after waiting for hours, first thing I do was installing WHQL UnifL drivers. Made sure every settings is set to High Performance. Still no luck. Haven't tried the RadeonPro though. Tomorrow I'll give it a try. Thanks for your help guys. I appreciate it.:) Will update the thread tomorrow.
     
  18. fez

    fez Master Guru

    Messages:
    208
    Likes Received:
    0
    GPU:
    Club3D Radeon 7870 2gb
    probably because of processor. Try control panel power to high perf.
     
  19. isidore

    isidore Ancient Guru

    Messages:
    6,263
    Likes Received:
    51
    GPU:
    RTX 2080TI GamingOC
    well this is weird as fock. From what you are saying your gpu refuses to go in 3d mode which is why i still think it's a power management problem somewhere.
    Though it shouldn't make any difference make sure:
    1. games run in full screen
    2. you are gaming on your laptop monitor and not an extended monitor/tv
    3. also run some bechmarks, like 3dmark or other games see if this is not a one game issues.

    Also care to say what laptop brand and model you have?
     
    Last edited: Aug 2, 2015
  20. sammarbella

    sammarbella Ancient Guru

    Messages:
    3,929
    Likes Received:
    178
    GPU:
    290X Lightning CFX (H2O)
    I had more problem than usual when i installed 15.7.1 drivers version.

    I had to unninstall Afterburner completely (inlcuding profiles) before new drivers install and reinstall it after reboot.

    After AB install and run i had to reboot to let it detect GPU values, if not GPU clocks remain always locked at lower power state (2D).

    Try deleting AB profiles folder and force redetection of GPU values until you see normal power state in GPU-Z.
     

Share This Page