1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Games hitching in Windows 10 but not 7 - help needed :)

Discussion in 'Operating Systems' started by PapaJohn, Aug 26, 2016.

  1. PapaJohn

    PapaJohn Member Guru

    Messages:
    173
    Likes Received:
    6
    GPU:
    GTX 1080 FE
    Hi, I have low end hardware so I'm realistic about what I can run and at what sort of detail but I appear to have an issue running any games smoothly on Windows 10 whereas on Windows 7 those same games run absolutely fine and I'm hoping that with your help I can get to the bottom of it.

    I'm dual booting both 7 and 10 from the same SSD with a slow ass 1Tb Caviar Green holding my games (Parking altered to 300 seconds from the default 8)

    I'm currently running the same OLD gfx driver 347.25 on both 7 and 10 for consistency in my testing but it's important to note that I have tried with the very latest driver on 10 with exactly the same results (even after using DDU)
    Chipset drivers have been installed automatically for both but 7 does not install Intel Management Engine and as os is running smoothly in games I have left it alone.

    Windows 10 is the anniversary edition from a clean install and shows no resource violations when I run an sfc/scannow check.

    I don't bluescreen on 10, it runs edge/youtube/internet browsing just fine bar the existing bugs it is purely just games that seem to have a hitching issue.

    A prime example, the old unity game "Rochard" has hitches at specific points on it's levels whilst playing on 10. On 7 these same hitches are nowhere to be seen - again, using the same hardware and graphics driver. And this is the same story again and again across all titles. 10 hitches at points, 7 runs things smoothly within the restrictions that the old hardware allows. Even hearthstone has stutters and delays on windows 10 whereas again on 7, it's a flawless experience as you would expect from a 2D card game.

    The graphics card appears to be hitting the same clocks in both os and the CPU does not display any issues either.

    Really interested in your thoughts and hope to gain some insight as to what is going on here. Thanks
     
  2. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    15,742
    Likes Received:
    317
    GPU:
    EVGA GTX 1080 Ti SC2
    Hitching and stuttering in games can be extremely annoying, more so if the game was previously running fine then isn't after an upgrade.

    Windows 10 will have different background processes to 7 and may have even configured your pagefile differently. I would suggest trying setting the pagefile to a fixed size on your SSD and disable the one on the slower hard drive and see if this improves things.

    I would also check what stuff is running in the background while playing the game. Try doing a clean boot with everything disabled at bootup except for the Microsoft services. Also, disable any anti-virus etc software that might be running (and add exceptions to them so they doesn't scan the folders where your games are). You can re-enable stuff one at a time and test the games to see if a particular one might be causing the issue on your system.
     
  3. primetime^

    primetime^ Master Guru

    Messages:
    894
    Likes Received:
    12
    GPU:
    XFX Radeon RX580
    Sounds like some kind of nvidia driver issue to me. You should always try to run the newest driver available for your card in most case anyway! You can also try adjusting settings in your power profile and set cpu to max performance. Every once in a while, you end up with a cpu that doesn't turbo properly when the game needs max performance!
     
  4. mbk1969

    mbk1969 Ancient Guru

    Messages:
    7,492
    Likes Received:
    4,029
    GPU:
    GeForce GTX 1070
    Did you check the power mode in NV CPL? What if it differs in Win7 (say adaptive) and Win10 (say optimal power)?
     

  5. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    15,742
    Likes Received:
    317
    GPU:
    EVGA GTX 1080 Ti SC2
    The Shader Cache under NVIDIA control panel > Profile settings has been know to cause issues with some games so it might be worth turning that off if setting maximum performance as mbk1969 suggests does not work.

    Also, I would suggest installing the latest chipset drivers manually, reinstalling the driver clean after using DDU to remove it and even try reinstalling the DirectX 9.0c Redistributable (since it has components older games might need and isn't installed by default on Windows 10, or so I've read but don't quote me).

    Make a system restore point first though before changing anything.
     
  6. PapaJohn

    PapaJohn Member Guru

    Messages:
    173
    Likes Received:
    6
    GPU:
    GTX 1080 FE
    OK thanks guys for your input so far.

    I have clean reinstalled both 7 and 10, dual booting from the SSD for the os's. Games are running from the 1tb Caviar Green.

    Chipset drivers are the default ones installed with both os's.

    I'm now running the latest Nvidia driver on both systems for a consistent platform from which to diagnose issues.

    The trouble with updating chipset drivers is that the motherboard/processor is that old I have no clue which ones are the latest, compatible ones to use. I'm hesitant to even change any at all on Windows 7 as it runs perfectly fine.

    10 is the problem. The pagefile it uses as default is a lower size than 7 but it never gets touched/resized/altered throughout any attempts to game on it so I really don't think that's the issue.

    EDIT - Does anyone have an idea on which chipset drivers and Intel Management Driver I should be installing for my setup on a Windows 10 computer?
     
    Last edited: Aug 27, 2016
  7. Agent-A01

    Agent-A01 Ancient Guru

    Messages:
    11,351
    Likes Received:
    881
    GPU:
    1080Ti H20
  8. TheRyuu

    TheRyuu Member Guru

    Messages:
    107
    Likes Received:
    0
    GPU:
    EVGA GTX 1080
    This is unlikely to change anything at least the pagefile stuff isn't. You can pretty safely leave that thing on default.

    It may just be the older hardware not running very well on Windows 10. That being said W10 shouldn't really be that much more demanding (if any). I can't remember how much RAM Win7 used but W10 might actually use less.
     
  9. primetime^

    primetime^ Master Guru

    Messages:
    894
    Likes Received:
    12
    GPU:
    XFX Radeon RX580
    About the ram yes and No......If your pc has extra ram win 10 will use MUCH more ram than 7. But yea it uses it sparingly if your pc has a low amount.Its kinda cool how it does that! OP probably just needs to set his power saving to high performance is my guess!
     
  10. PapaJohn

    PapaJohn Member Guru

    Messages:
    173
    Likes Received:
    6
    GPU:
    GTX 1080 FE
    OK for now I seem to have sorted it by using the NVidia driver installed automatically with 10. Any newer or older ones seems to cause hitching.

    Windows 7 appears to work fine with any Nvidia driver.

    Thanks for the help guys, I'll update if anything changes or I face any more issues :)
     

Share This Page